Virtual PC 2004 Debian setup of X

I'm having the most difficult time trying to get X Windows running under Debian.  I installed Debian using a Debian DVD image I downloaded about a month ago.  All went well enough, if not a little slow.  I then ran "apt-get install x-window-system" and X downloaded and installed.  Great.  Now I tried starting x.  No luck.  The Virtual PC screen expands to fill the width and about 2/3 the height of my notebook's 1600x1200 display and then the window effectively freezes (no graphical display or movement - I can CTRL-ALT-Backspace back to a console prompt, and try fiddling with the XF86Config file (as I've now done MANY times) but nothing I've tried has resolved this.

I have also done an apt-get upgrade x-window-system and there's nothing left to get - I'm all up to date.

In my own research I've found several references to particular settings - and I've tried incorporating them, but with no luck.  Among my attempts I tried using an XF86Config file from someone's virtual PC install of RedHat 9 - but that didn't work.  I've tried incorporating the settings found here:
http://blogs.msdn.com/dparys/archive/2004/03/18/91766.aspx
but that didn't work.  I'm really at a loss for the moment.  I'd love it if someone could send me their XF86Config file that is known to work under Debian/Virtual PC 2004 so I could try it.  

For those who would like to help but don't have Virtual PC, it's available for a 45 day trial from M$ - see http://www.microsoft.com/windows/virtualpc/default.mspx

I have placed copies of my XF86Config files (I have 3 different ones I've tried) and the log files from XF86 stored in the syslog folder into a tar file and placed that on my web site - see http://www.leewilbur.com/XF86Confs.tar for the file.

Thanks
LVL 97
Lee W, MVPTechnology and Business Process AdvisorAsked:
Who is Participating?
 
gheistConnect With a Mentor Commented:
What does log say when you remove or move away /etc/X11/XF86Config-4  ???
XFree86 is usually inteligent enough to detect supported hardware for maximum resolution.
If this does not work add option "NoAccel" "true" to your video card definition in this file

For example I do not like these which look like some inconsitencies in auto-generated config or installed library set:
(1)
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found

(2)
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found
0
 
gheistCommented:
(2)
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
0
 
Lee W, MVPTechnology and Business Process AdvisorAuthor Commented:
Excellent - the -4 file was causing the problem.  I renamed that and there was a working X window environment - using "twm" manager.  I'll install my preferred desktop environment - KDE (and hopefully figure out how to get that to be my default Window Manager.

Thanks
0
 
gheistCommented:
Basically you run kdm instead of xdm , and startkde instead of startx.
XDM configs are copied form /usr/X11R6/lib/X11/xdm/ to /usr/local/share/config/kdm/, so you need to edit in two places :-(

Thanks again for not posting whole XFree86 config and log.

run XFree86 -config to save this running config.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.