Solved

Site to site Pix 501 (PPPoE) to Pix 506E (Static)

Posted on 2004-09-03
2
1,242 Views
Last Modified: 2011-04-14
I put 500 points for this, only because the customer thinks EVERYTHING computer related takes 15 minutes.  Sigh.  Needless to say I've spent considerably more.

Site in DC is main office and has a Pix506E.  We've used it to connect VPN clients before, though I don't need to do that anymore.

Site in San Fran is remote office and has a new Pix501.  Can ping it from anywhere.  I need a site to site VPN between these offices.

I've checked similar topics on here and scoured the web and Cisco's site to no avail.  And here's the really weird thing.  When I'm on the network in DC, I can't ping SF.  However, if I leave ping running in DC and check the SF pix's access list 90 for interesting traffic going OUT, I see it incrementing steadily.  No one is in the office in SF and there's nothing but a printer there that I'm pinging.  So why can't I see the response?  I also tried telnetting to the printer on port 9100, no luck

I know you'll want to see the configs, so here they are.  TIA.

Washington DC Pix

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxx encrypted
passwd xxx encrypted
hostname fire
domain-name xxx.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 69.xxx.xxx.46 SF-Outside
name 10.0.0.0 DC-Inside
name 192.168.50.0 SF-Inside
access-list inside_access_in remark Ping outbound
access-list inside_access_in permit icmp any any
access-list inside_access_in remark Outbound allow
access-list inside_access_in permit ip any any
access-list outside_access_in permit icmp any any
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq smtp
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq www
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq pop3
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq 6801
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq 5531
access-list outside_access_in permit udp any host 65.xxx.xxx.186 eq 5532
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq nntp
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq https
access-list outside_access_in permit tcp any host 65.xxx.xxx.186 eq 3389
access-list 90 permit ip DC-Inside 255.255.255.0 SF-Inside 255.255.255.0
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 65.xxx.xxx.187 255.255.255.248
ip address inside 10.0.0.10 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool remote 172.16.1.1-172.16.1.254
pdm location 10.0.0.10 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 65.207.15.188
nat (inside) 0 access-list 90
nat (inside) 2 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 65.xxx.xxx.186 10.0.0.8 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 65.xxx.xxx.185 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
http server enable
http DC-Inside 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set strong esp-des esp-sha-hmac
crypto map toSF 30 ipsec-isakmp
crypto map toSF 30 match address 90
crypto map toSF 30 set peer SF-Outside
crypto map toSF 30 set transform-set strong
crypto map toSF interface outside
isakmp enable outside
isakmp key ******** address SF-Outside netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 30 5
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet DC-Inside 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 30
management-access inside
console timeout 0
dhcpd address 10.0.0.100-10.0.0.199 inside
dhcpd dns 10.0.0.10
dhcpd wins 10.0.0.10
dhcpd lease 14400
dhcpd ping_timeout 750
dhcpd domain ftllaw.com
dhcpd option 3 ip 10.0.0.10
dhcpd option 48 hex 08
terminal width 80
Cryptochecksum:xxx
: end


San Francisco Pix

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxx encrypted
passwd xxx encrypted
hostname sanfranpix
domain-name xxx.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.0.0.0 DC-Inside
name 192.168.50.0 SF-Inside
name 65.xxx.xxx.187 DC-Outside
access-list 90 permit ip SF-Inside 255.255.255.0 DC-Inside 255.255.255.0
access-list outside_access_in permit icmp any any
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.50.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location DC-Inside 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 90
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
http server enable
http SF-Inside 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-des esp-sha-hmac
crypto map toDC 30 ipsec-isakmp
crypto map toDC 30 match address 90
crypto map toDC 30 set peer DC-Outside
crypto map toDC 30 set transform-set strong
crypto map toDC interface outside
isakmp enable outside
isakmp key ******** address DC-Outside netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 30 5
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet SF-Inside 255.255.255.0 inside
telnet timeout 5
ssh timeout 30
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname xxx@sbcglobal.net
vpdn group pppoe_group ppp authentication pap
vpdn username xxx@sbcglobal.net password *********
dhcpd address 192.168.50.100-192.168.50.131 inside
dhcpd dns 206.12.28.12 206.13.31.12
dhcpd wins 10.0.0.7
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain xxx.local
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:xxx
: end
0
Comment
Question by:SumaMike
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
Comment Utility
One issue is that you are using the same acl 90 for two separate processes. This is certainly in the configuration examples from Cisco website, but is not recommended practice.

>access-list 90 permit ip SF-Inside 255.255.255.0 DC-Inside 255.255.255.0
>crypto map toDC 30 match address 90
>nat (inside) 0 access-list 90

Could be:

   access-list 91 permit ip SF-Inside 255.255.255.0 DC-Inside 255.255.255.0
   crypto map toDC 30 match address 91
   
   access-list 90 permit ip SF-Inside 255.255.255.0 DC-Inside 255.255.255.0
   nat (inside) 0 access-list 90


Everything else looks fine.
 From either end, what do you see with "sho cry is sa" ?
 Looking for QM_IDLE

Next issue is routing. Can I assume that the default gateway setting on the SF printer that you are pinging is set to the PIX inside interface? Does it get it's IP address information from the PIX via DHCP? Does it get the correct subnet mask?

Next potential issue is subnet mask mismatch somewhere....outside the PIX




 
0
 
LVL 1

Author Comment

by:SumaMike
Comment Utility
Damn!  I hate when it's a stupid simple networking issue.  Yes, everyone turned their computer off, so I used the only thing left, a printer.  And of course, when I asked my engineer if he configured the printer with a gateway, no dice.  Once I got some real computers back on, it worked great.  Thanks for the help
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now