• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5520
  • Last Modified:

disabling microsoft-ds

According to netstat my computer is listening on a port that is associated with "microsoft-ds". Since this presumably is need only for using windows network neighborhood, and I don't use network neighborhood, I would like to disable this service. How can this be done?

Thanks.
0
bobwood2000
Asked:
bobwood2000
  • 2
1 Solution
 
adamdrayerCommented:
is it port 445?

http://www.petri.co.il/what_is_port_445_in_w2kxp.htm

excerpt:
How to disable port 445?
You can easily disable port 445 on your computer. To do so follow these instructions:

Start Registry Editor (Regedit.exe).

Locate the following key in the registry:

HKLM\System\CurrentControlSet\
Services\NetBT\Parameters

In the right-hand side of the window find an option called TransportBindName.

Double click that value, and then delete the default value, thus giving it a blank value.

Close the registry editor.

Reboot your computer.

After rebooting open a command prompt and in it type

netstat -an

See that your computer no longer listens to port 445.

0
 
bobwood2000Author Commented:
Can I avoid modifying the registry if I just disable some service from starting automatically when windows starts?
0
 
adamdrayerCommented:
umm,  try the computer browser. but that's just a guess.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now