?
Solved

D-Link Routers on University LAN

Posted on 2004-09-04
15
Medium Priority
?
378 Views
Last Modified: 2013-11-29
Our school has instituted a new registration process. Anytime a new MAC address is detected on the network, that person is automatically directed to the school's registration page. So you register and in a minute or so have access to the internet. I don't like it.

Anyway, I'm used to having a router to protect my computers and host additional things such as network cameras in my room. I can't seem to get this router picked up by the network. I have changed the MAC address to match that of a registered computer on the network to no avail. The router is a DI-524, and maybe it's just that version that won't work.

Any help would be much appreciated.
0
Comment
Question by:Avalerion
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
15 Comments
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11981194
You need to talk to the folks who run the campus network.

If you were on the campus where I work, I'd check the posted policy to see whether I'm supposed to help you make it work, or cut off your Internet privileges for plugging in an unauthorized piece of network gear.

0
 

Author Comment

by:Avalerion
ID: 11981320
There is no official policy on equipment, nor will they help.
The school's OIT is as dumb as you can get, except for the few guys that run the whole thing.
Therefore I would not ask them to help with it.
It's pretty much impossible to get to them.

The situation seems pretty clear, but I do not see why the MAC (changed) on the router can't be picked up by the school. No WAN light ever comes on the router.
0
 
LVL 6

Expert Comment

by:icemanwol
ID: 11981620
ok, 2 things, the MAC address you are trying to use on the router for MAC address cloneing, is it the same one as the network card that is plugged into your computer?  If it is, you need to change out your network card and put in a diffent network card into the computer.  You cannot have 2 of the same MAC addresses so this is why this is needed.  If you are useing a network card with a diffent MAC address then the routers that you changed it to, Make sure your router is on DHCP and is not useing the same ip address range for the internel and externel network (like 192.168.1.122 is a school assianed address and your address is 192.168.1.133).  As a last resort, i would try flashing the router to the latest firmware, you can get that from here:    http://support.dlink.com/products/view.asp?productid=DI%2D524
Hope this helps
0
Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

 
LVL 79

Expert Comment

by:lrmoore
ID: 11981796
>No WAN light ever comes on the router.
This is the fundamental problem. Until you can resolve this, nothing else will matter.
You probably need a crossover Ethernet cable between the LAN port in the room and the WAN port of the router, not a standard Ethernet cable.
0
 
LVL 4

Expert Comment

by:HackLife
ID: 11981978
Have you tried attaching the school network port directly to your computer port and see if you can get connected? This will eliminate the possibility that you have no network connection, including any port and cable faults.

If this works, and you plug your router back in, does any light show up?

If your router does get power, I would say it's down to your WAN port. A shorted port is a possibility.

Happy troubleshooting.
J.Nguyen
0
 

Author Comment

by:Avalerion
ID: 11982743
A crossover ethernet cable would not work. I use a patch cable to connect my pc to the jack, and the computer connects fine.

The day before I moved into school and used the router, it was working fine managing a connection via my Comcast cable modem. No problems. The WAN light worked fine.

It's just odd that it doesn't light up at all, even though the connection is fine.
This leaves the possiblility of it actually shorting out, as mentioned previously.

It doesn't make sense however. One day it's fine, the next it goes out? I've dealt with tons of different routers, with D-Link being some of the best. I'm just wondering if the school network can detect that it's not a standard pc... and if it doesn't, maybe I can open certain ports on it (plus respond to pings) that may make it seem as if it were a PC.

Any other ideas?
0
 

Author Comment

by:Avalerion
ID: 11982746
Also, when you clone the MAC of a PC on the network to the router, both devices work perfectly fine even though they have the same MAC.
0
 
LVL 2

Accepted Solution

by:
jasperomalley earned 750 total points
ID: 11984734
I doubt OIT has configured their switches to deactivate ports with routers (rather than PCs) connected to them, it's just not that easy to do reliably; if they're as clueless and/or understaffed as you think they are, it's an even less likely possibility.

It's possible your cable modem had an MDI/MDI-X autosense feature, which allowed you to use either a straight-through or a crossover cable for the connection between it and the D-Link router. Try the crossover cable, and if still doesn't work, try using a new straight-through patch cable (or test the patch cable with your PC again, to make sure it's still good).
0
 
LVL 4

Expert Comment

by:HackLife
ID: 11984924
You have no network connection to the school, or it is deactivated. Your line may not be activated. If I am wrong here, you should check if your ports by bypassing the router and plugging your computer's NIC directly.This will narrow the problem down to your router or your drop.
0
 
LVL 4

Expert Comment

by:sloopeth
ID: 11990443
why not just tell them the MAC address of the router WAN port?
0
 

Author Comment

by:Avalerion
ID: 11990520
Because I can clone it to match my PC... I'm also not interested in letting them know a wireless router is set up in the dorms.

I'm going to try some new suggestions tommorrow, including using a different router.
The network connection is fine. It's just the WAN port seeming to have a problem.
I want to see if it's an isolated case, or what the admins are doing.
0
 
LVL 17

Expert Comment

by:RDAdams
ID: 11993322
Just a note avalerion, the crossover cable may help.  If your router does not automatically crossover when hooked as an uplink then it is required.
0
 

Author Comment

by:Avalerion
ID: 11993347
I'll try the crossover and then a different router. Hopefully it will work... otherwise I'll go crazy on the network admins.

Last year I had my wireless router hooked up to the jack just fine with a patch cable. Worked great all year.

This year when they instituted the NetReg (MAC Registration thing) the router suddenly doesn't work as well.

Anyway, I appreciate all the help. I'm going to try your ideas when I get back tommorrow and I'll let you know what happened.
0
 

Author Comment

by:Avalerion
ID: 11998004
I swapped the router out to a DI-624, which worked flawlessly on the network.

I guess some WiFi routers act different...
0
 
LVL 4

Expert Comment

by:HackLife
ID: 11998677
I dissagree to the points given. No offense to jasperomalley, but how does his answer and switching out the router relate? I think I was the only one that suggested bypassing the router, and not changing out the cable to configuration.
0

Featured Post

Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question