Solved

SuSE 9.1 hangs during installation

Posted on 2004-09-04
11
391 Views
Last Modified: 2010-04-20
I'm trying to install SuSE 9.1 personal onto an old PC. I'm doing an install from CD, using a disk burned from the .iso image from ftp.suse.com. The installation is basically standard (boot from CD, graphical installation, install media=CD), except that I'm using a software RAID-5 drive as the root filesystem. I have 3 40GB maxtor IDE drives, each partitioned with a 256MB partition at the front of the disk, and the rest of the space used in the RAID. On one of the disks, the small partition is /boot, on another it is swap, on the third it is unused.

The problem is, at some point during the installation of packages, the installer mysteriously hangs. Files stop copying, but the system hasn't actually crashed - the mouse cursor is still animated, I can use the keyboard to change the focus, but no more progress is made copying the files, and I can't seem to abort the installation. This happens apparently at a random point during installation - sometimes after only 3%, sometimes after 75%, an it isn't always the same package that causes the hang.  Another peculiarity is that the "estimated time remaining" is always 2 hours exactly - I don't know if this has anything to do with the problem or not.

I've tried "safe mode" install, normal install and "manual" install, all with the same result. I'm not ruling out a hardware failure here, as the MoBo, processor and RAM are both pretty old (Gigabyte G5AA, K6-2 500mhz, 32MB + 128MB PC100), but the disks are brand new, and so is the CD drive I'm installing from. I've also checked the .iso file against the MD5, and it is intact.

Does anyone have any idea what's going on here? Is it possible that I'd have more luck with a network install? Text-mode install? Is there a way to get YAST to write a log somewhere, so that I can investigate what causes the hang?

Thanks in advance,
Misha
0
Comment
Question by:mishagale
11 Comments
 
LVL 40

Expert Comment

by:jlevie
Comment Utility
This sounds similar to what I've seen on an older 500Mhz AMD system with Fedora Core 2. The installer would walk off into never-never land. It didn't crash or emit any sort of errors. Installing over the network worked, so I presume it was some deadlock between reading from the CD and writing to disk. Dunno if the same technique would work in your case, but it's worth a try.
0
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 250 total points
Comment Utility
You need at least 256MB for a graphical install using YaST2. You could try to do a manual installation with the text interface to YaST2. Or, just add more memory to the machine (at least during the installation).
0
 
LVL 36

Expert Comment

by:grblades
Comment Utility
I agree that it is probably a memory issue. During installation there is no swap partition active so if you run out of memory the system can crash or hang.

With Fedora FC2 if you install and it detects you haven't much memory it will prompt you abd activate the swap partition early so it can install.
0
 
LVL 2

Author Comment

by:mishagale
Comment Utility
I have no problem with the text interface, so I'll try that, since I don't have any sticks of compatible memory lying around. I'd activate the swap partition manually, except that for some reason I can't switch virtual consoles. Failing that, I'll set up a local ftp server with the files from the CD, and try that. Will let you know if I have any luck.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 17

Expert Comment

by:owensleftfoot
Comment Utility
Whenever the install fails, switch to alternate consoles by pressing ctrl+alt +Fx where x = a number between one and 12. In other words ctrl+alt+F1 would take you to the first console. During an installation different information is logged to different consoles. It may show you why the install is failing.
0
 
LVL 2

Author Comment

by:mishagale
Comment Utility
Ok, I'm still stuck.
Niether a text-mode install, nor a "safe" install (ACPI and DMA turned off) prevent the installer from crashing. I have tried an FTP install, but unfortunately, my network card is not recognised. It is a Netgear FA311, for which there isn't a driver in YAST - there may be a driver on the "modules" floppy, but I didn't bother to install a floppy drive in the machine, and I don't think I have one spare anyway. I have drivers on a CDROM from netgear, but they are in source form, and need compilation.

My next thought was that a hard disk installation might be successful, so I used the "rescue system" to copy the contents of the CD to my RAID, which was no trouble. Unfortunately, YAST seems unable to recognise /dev/md0 until after the installer has started, when it is too late to change the source medium. If no one knows how to make this work, I'll repartition so that I have a non-RAID filesystem large enough for the contents of the CD.

I still have no idea as to the cause of the crash (I can't switch virtual consoles once it has stopped responding), but I'm pretty sure the hardware is sound, since the machine never crashes while I'm using it in rescue mode, or before the file copy stage of installation.

If no one has any bright ideas, I guess I'll have to try a different distribution. It's a shame, because apart from the installer, I rather like SuSE.
0
 
LVL 40

Expert Comment

by:jlevie
Comment Utility
> I'm pretty sure the hardware is sound, since the machine never crashes while I'm using it in rescue mode

That's not a safe assumption. The rescue mode boot is using a stripped down kernel with most things disabled. Usually all that gets enabled in rescue mode is the keyboard, text mode video, and disk. The installer also uses a stripped kernel, but it may enable drivers for NIC's that it finds. Additionally, the installer will be doing lots more compute work and much greater amounts of disk I/O. So a small fault in the system that kills the installation might not show up in your use of rescue mode.
0
 
LVL 2

Author Comment

by:mishagale
Comment Utility
jlevie: Agreed. The CD has a memory test utility, which I figure will show up any errors with the RAM, or CPU. Can anyone recomend me a utility to test the rest of the system, particulary the IDE controller?
0
 
LVL 40

Assisted Solution

by:jlevie
jlevie earned 250 total points
Comment Utility
You might want to try a memtest86 run on the machine (http://www.memtest86.com/). If there are any memory, cache, or certain processor faults it should find them.

When you did the install in text mode were any errors reported or did the box just hang? If it just locked up I'd be suspicious of some sort of DMA/chipset/disk/CD problem. Sometimes those sort of problems can be cured by updating the system BIOS to the latest version. For old motherboards it can be a problem to find a later BIOS. But if it was from a major vendor they may still have the BIOS & flash utility available for download.

Another thing you can try is to strip the system down to essentials, meaning that only the video card is installed/enabled. NIC's, sound cards, etc should be removed or disabled (if they are on-board).
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now