Outlook Connecting to Exchange 2003 over RPC HTTPS, Can I save my password so the domain box stops popping up each time I start outlook?

Hi,

Finally got Exchange 2003 configured to use RPC over HTTPS so clients do not have to VPN in. I have outlook 2003, WinXP SP2, and have set it up such that I can access my exchange mailbox using RPC over HTTPs. Everything's working fine--however there is one slightly annoying issue. Every time I start Outlook, I am confronted with the domain login box, prepopulated with the DOMAIN\USERNAME in which I have to enter in my password. Can this be made to go away? There is no option to save my password (at least not in this domain prompt).

The email account settings box under user authentication "always prompt for username and password" is unchecked.

Any ideas?

Jay
jbregAsked:
Who is Participating?
 
SembeeCommented:
RPC/HTTP is designed to be used in a domain environment as an alternative access method. If the machine is a member of the domain then the username/password is not prompted for each time.
If the machine isn't a member of the domain, then as others have said above, I would be very concerned if the ability to save the password was provided and would be looking for a way to disable it. A machine that isn't part of the domain is out of our control.
I actually don't allow RPC/HTTP to be used on non-domain machines for the sites that I manage and this has kept the security in place.

Simon.
0
 
stefriCommented:
i am afraid this behaviour is by nature
stefri
0
 
jbregAuthor Commented:
Do you have any resources or documentation on this? It seems very strange that it does not allow these logins to be stored, when it does for every other messaging type and most domain popups elsewhere...

Is there a workaround?

Jay
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
jaycaCommented:
No workaround, this is for security reasons.

As a person who supports Exchange, I would be very upset if they did allow that.  
0
 
jbregAuthor Commented:
Not that I don't trust you, but is there some documentation or resource which I could use to learn more about this?

Is this the configuration you would reccomend for end-users, notwithstanding the fact that it is marginally cumbersome?

Jay
0
 
SembeeCommented:
Is the machine with Outlook installed a member of the same domain as the Exchange server?
If so, then the constant prompt for username/password is not normal. Pass through authentication should work. Having implemented a number of RPC/HTTP implementations if there was a constant username/password prompt for clients on the domain/network then the service wouldn't be implemented.

If it isn't then the password prompt is correct as pass through authentication cannot work.

Can you confirm which it is?

Simon.
0
 
jbregAuthor Commented:
Simon,

No. I suppose I could do this, though, but then I'd have to configure my router at home to persistently vpn into our sonicwall. This machine is mine at home and is not on our domain.

Jay
0
 
SembeeCommented:
If it isn't on your domain then the password will not be saved. That is by design.

Simon.
0
 
jbregAuthor Commented:
I understand this, I suppose, but from an end-user perspective it really sucks having to input your password each time you open outlook. I thought one of the chief benefits of an RPC over HTTPS implemenation was the avoidance of extra, cumbersome steps like VPNS...

Jay
0
 
cj52973Commented:
RPC/HTTP is designed to allow connectivity to Exchange without the need for a VPN.  If you are using Basic authentication you will see a log-in box each time you attempt to connect to Exchange.  This box will also not have an option to save the password and is very annoying.  Try using NTLM.

This requires NTLMv2 (NAT Friendly) so you have to be running Windows 2000 or higher with Outlook 2003.  
Set your RPC proxy to utilize windows integrated authentication.  
Set you client to utilize NTLM.
See http://support.microsoft.com/default.aspx?scid=kb;en-us;820281 for client side registry edit I set mine to 3.
Try it you should be able to save your password and it will work just fine.  
If not or if not a domain machine try using Run – cmd - control keymgr.dll to create a keychain for the server you are connecting to.  I’ve used the keymgr.dll to set the auth for my SPS and OWA site too.

Use the format username@domainname.com to login

On another note MS could have added the ability to store the password in basic mode.  It would have been just as secure if not more secure than using basic mode in OWA and storeing the password in IE.  This is not a security feature.

Chris
0
 
mentchconsultingCommented:
I am having this same problem.

So I tried to follow the instructions and ran "control keymgr.dll". It opens up the window "Stored User Names and Passwords", but it only gives me two options:  Remove and Properties.  No button is displayed to "Add".

I am running Windows XP.

How do I get the Add option??  I am the administrator for my computer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.