NIC Card

Posted on 2004-09-04
Last Modified: 2010-04-17
This is not really a router issue but rather a NIC issue.  I am setting up a Linux Fedora Box and can't seem to get connectivity .  I can ping the address but not the host address or gateway I get a network is unreachable response.  I have tried 3 different NIC  cards along with the internal nic device that was on the motherboard.  The card wiil be recognized when I boot up the system and shows a green connection light from the switch I am connected to.  I have use the same line that was connceted to another server that was live so I know it works.  The message I receive when i try to configure the network is 3c59x device eth0 does not seem to be present, delaying the initialization.  Any suggestions?  Thnaks in advance.
Question by:midav2004
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2

Accepted Solution

MarkDozier earned 100 total points
ID: 11985834
first disable the onboad NIC.
Then reconfigure the e0 and leave the others diabled.
Do the ping on 127, and ping the NIC IP ect...
Repeat the process on the other cards to see if they work

Author Comment

ID: 11986405
Actually, it was that I did not have the correct driver loaded with the new motherboard.  I had thought wrongly that it was loaded with the linux install.  I went to the 3Com site and downloaded the linux driver and that worked fine.  I did disable the onboard NIC because I couldn't find a driver for it and not sure waht brand it was either.

Expert Comment

ID: 11986991
The onboard NIC drive should be on the Motherboard CD. NOt know which borad you are using I would check that first and then if you need to download the mobo CD. I always install my mobo drivers even if the O/S has support for it. Sometimes just a minor difference can make a big change.

Author Comment

ID: 11989902
The CD from TYAN only works for Windows.  I went to their website and the drivers for linux are not labeled for this mobo.  The ones I downloaded from there did not work for the onboard so I installed another NIC and that works fine.  I only use this as a webserver so I have 3 extra PCI slots not being used with one for a case fan/blower.

Expert Comment

ID: 11992812
Okey. I was asking because many poeple are unaware that mobo CD have other then windows drivers. Sometimes even pro overlook it.
Congrats on fixing the problem. I hope you have long success with the webserver.

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
IPv6 question 1 74
RV042 site to site vpn can ping but not access server via rdp 6 46
What problem can Native VLAN mismatch causes 4 74
Dlink-DIR 816 router 4 62
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question