Solved

flashing bios for mercury motherboard ( confused)

Posted on 2004-09-05
10
3,368 Views
Last Modified: 2008-01-09
helloo all
I have a mercury motherboard model number ( KOB P4M266 NDFSMX ) with AMI bois chipset ,,,, I want to flash the bios because of the message cmos error which apear each time I start the pc .
from the mercury web site I got the latest bios upgrade for this M.B I download the file ,its name (020905s.ROM) .and according to mercury readme file flash utility is required to flash the bios (seems the file which has been downloaded is a data file and need an application to excute it), anyway I went to flash utlity section I found 3 files :
Aminf337.exe
Aminf339.exe
flash821.exe
actually I donno which file is the one which is supposed to copy to flash disk with 020905s.ROM
so I tried them all but
aminf337 give me an error that (file not found) which file I don't know
aminf339 give me the same dam message
flash821 give me an error after starting (chipset is not supported)

I know I missed something
please any help will be appricieted
0
Comment
Question by:fadloun
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 1

Accepted Solution

by:
gor_c earned 250 total points
ID: 11984286
You may need to specify the file name of the BIOS image to the flashing program e.g "Aminf337.exe 020905s.ROM". You'll therefore need to do this in MS-DOS, or create a batch file on the floppy.

I would have expected all of this to have been done for u.

I suggest this: first try and find out which flash program is meant for your motherboard.
(Sounds like the first 2 are correct, but the Aminf339 may be a later version).
Restart computer in msdos mode, then run "Aminf337 /?" and it may give information about how to run it.  If u don't understand it, send me a listing of that info and I'll try and help.

If the command does not do anything, then just try "Aminf339 020905s.ROM", but it's a bit risky.

You may need to create an "autoexec.bat" file to automatically run this command when the computer starts.
0
 
LVL 5

Author Comment

by:fadloun
ID: 11984406
very good point ,,, how did I forget it ,,,,, BUT still stuck
I got the same error message (file doesn't exist) By mistake I wrote it above file not found

here is the result
H : Help|?
.A : Auto detecting&Programming flash ROM
.B : To force Boot Block Programming
C : Load BIOS CMOS default values without warning the user about
.any configuration change
.D : Clear passwords during loading CMOS defaults
.E : Clear CMOS after programming done
.G : GPNV data area reserving
.I : Identification BIOS file is right for this system or not
.N : To force NVRAM programming
.O : Flash functions call from BIOS file
.P : To make [Security] item visible
.R : Force reboot after programming done
.File_name] : To save Flash ROM data into file AND quit[
etryNumber] : Retry if programming fails. The [RetryNumber] can be 0 - 65535
.This function is only for command line mode .
.File_name] : To update utility's modules data[
.V : Verify BIOS checksum
.X : Enter utility's user interface without system checking
Options> : Disable flags<-
>Options<
]B]/[C]/[D]/[E]/[G]/[I]/[N]/[O]/[R]/[V[
____________________________________________________________________________

more help plz
0
 
LVL 1

Expert Comment

by:gor_c
ID: 11984558
That listing seems to be missing some formatting..

Anyway, you'll want to use the option to identify if the bios is right or not, then save flash rom to disk as backup, and finally to flash the rom itself.

Try "Aminf339 /I 020905s.ROM" first, what do u get?
0
 
LVL 1

Expert Comment

by:gor_c
ID: 11984658
Check out this website fadloun:

http://www.soyousa.com/kb/kbdesc.php?id=270

Double check that the rom file is correct for your motherboard.
0
 
LVL 5

Author Comment

by:fadloun
ID: 11984664
helloooo gor
I did type :a:\Aminf339 /I 020905s.ROM
it does work BUT after showing alot of informatio about my system it prompt me to press any key to  continue when ready ,,,,,I pressed and it starts flashing the bios eventually and before the progress bar finish the monitor turn into black and the led become orange (data lost) and the keyboard stuck (numlock is not working) and no reading from A Drive :(
I am afriad to restart the pc ,,, I don't know what to do coz I know that flashing bios is a risky process and should not stopped for any reason,,, I dono why it stopped like this

I am sticking here waiting for your reply bro
regards

0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Expert Comment

by:octavsand
ID: 11984975
hmm... the thing is it should not have started flashing the BIOS. It is possible that the file was wrong or corrupted, but then again the progress bar may simply have jumped from, say, 80% to 100% because whatever process was supposed to be done finished quickly. It is equally possible that you may now have a dead motherboard with practically no way of reviving it. Had I noticed this earlier, I would have told you the error you get at the start of booting, "cmos error", may be due to a bad battery on the motherboard or the CMOS Reset jumper stuck in the "reset" position. Ideally, you would have then checked with a new battery and maybe you would have found the error no longer appeared. Right now you might just be in a lot of trouble. If you cannot read from the A: drive, and you cannot tell the flashing process to try another BIOS, you have only the option of rebooting the PC and hoping for the best. If at that time, the system does not boot, you may be in big trouble. I would suggest contacting the reseller, if they offer recovery services, and asking for a new flash of the BIOS (assuming they have the necessary tools). Just tell them what happened, you tried to flash, it didn't work, and how much does a recovery cost.

Good luck to you fadloun and I hope, for your sake, that the flashing process did get to complete.
0
 
LVL 5

Assisted Solution

by:Blue_Rishi
Blue_Rishi earned 250 total points
ID: 11986534
If the flashing has failed, you have 2 options to restore it yourself:

1) bootblock method
2) hot swapping

for method 1:
1) power off your system
2) check the jumper setting for the 'clear cmos'; make sure it's set to normal
3) check if there's a jumper for allowing bios flash (seen on some mobo's)
4) format a floppy, put the correct bios file on it, but rename it to 'AMIBOOT.ROM'
5) put the floppy in the drive and power up
6) if bootblock bios is available, the floppydrive will spin-up and reflash your bios...

I wouldn't recommend the 'hot swapping' method, although I've used it succesfully in the past; It's a very risky method...

further reading: http://www.amptron.com/documents/Recover.pdf

Blue Rishi
0
 
LVL 5

Author Comment

by:fadloun
ID: 11990378
helloo again
seems M.board has gone,,,, after restarting the computer the keyboard blink once and there is no signal on the screen ,actually there were 2 vga cards one built in and one on agp slot ,,,,,
if the agp card inserted in the slot no signal from both cards ,, if removed and connect the monitor to built-in one I got message on the monitor ( out the range).
Rishi
I think this mother board doesn't support bootblock method ,,,, I have checked the manual ( downloaded it from mercury site) no such a thing ,and I try to do what you said about amiboot.rom , the drive A led doesn't blink at all .
but I notice that there are 2 jumpers I didn't saw them before one (the manual mentions to ) and I don't know what are they supposed to do
J13 :
3-pin Flash ROM Voltage
(VCC) 5V: Short Pins 1-2
          3V: Short Pins 2-3
 JP4:
 3-pin Flash ROM Size
 2M: Short Pins 1-2
 4M: Short Pins 2-3

do you think those jumpers related to my problem ( flashing stuck) or are related to bootblock method

regards
0
 
LVL 5

Expert Comment

by:Blue_Rishi
ID: 11990621
About the bootblock method, this feature comes with modern bioses, although is not always implemented by mobo manufracturers. Sometimes you need to press a key combination to activate bootblock bios (like alt - F2)

3-pin Flash ROM Voltage, not sure; could be for selecting between 3V/5V eeprom chips. On the other hand, on older boards you'd have to short a jumper before flashing; without supplying 12V to a certain pin (1?) it couldn't erease/program the chip (on even older chips you'd have to use UV-light for ereasing).

2M/4M: is for selecting eeprom size, typically 2Mbit=256Kb (actually have never seen 4Mbit but now they're around...). If the *.rom file is 512Kb in size, It should be on 4M, otherwise (256/128Kb .rom file) leave it on 2Mb.

Blue Rishi
0
 
LVL 5

Author Comment

by:fadloun
ID: 11994021
hello
 I think hot swapping is the only solution I can do ,,, so I'll try to get same motherboard and do that.
but still wondering why flashing bios stopped like this ,,, I am sure I got the correct bios update.
anyway :
thank you all for your help
regards
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

In this article you will get to know about pros and cons of storage drives HDD, SSD and SSHD.
What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now