Solved

Help creating an online server with apache going threw two hubs please

Posted on 2004-09-05
78
319 Views
Last Modified: 2010-04-03
I need help setting up an online server off my computer the problem is i can online get the server to work on my LAN and cant make it accesible for anyone else! i need help please respond! you can email me fabio.elia@gmail.com
thanks,
fabs
0
Comment
Question by:FabioElia
  • 36
  • 24
  • 7
  • +3
78 Comments
 
LVL 7

Expert Comment

by:Stampel
Comment Utility
You must provide more details to be helped :)
For example what are the IP of the computers involved, and the Operating System.
Assuming your server work on your LAN for example 192.168.0.1 then if you have another
computer on this LAN for example 192.168.0.2 it should access it in internet explorer using
http://192.168.0.1 from it if there is no firewall blocking port 80.

Describe it more , i will try to help u
good luck
Philippe
0
 

Author Comment

by:FabioElia
Comment Utility
ok windows xp home but im putting server 2003 likei had before ip 192.168.0.105  the other comps is 192.168.0.104their is no firewall and i accessit throughinternet explorer but it only works on my lan network
0
 
LVL 4

Expert Comment

by:HackLife
Comment Utility
windows xp home = not a web server. You may get by running apache, but it's not ideal. How are you serving your websites?

Windows 2003 server = good. You just install IIS, and make sure your router points incoming traffic to your server.
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
You can Install the Apache on what so ever OS you want. Just verify you have all the propper configuration:
1. Test your server configuration locally (i.e. 127.0.0.1 in the IE address bar).
2. From a remote machine try to ping the server's address and see if you have any reply...
3. If you are having problems in the reply, you must have running a Firewall system on your machine thus wont allow users to access you server...

More help? just say so...

Cyber
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
You need to point who ever twoard your machine via your ip address. If you have a static ip address one that does not change. You can point them to that like this the ip addy is a example replace yours with it. Http://65.25.114.222
Or you could use a domain name service such as dyndns.org. You would need to register at dyndns.org and then update your ip addy every couple of weeks either manually or via a client that would do so automatically. You can get a client from there web site. There you can choose what ever name you want but still its all dependent on your ip addy. Or you could use a pay for service domain name service wich you may be able to just supply a name. If you have a dynamic ip address you will need to use the same type of services as mentioned above but then again you will need a client or do it manually to change the ip addy every time it changes.
You will also need to make sure that apache is listening on port 80 or what ever port you are useing.
If you are useing windows xp you might have the internal firewall on. You will need to turn that off or allow port 80 or what ever port you are useing.
 
0
 

Author Comment

by:FabioElia
Comment Utility
ok well i have apache ive had it up before i already got rid of all the firewalls and the builtin firewall on  xp and still only my Lan sees it and noone else
fabs
0
 

Author Comment

by:FabioElia
Comment Utility
i did the 127.0.0.1 and it brings me to the same page as normal so it works but only for lan
fabs
0
 
LVL 4

Expert Comment

by:HackLife
Comment Utility
Make sure your router forwards packets for port 80 or 8080 to your computer with the apache.

Depending on the router, you may have virtual server or port forwarding or the like. Look around in your router web interface on how to do it.

you can register your ip at www.dyndns.org for a free domain name.
0
 

Author Comment

by:FabioElia
Comment Utility
Ive tried www.dyndns.org but everything i dono matterwhat i canonly accessit with my lan andnothing else ,
fabs
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
HackLife was right.  You need to forward your port 80 to your 192.168.0.105 address from your router.  Then, from an outside computer try it.
0
 
LVL 4

Expert Comment

by:HackLife
Comment Utility
If you are willing to post your ip or domain name, I can help you test.
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
Ok if your machine is 192.168.0.105 all the time. That is a key statement. Then you need to make sure that your router has opened what ever port you are useing for apache. In your apache httpd.conf file you will find a line similar to this
Listen to 80.
That is saying apache will look for incoming trafic on port 80 if it is something like 8080 you or anything else you need to make sure that the router is listening on the right port. That being said the next task is to have your current or static ip address if you have a dynamic ip address one that changes you need to make sure that what ever service you are using points to your current ip address. As with dyndns.org if you can not find a client to auto update your ip address if it changes. You can change it manually by going to there web site and doing a update to your selected account. It will show you your current ip address in its database also it will show you your current ip address you are connected on they must be the same. If not do the update option and it will change the ip address in its database. Rarely but it can take up to like 15 minutes for the net DNS servers to point to your machine. If you have a dynamic ip address from your internet service provider. Every time you disconnect from your internet service provider you will get a new ip addy. At that point you will need to do the update all over again. Also your isp will randomly change your ip addy every few days. Also your hubs will possibly change your machines local ip addy 192.168.0.105 if you get disconected from them or power outages occur. Usually if you only have one machine hooked up at a time that would be a rare occurance. Check your local ip addy through the cmd prompt just type ipconfig and see what your local ip addy is. If there is a router involved at some point it needs to have opened up the forwarding ports to that local ip addy.
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
Can you diagram how ALL your net architecture is actually built (including WAN settings)?

|Server|<------->|Hub|<------->|Client|?
192.168.0.105                            192.168.0.104

Cyber
0
 

Author Comment

by:FabioElia
Comment Utility
68.163.137.75 my ip im not sure if i did it right but how do you forward port 80 to the ip adress? Well the diagramis confusing butit goes like
|server|<------>|Hub|<--------->|another hub|<---------->|client|
 please help, thanks,
fab
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
What type of router are you using?
0
 

Author Comment

by:FabioElia
Comment Utility
My Comp along with another computer connect to a hub which then connects to another hub in the other room which has three other computers on it then it connects online. the ip adress go 192.168.0.105-.100
0
 

Author Comment

by:FabioElia
Comment Utility
A dlink router(xtremeair plus wirless router) and a netgear(netgear extremehub en104tp) router
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
Do you have a crossed cable? Try to get your hands on one of those and try to connect those two elements directly to see if you have a 'ping' (which from what I gathered you have no reply in the current situation - and correct me if Im wrong)...

Cyber
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
PS
Crossed UTP cable;

Cyber
0
 

Author Comment

by:FabioElia
Comment Utility
how do ido that nothingseemscrossed how doisee if they ping?
0
 

Author Comment

by:FabioElia
Comment Utility
sorry my spacebar doesnt work good
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
OK work the process like this to narrow down where your problems are occuring.
Diconnect all your machines from the routers.
Disconnect both routers.
Connect one router to your modem.
Connect your machine to port one on that router.
Get your local ip and your net ip addressess.
Set your router up for your machine to the correct port for your apache server.
Test your server from the net address either by domain name or net ip address.
Once all that is set up and connected correctly.
Add your second router. Now if you have problems at least you know it will be with the second router.
Finish setting up the second router to point to your machine.
After that all you have to do is connect your other machines.
0
 

Author Comment

by:FabioElia
Comment Utility
how do i find out my net ip
0
 

Author Comment

by:FabioElia
Comment Utility
i did whaat you said om on the first hub
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Aw, heck!  I think he's not using hubs.  He's using two routers with ethernet ports.  That makes a world of difference especially if he's two routers back.  Fabio, you will have to go into the config of each of these routers.  The first router you will haver to point port 80 to the second router.  The second router will point port 80 to the IP of the machine with apache.  Normally Netgear will be http://192.168.0.227 I think.  Dlink, however, is http://192.168.1.50 if I'm not mistaken.  get out the manuals and find out how to connect to each.   Find a tab that says forwarding.  You want to forward port 80 to 80 to the IPAddress you want depending on which router it is.  
0
 

Author Comment

by:FabioElia
Comment Utility
lol sryyour right its a router my b well im only attacehd to dlink right now i     disconnected netgear but i cant seem to point it to port 80 imusing themanual an cd that came with it but it wont let me go to the link to set it up http://192.168.0.1 it wont let me go to it sonow im stuck
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
On you PC go to a command prompt and type ipconfig /all
The in your web browser open up whatever the ipaddress is of your default gateway
0
 

Author Comment

by:FabioElia
Comment Utility
okyai got the deafult gateway and all but the thing is it asks me for a userand in the manual it says use admin but its not letting me access it it needs another user name
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
Crossed UTP cable is a cable that allows you to connect two machines directly without any component in the middle. I think it is worthawhile to purchase such a cable and for testing to eliminate where the problem is;

Cyber
0
 

Author Comment

by:FabioElia
Comment Utility
well if i cant get it to work then ill check it out but i want to try it beforei go buy some stuff
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
try admin for the password and then try password for the password.  I can't remember for dlink but it's one of the two.
0
 

Author Comment

by:FabioElia
Comment Utility
i had tried them both already and nothing "401 Unauthorized"
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
hmmm, it must have been changed.  You could do a reset on the  router.  It will cause you to lose connectivity for a moment but will restore the defaults.  There is a button on the back you push with a pen.
0
 

Author Comment

by:FabioElia
Comment Utility
killtry
0
 

Author Comment

by:FabioElia
Comment Utility
nope nothing
0
 

Author Comment

by:FabioElia
Comment Utility
it reset but   still nothin
0
 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
401 Not fount means that you have communication between the elements, can you 'ping' the other machine?

Start=> Run.. => enter the keys 'cmd' => click OK and use the following command:
ping 192.168.0.104
from the server and:
ping 192.168.0.105
from the workstation;

What do you have?

Cyber
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
That sucks.  Push the button in and hold it for about 10 seconds then release.  Then try the password admin
0
 

Author Comment

by:FabioElia
Comment Utility
i did ping 192.168.0.105 on this comp  where ami supposed  to do the other one same comp
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 15

Expert Comment

by:Cyber-Dude
Comment Utility
What was the reply?

Cyber
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
You are going to need the local ip addy from the router.
The local ip addy is what distinguishes your machine from all other machines and how your router allows traffic to your machine.
open up a command prompt
 at the type ipconfig /all
This will give you a bunch of lines
look for the line with a local ip addy they usually start with 192
that will be your local ip addy
you need to get the correct ip address for your router setup window it will be in your manual or if you lost or do not have that go online if need be just connect your machine directly to the modem. If need be post your make and model number of the router and we will give you the correct ip addy for the setup window of your router.
Once you have all that reconnect the router inbetween the modem and your machine.
Once in the router setup window you may need to enter a user and password to access your router setup window
this also will be in your manual for the default settings Make sure you do a reset if you do not know the user and password.
From here you will be able to direct your router to your machine.
That will be the first step.
Also you need to access the router setup window via a web browser FYI
0
 

Author Comment

by:FabioElia
Comment Utility
sry ya i canconnect to my router now what settins should i have?
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Forward port 80 to 80 to you internal IPAdress that has your web server.   Then you should be able to connect via the ip from the internet
0
 

Author Comment

by:FabioElia
Comment Utility
oki cant find anywhere to forward port 80
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Go to the advanced tab and enable the virtual server.  Type this...

Name = Web Server
Private IP = whatever the internal webserver address is.
TCP
Public Port 80
Private port 80
.Schedule Always
Then apply

I just grabbed one of the DLink manuals but it should be similar to this.
0
 

Author Comment

by:FabioElia
Comment Utility
private ip such as 68.163.244.96 cause its not working
0
 

Author Comment

by:FabioElia
Comment Utility
oki saw wat u meant i did tat i have it done but it seems like no one can accessit
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
The 68 address is public meaning on the internet.  The public one will be the 192 address
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
oops, the private one will be 192.  Sorry
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
Very good it seems as you got into your setup screen for your router. Your getting there not to much more to go.
Have you set up one router or are you in the process of the second router? As long as you got the first one working its just a matter of haveing the cables and the second router connected correctly and of course the second router setup screen settings. Once that is done all you should have to do connect the other machines. Though if you are running any type of servers on the other machines you will also need to set those access rules in the router's
0
 

Author Comment

by:FabioElia
Comment Utility
well ive done everything so far and configured thedlink routerbut i cant figureout thenet gearrouter
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
For the netgeartype http://netgear(with some#'s and letters to follow).  Usually the numbers and letters may be on the bottom of the router for reference or they sent you a bunch of stickers in the box that it came with.  OPtionally, you can try http://192.168.1.1 to get access to it.  You should have a similar page forwarding under the advanced tab.
0
 

Author Comment

by:FabioElia
Comment Utility
none of the numbers work forthe netgear istheir another link mayb i dont have my netgear manual
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
try ftp://downloads.netgear.com/files/wgr614v4_ref_manual.zip
Probably not your router but it should be close
If you've plugged in the router and another PC behind it (for instance the XP box we've been working with) then go do and ipconfig /all and it should be the default gateway.
0
 

Author Comment

by:FabioElia
Comment Utility
my netgear isnt a router  its a hub
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Sweet!  Then you're done.  If the configuration worked before off of the other router then it should work now.
0
 

Author Comment

by:FabioElia
Comment Utility
but it doesnt noones able to see it
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Were they able to see it before you added the hub?
0
 

Author Comment

by:FabioElia
Comment Utility
well i had taken out the hub for a host time so im not sure il try right now
0
 

Author Comment

by:FabioElia
Comment Utility
sry tat was messed up i hadtaken it out before then put it back on now its off
0
 

Author Comment

by:FabioElia
Comment Utility
nope noone cansee it
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
But it still doesn't work and honestly shouldn't matter.  For some reason your router is not forwarding the port 80.  If I were you I would double check your external IPAddress.  Do you have DSL?  Are you connecting via PPPoE or static IP?
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Did you change the private address to the 192.168 number?
0
 

Author Comment

by:FabioElia
Comment Utility
ppoe is what im connecting withand yes i had changedit to 192....a while ago
0
 

Author Comment

by:FabioElia
Comment Utility
should i change it to static ip?
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
OK.  Check to make sure your external ip address hasn't changed.  Also, go back into the router and double check the setting for the forwarding that you created for port 80.  Also, make sure that your desktop still has the same IP address with the ipconfig /all command.  If all of this is there then it should be working.  BTW, you can still see the web page if you typed in the ipaddress of the webserver on the local lan, right?
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
My concern for the PPPoE or static is that the external IP may change periodically depending on the DSL package that you bought.  
0
 

Author Comment

by:FabioElia
Comment Utility
on lan ican see it ya
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
Cool, double check the other settings just to make sure that I mentioned a couple of comments ago just to make sure
0
 

Author Comment

by:FabioElia
Comment Utility
my external ip 68....changed what should i do now ?
0
 
LVL 4

Accepted Solution

by:
jonnietexas earned 500 total points
Comment Utility
Well, you're hosed.  You can upgrade your dsl service to have a static (or as SBC is calling them these days "sticky") ipaddress.  It will run you between 60 to 100 bucks per months.  Otherwise, move your website to an external host.  Sorry bubba.
0
 

Author Comment

by:FabioElia
Comment Utility
alrighttanxs anyway
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
You might check out www.dyndns.com.  Never used it but might be an option.
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
You might check out www.dyndns.com.  Never used it but might be an option.  Thanks for the points.  Sorry it didn't work out for you.
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
This was a bogus point execution handout
i already gave him the instructions on what to do with or without a static ip addy.
This might sound like sour notes but i have to say the point hand outs on these boards is bogus
0
 
LVL 4

Expert Comment

by:jonnietexas
Comment Utility
So take the points.  I'm just trying to help and learn more myself.  Yes sour notes.  Stuff happens.
0
 

Author Comment

by:FabioElia
Comment Utility
TheTinkeringToad sry manifyou want i canhook you about with gmail iddgive youthe points cause i really dont care but what ever if theirs another way without buying  anything then ill give you the rest of my points
0
 
LVL 2

Expert Comment

by:TheTinkeringToad
Comment Utility
No thank you.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Don't buy such-and-such disk drives, they are not reliable!    Boy, how many times have we read a post from a well-meaning person who had some bad experiences with a drive and now they exclaim the entire company's products can't be trusted.  First, …
We wanted to provide an in-depth explanation of the Ping Node offering clarifications on its function and usage. Incorrect Ping Node configuration and functionality can cause problems with HA clusters. The importance of this article is critical for …
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now