Solved

Mounting disks in Mandrake 10

Posted on 2004-09-05
10
2,284 Views
Last Modified: 2013-12-15
Iam using Mandrake 10, but when I insert a disk (floppy, CD, or DVD) after creating a device link to it on the desktop and right-click and select the mount option, I get the device icon and the indicator light on the drive comes on to indicate activity, but when I click open (on either of the icons) I get an error message saying they do not exist. When I try to use the mount command in the terminal I get the message that the command does not exist. Any suggestions much appreciated.
0
Comment
Question by:mark_667
  • 4
  • 3
  • 3
10 Comments
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 11986155
"When I try to use the mount command in the terminal I get the message that the command does not exist."

That's a bit weird. Try this. Create a directory in /mnt for your floppy. "mkdir /mnt/floppy" (without the quotes) Then try "mount /dev/fd0 /mnt/floppy" (Again without the quotes). What error message does it give you?
0
 
LVL 10

Expert Comment

by:Luxana
ID: 11986523
mark_667

after  mount your cdrom you double click to to mounted cdrom icon on on your desktop a there is message do not exist !! I thing I had this problem as well so I always must show absolute path to my mounted cdrom drive.What is the path displayed when you doubleclick on mounted cdrom icon on your desktop?

Try browse to folder where you cdrom is mounted. It should by something like :

/mnt/cdrom

Luxana
0
 
LVL 1

Author Comment

by:mark_667
ID: 11996270
Here is what I got when I tried the commands:

[admin@localhost sdmin]$ mkdir /mnt/floppy
mkdir: cannot create directory '/mnt/floppy' permission denied
[admin@localhost sdmin]$ mount /dev/fd0 /mnt/floppy
mount: only root can do that
[admin@localhost sdmin]$

Apparantly, although I set the automatic login to administrator I do not have root access. So I changed the Direct root login option in levels and checks to 'yes' from default and restarted, but only got the same as above. Can I change the access permissions for 'admin' to include root or do I have to log-in as root, and if so, how can I do this without losing all my settings? I have also tried the command /mnt/cdrom in both the terminal andkonqueror, but it failed for the same reason.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 10

Expert Comment

by:Luxana
ID: 11997186
HI

al you need to do is :

 $ su -  (change to root)
enter password for root

# mkdir /mnt/floppy  (if it does not exists alredy)

vi /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

/dev/hdX                /mnt/cdrom    iso9660    ro,user,noauto  0                 0
/dev/fd0                 /mnt/floppy         auto     user,noauto       0                 0

now more to options :
if you set user in option it means that user can mount device but can't  unmout but wehn you set users user can mount and unmount device.  noauto means that the device will be not mounted as system boots to set it auto it will mount device as system boots. My advise is to set it noauto and then when you need it just:

$ mount /mnt/floppy
or
$ mount /mnt/cdrom

mount command will reads /etc/fstab and add addionals optios form fstab file.



0
 
LVL 10

Expert Comment

by:Luxana
ID: 11997214
I do not know how much are you experienced with linux but just in case I need to metion that in /etc/fstab do not remove you lines which are already there just add lines or modify pls.

LUXANA
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 11999460
If you look in /mnt you probably already have floppy and cdrom directorys. To mount your floppy
su -c mount /dev/fd0 /mnt/floppy or cdrom -
su -c mount /dev/cdrom /mnt/cdrom
0
 
LVL 1

Author Comment

by:mark_667
ID: 12005872
This is what I got when I ran the command vi /etc/fstab

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto user iocharset=iso8859-1.codepage=850.noauto.ro.exec 0 0
/dev/hdd /mnt/cdrom2 auto user iocharset=iso8859-1.codepage=850.noauto.ro.exec 0 0
/dev/fd0 /mnt/floppy auto user  iocharset=iso8859-1. sync codepage=850.noauto.ro.exec 0 0
none /proc proc defaults 0 0
none /tmp tmpf defaults 0 0
/dev/hda5 swap swap defaults 0 0
~
~
"/etc/fstab" 9L, 440c                                     9,1      All

Note there are 2 CD-ROMs listed one is a DVD-writer, the second is a CD-writer - are they listed correctly?

However the command:
# /etc/fstab: static file system information.
and
# vi /etc/fs?tab
did nothing
Luxana: I don't know hopw to access and change the options you refer to can you spell it out a little more?
owensleftfoot: apparantly I do already have these directories and it indicates that it has mounted the disk, but if I try to open it by right-clicking the mounted desktop icon and selecting 'open' I get the message 'the file or folder '/mnt/floppy' foes not exist'. Also I tried the command:
su -c mount /dev/fd0 /mnt/floppy
and got the error: 'su: user /mnt/floppy does not exist'.
Am I missing something?
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 12011120
What does "ls /mnt/" (without the quotes) give you?
0
 
LVL 10

Accepted Solution

by:
Luxana earned 50 total points
ID: 12012203
mark_667

first do what owensleftfoot wrote in last comment. So we can see if yours mouting points exists.

What do you mean that vi /etc/fstab did nothing it should at least give you some error message.

Mark also you need to know some commands:

$ su -   ( you change to superuser(root-#)

when you working in terminal notice:

$ -> normal user
# -> root

also in command above :
su -c mount /dev/fd0 /mnt/floppy use quotation marks like this :

$ su -c "mount /dev/fd0 /mnt/floppy"  (in this case u r trying to mount floppy as normal user)
or
# mount /dev/fd0 /mnt/floppy  (like root note different between # $)
then
# ls /mnt/floppy

# ls /mnt/ tells you what is inside /mnt folder make sure that /mnt/floppy exist if not make one !

in /mnt/ folder should by also /mnt/cdrom and /mnt/cdrom2 folders if so put into cd-rom normal cd-r cd and try

# mount -t iso9660 /dev/cdrom /mnt/cdrom     ->(try both devices)

then

# ls /mnt/cdrom

let us know how you doing...



--------------------
LUXANA


0
 
LVL 1

Author Comment

by:mark_667
ID: 12037741
Sorry I took so long to reply. In the mean-time I had to re-install it for an unrelated reason and it seems to have made a difference although I did nothing different to the first time. I found I can now mount floppy disks on the desktop and konqueror will display the contents.
Typing 'ls /mnt/' gave me:
cdrom/ cdrom2/ floppy
/etc/fstab/ gave me the message 'permission denied', even though I was logged in as root. I found that vi/etc/fstab gave 'no such directory' because I didn't leave a space between 'vi' and '/etc/fstab'. Doing so gave me the data dump I posted in my last reply.

After looking at the replies, I have decided the points should go to LUXANA for providing more detail in the responses that were relevant to the question.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question