Solved

Unable to contact web server

Posted on 2004-09-05
11
1,568 Views
Last Modified: 2008-01-09
I have just installed IIS and Visual Interdev 6.0. While creating a project through Visual Interdev, in the "Specify a server and mode" screen, i am entering localhost as the server.
I am getting the error

Unable to contact web server http://localhost.

How to resolve this issue???
0
Comment
Question by:jaspreet_s_sethi
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 5

Expert Comment

by:cristy56
ID: 11987579
check to see if this folder exists :
c:\inetpub\wwwroot\

Cristy
0
 
LVL 5

Expert Comment

by:cristy56
ID: 11987589
have u tried to create some asp or htm file in c:\inetpub\wwwroot\ and then access them successfully thru' the browser ?
e.g.
http://localhost/test.asp 
does that work normally ?

Cristy
0
 

Author Comment

by:jaspreet_s_sethi
ID: 11987592
WWWRoot folder exists...
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 
LVL 7

Expert Comment

by:suramsureshbabu
ID: 11987819
check weather the iis is running or not if its not running start it through the iis admin interface

then type http://localhost/

and check
0
 
LVL 5

Expert Comment

by:KarcOrigin
ID: 11987966
Try
http://localhost:8080/

OR

http://localhost:80/

Pl. reply back with the result.

Cheers!

0
 

Author Comment

by:jaspreet_s_sethi
ID: 11988386
Cristy: test.asp worked without any issues..

suramsureshbabu: IIS is running.. http://localhost/ opened the IIS default page..

KarcOrigin: http://localhost:8080/ ----gave the page cannot be displayed error page
                 http://localhost:80/ --- opened the IIS default page...
0
 
LVL 1

Expert Comment

by:mlpk_tyr
ID: 11988652
you need to specify the content directory for the server. place your contents in the appropriate folder or link the contents to the server. if everything is ok then you must have a page named index.html which will be the first page loaded whenever you make a request to the web address. try naming as index.html and reply.

hope this work,
mlpk_tyr
0
 

Author Comment

by:jaspreet_s_sethi
ID: 11988773
mlpk_tyr: the IIS is working fine.. if I code an ASP page and request it through the web browser it is working fine.. the issue is that I am getting the error when creating a new project from the Visual Interdev (read the question).
0
 
LVL 10

Expert Comment

by:avidya
ID: 11991026
hi jaspreet,

in VI can you connect to the server with http://127.0.0.1 ?
(this is the IP address for "localhost")
0
 
LVL 10

Accepted Solution

by:
avidya earned 250 total points
ID: 11991054
and be sure to have the "Server extensions" enabled in IIS
0
 
LVL 10

Expert Comment

by:avidya
ID: 12008889
Hi Jaspreet,

Thanks and good luck
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Get to know the ins and outs of building a web-based ERP system for your enterprise. Development timeline, technology, and costs outlined.
Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
The viewer will get a basic understanding of what section 508 compliance can entail, learn about skip navigation links, alt text, transcripts, and font size controls.
The is a quite short video tutorial. In this video, I'm going to show you how to create self-host WordPress blog with free hosting service.

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question