[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 10153
  • Last Modified:

Can only connect as GUEST when trying to access Windows Shares via UNC Paths and Network Neighborhood

Hello all,

This issue has been plaguing me for some time now, I'm hoping you experts can help.

I have 3 PCs set up at home, all running WinXP SP1 with Sygate Personal Firewall.  I have file sharing enabled on each machine, and have configured a few shares.

However, when i try to access the machine, either by typing the UNC mahcine name, \\MACHINENAME, for example, the authentication dialogue appears, but i cannot specify a user name.  The field where i usually enter my username is 'Greyed Out' with the word MACHINENAME\GUEST in it, of which i cannot change.

Here is a link to a screenshot that depicts the above behaviour: http://www.aktiveonline.com/share.jpg

The password field is as usual, and i can enter into it. Its just the Username field i cannot seem to change.

I have disabled simple file sharing, and checked that Sygate Firewall is allowing connections via Network Neighborhood, all to no avail.

I look forward to your suggestions.

-DEAN
0
aktivemofo
Asked:
aktivemofo
1 Solution
 
Tonie16Commented:
Go and check your settings of your Network Connections on each of the pc's.
Make sure the Windows default firewall is off and also the no authentication is nessesary.

Tonie
0
 
ErikPhilipsCommented:
Log in as administrator.  Open explorer.  Tools->Folder Options->View Tab->(Advanced Settings)->UNCHECK simple file sharing.
0
 
ErikPhilipsCommented:
Check to make sure that the username and passwords are the same on both machines.  I believe that if windows cannot authenticate with the same username/password, you must use guest.  (IE if machine A and machine B both have a username BOB, and you are logged into Machine A as BOB connecting to machine B, if BOB exists as a user on machine B, then if the passwords do not match, then you must log in as guest.  If BOB does not exist on machine B, you should get a login prompt.... I think)
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
motaz_mohamedCommented:
I think you can solve this problem by doing the following:
1) Double click My Computer
2) Go to Tools > Map Network Drive
3) In the Drive field, choose any letter you like.
4) In the Folder field, type your UNC path \\your_machine_name\the_folder_you_want_to_access
5) Under the "Reconnect at logon" check box, you will find "Connect using a different user name". Click on different user name then type your user name and password.

Good luck
0
 
pjcrooks2000Commented:
aktivemofo , you should mimic the accounts on all of the machines back and forth, that way when you logged on one machine as a user lets say hes called "Joe Bloggs" with a password of "joespass" then when you try to connect to another machine you will be logged straight in as the appropriate user.  

In order to make it not as complicated as that.  You can just create one user for all three machines.  That way the user will always have the same name and password to authenticate your access.

You may have a problem with your firewall by the way so you will have to make sure that it does not prevent access, also XP has its own built in firewall that you may need to disable to allow access.

I hope this helps you

pjcrooks2000
0
 
JohnItemCommented:
Indeed it is necessary to match username and passwords on all machines as suggested by our peers above...


I would add that you follow these steps (please bare with me, even if you have done it before.)

________________________________________
Sharing 101
Windows XP Professional supports two types of file sharing: simple and advanced. Simple file sharing works just like it does in Windows XP Home Edition. You have only two choices to make:

• Whether you share a folder on the network
 
• Whether users can change files in the shared folder
 

If you choose to deny users permission to change files, Windows XP Professional gives everyone Read access to the share. Otherwise, the operating system gives everyone Full Control of the share.

To Share a Folder Using Simple File Sharing

1.
 Create the folder you want to share. I like to create shared folders either in My Documents or on the desktop to keep them from hiding.
 
2.
 Right–click the folder and then click Sharing and Security. The Sharing tab of the Properties dialog box for the folder opens, as shown in Figure 1.
 
3.
 Click the Share this folder on the network check box. This makes the folder visible on the network.
 
4.
 Click the Allow network users to change my files check box if you want network users, including yourself, to be able to modify your stuff on the network.

(If the option to share the folder isn't available, look at the bottom of the Sharing tab. Does it say that remote connections to this computer are disabled until you run the Network Setup Wizard? I had already run the wizard, but if you haven't, you must do so before you can share the folder.)

_______________________

This should do it my friend.  Looks like you have everything else in order.
0
 
aktivemofoAuthor Commented:
Hi all,

this was the first question i have logged via Experts Exchagne, and almost choked on my coffee this morning when i saw 7 responses!

I'd like to thankyou all for your help and time spent on this issue.

I now face the problem of having to distribute the ponts..

Thanks again,

Dean.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now