Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1421
  • Last Modified:

error opening a CHM file

Hi All

I am trying to open a chm file from a client. I am using IE 5.

I have used <a href="help.chm">

but the link opens the chm file with some jhunk data
satrting with ITSF. It is not opening the download dialog. DO I need to set the MIME type some where.

output:
ITSF`/Ît ý|ª{О  É"æìý|ª{О  É"æì`xTÌþNTITSPT ÿÿÿÿÿÿÿÿ j’].!Нù É"æìTÿÿÿÿÿÿÿÿÿÿÿÿPMGLi

Please help
Ramakrishna
0
ramakrishnav
Asked:
ramakrishnav
  • 3
  • 2
  • 2
  • +4
1 Solution
 
webtransCommented:
yes this maybe a solution
making a page that dispose the files in the browser with the appropriate header
or make sure that the chm version is the same
0
 
Cyber-DudeCommented:
It could be one of the following:
1. A corrputed chm file.
2. Or a non propper application trying to open the file.

I would suggest running the following procedure:
1. Operate the OS in command prompt by pressing F8 during POST and choosing 'Command Prompt' from the menu.
2. Run the following: scandisk
3. Run: scanreg /fix
4. Restart the OS and try again.

Cyber
0
 
EvarestCommented:
Download the html helpfile to a location on your HDD instead of opening it directly from in IExplorer.
Then try to open it by browsing to it in Explorer.

If this opening doesn't work, download HTML Workshop from

http://go.microsoft.com/fwlink/?LinkId=14188

Install and open the program. Then go to the menu: File|Decompile...

Give in a folder in Destination Folder.
Browse for the Compiler (CHM) Help File to fill it in in the second editbox.

All HTML+Images etc will then be extracted from the CHM. If this doesn't work, the problem lays with the CHM itself. It'll probably be corrupt.

If this works, you can browse the CHM just like you browse a website. If you want, you can recompile it into a CHM. (use File|Compile... from the menu and browse for a .hpp file).

Kind regards,
Evarest

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
ramakrishnavAuthor Commented:
Hi Thanks all for the immediate reply.

 I think there is no problem with the chm file because, if i try to open the same chm file on my local drive using IE it is poping up with download dialog box. But from the server if I use the fullpath to that chm file it is not opening the download dialog box. I dont want it to open online. I just want to download it to my machine.

Thanks
Ramakrishna
0
 
EvarestCommented:
Try using a download manager to download the file to your HDD... A simple small download manager will do. Just pick one from the list :-)

http://www.download.com/3120-2001-0-1-0.html?qt=download+manager&author=&titlename=&desc=&dlcount=&daysback=&swlink=&gfiletype=&os=&li=49&dlsize=&ca=

(it's all freeware)

Evarest
0
 
Arno KosterCommented:
to download the CHM file right-click on the link and select "save as"...
0
 
EvarestCommented:
The simplest of things we sometimes forget :-)
0
 
YasutakaCommented:
Hi,

I'm not sure what is causing this, but you can try the following...

Seems like you need a setting on the server (which hosts the chm file).
Go to the web server and open up Internet Infromation Services (IIS) Manager from the Administrative Tools and follow the steps given below:

1. Right click on your web application and click Properties from the context menu. Will look like this in IIS Manager.
    - Internet Information Services
       - <your machine name> (local computer)
          - Web Sites
             - Default Web Site
                - myWebApp
2. In the Properties dialog-box, click "HTTP Headers" tab
3. Click on the "MIME Types" button
4. In the MIME Types dialog-box, click "New"
5. In the MIME Type dialog-box, enter ".chm" for the "Extension" field, and "application/octet-stream" in the "MIME type" field, without quotes.
6. Close all the dialogs by pressing OK

Now, please try accessing the .chm file from your client. In case it still doesn't work, I'd restart the Web Server once, and try again.

Hope this works. If it didn't, you can reverse the settings by going to the same MIME Types dialog-box and removing the ".chm" extension that you just added.

thanks!
-Yasutaka
0
 
santosh26676Commented:
May be you check the path of the chm file. Also, ow about trying to open the chm file in a seperate window instead of same window.

Hope this helps.
0
 
ramakrishnavAuthor Commented:
Hi,
Thanks all for  the suggestions,

I hope this is the problem with the webserver settings.

If i right click the link and save in to my desktop, the chm file is opening with out any error. I dont know why it is not opening the dialog window when I left click.

Interestingly, I have found some sites in the internet which are having the same problem.

Try this link.
http://www.axciton.com/downloads/AxcitonManualSp.chm

This is the problem I am getting.

thanks
Ramakrishna
0
 
Arno KosterCommented:
when I try to save the file it assumes a .html extension.
I guess the axciton server assigns the wrong MIME type to the chm extension !

I suggest you find out the MIME type used for chm files.
It should be something like "C:\WINNT\hh.exe"
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now