Arcserve Database engine will not start

Arcserve 2000 Version 7

The database engine will not start after restarting the server:

Get the following: Timeout while starting database engine.
Errors codes in the Arcserve activity log:
2005 & 2009

Tried stopping and re-starting all services related to Arcserve, no effect.
The server did run out of space and looks like this is part of the problem, there is now space available on this server though.

Just to mention that the c:\program files\computerassociates\Arcserve is 12.9GB and there are some extremely large files which are:
astpsdat.000
astpsdat.001 etc...
asobject.000
asobject.001 etc...
These files alone are 1.55GB

rds.exe is running at nearly 100% all the time.

??
LVL 1
Artform04Asked:
Who is Participating?
 
dovidmichelConnect With a Mentor Commented:
If the above do not work then looks like the problem is in the engine itself and a reinstallation to clean it up.
0
 
Cyber-DudeCommented:
Check your hard drive whether it is full...

Cyber
0
 
Cyber-DudeCommented:
Also, do use trial version of ArcServe?

Cyber
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Artform04Author Commented:
Have space on the HDD, now, didn't have when the problem occured.

No it's not trial software.
Cheers.
0
 
Cyber-DudeCommented:
Try to restart the service... What are the results?

Cyber
0
 
Artform04Author Commented:
All restart fine apart from the "database engine" service which tries to start but fails after timing out.
0
 
Cyber-DudeCommented:
I see, is your ArcServe database located on an SQL server? Try to see all services list on the server and just follow all 'automatic' services to see if they started. I know that the database service is related to another service. OR try to restart the Server.

Cyber
0
 
dovidmichelCommented:
The database has a fress space threshold so it should have stopped updating prior to the disk filling.

astpsdat is the database that contains the list of all files and directories backed up that is why it is so large.
Here are some things to try, easiest first.
close the Manager and then delete all the arcserve\database\r*.* files.
Run the database repair utilities, readme in the ARCserve directory.
or Just initialize the database, ARCserve Server Admin, Database tab, Operation, Initialize.
Tapes will have to be merged back in after initializing or you can do a Recover.
All else fails this should work.
Install ARCserve to a different system (tape device not needed).
After the install delete the contents of the current corrupt database directory and then copy in the contents of the temp install database directory into it.
Now you should be good to go.
0
 
Artform04Author Commented:
Thanks for advice but....

Deleted all the r*.* files
Couldn't find the repair tools or the readme file,
the Initialise of database was greyed out.

Tried copying all the database files from and old backup server but this still wouldn't allow the service to start.

Any more ideas..
Cheers
0
 
Cyber-DudeConnect With a Mentor Commented:
Dont mess arround withit
Try to repair the installation; Do you have the original CD?

Cyber
0
 
Artform04Author Commented:
Had to do a Re-installation in the end, got it working.

Thanks for advice ppl.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.