New pc with xp on lan

Hi,

I have a lan with a win2k server
Static ip
Workstations named p1, p2 etc.

A friend brought me his pc with xp home, I configured the tcp/ip properties, so it can use my internet connection, it surfs fine.

I need to copy some folders/files on mine in order to burn the data for backup purpose.

How do I access either way, it really doesn't make any difference
server seeing the pc
or
pc seeing the server

Although I'd rather make the changes on the pc.

Thank you
LVL 7
kenesoAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Tim HolmanConnect With a Mentor Commented:
Good point.  You need TWO things to access domain resources:

1)  WORKGROUP name IDENTICAL to DOMAIN name
2)  Matching username and passwords on the XP Home machine AND the NT/2000 domain, so TWO sets of user accounts

Quite nicely summarised here:

http://www.wown.com/j_helmig/wxphdoms.htm
0
 
LucFEMEA Server EngineerCommented:
Hi keneso,

Check the workgroupname, it has to be the same as the others on the network (if this is a domain, make sure the workgroupname matches the domainname)
Also check if file and printersharing is enabled.
Now all should show up in network neighbourhood.

If it doesn't work right away please check if you can reach the others by the IP-address.

Greetings,

LucF
0
 
JohnItemCommented:

LucF is correct and you should verify you can ping first, and that the workgroup name match.

Afterwards please follow these steps on XP machine.




If you can ping the server, the only other thing missing is the enabling of file and printer sharing on the machine.
___________________________________
Sharing 101
Windows XP Professional supports two types of file sharing: simple and advanced. Simple file sharing works just like it does in Windows XP Home Edition. You have only two choices to make:

• Whether you share a folder on the network
 
• Whether users can change files in the shared folder
 

If you choose to deny users permission to change files, Windows XP Professional gives everyone Read access to the share. Otherwise, the operating system gives everyone Full Control of the share.

To Share a Folder Using Simple File Sharing

1.
 Create the folder you want to share. I like to create shared folders either in My Documents or on the desktop to keep them from hiding.
 
2.
 Right–click the folder and then click Sharing and Security. The Sharing tab of the Properties dialog box for the folder opens, as shown in Figure 1.
 
3.
 Click the Share this folder on the network check box. This makes the folder visible on the network.
 
4.
 Click the Allow network users to change my files check box if you want network users, including yourself, to be able to modify your stuff on the network.

(If the option to share the folder isn't available, look at the bottom of the Sharing tab. Does it say that remote connections to this computer are disabled until you run the Network Setup Wizard? I had already run the wizard, but if you haven't, you must do so before you can share the folder.)

_______________________

This has got to work... You have everything else working.

(I hate XP simple file sharing)


0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
LucFEMEA Server EngineerCommented:
0
 
kenesoAuthor Commented:
The server has a domain name
Then there is a workgroup

Where do I change/check the workgroup name?

I can ping the server, no problem.
The xp can access internet, no problem.

But when I try
start > run > 192.168.10.2\c$
from the xp it asks for an id and psw
when I do from server it gives me access denied

So please give me step by step procedure to chenge settings on the xp
0
 
kenesoAuthor Commented:
I can't ping the xp from the server
0
 
LucFConnect With a Mentor EMEA Server EngineerCommented:
>>Where do I change/check the workgroup name?<<
Right-click "my computer" => "Properties" => "Network identification" => "Network ID"
(the location could be a bit off, I'm using win2k)

>>start > run > 192.168.10.2\c$
>>from the xp it asks for an id and psw
Have you tried "<domainname>\Administrator" as the name? with the administrator password

>>when I do from server it gives me access denied<<
WinXP home doesn't like these kind of things and try opening a share, and then accessing it from the server by:
Start run \\<IP-addres>\Sharename

LucF
0
 
JohnItemCommented:

keneso,

Have you tried the Microsoft steps I listed above?  They have solved these issues in the past.
0
 
JohnItemCommented:
Indeed LucF, the content between break lines on my second-last post is a cut-and-paste from Microsoft's "Windows XP Networking: Sharing in the Home Office".

My intention in pasting was to expedite the answer, never to claim as my own. I thought it obvious as such.
0
 
LucFEMEA Server EngineerCommented:
Don't worry JohnItem, I was just pointing out that your post could be considered as Plagiarism. All you have to do is post your source with you comments if needed.

Thanks,

LucF
0
 
Tim HolmanCommented:
Can't you just join the XP machine to the domain ?
0
 
wparrottCommented:
tim_holman wrote:
"Can't you just join the XP machine to the domain ?"

Since the computer in question is an XP Home, he cannot join it to the domain. See this:

http://www.microsoft.com/windowsxp/pro/evaluation/overviews/joindomain.mspx

Follow LucF's suggestion from above to set the workgroup name on the XP Home to the same name as your Windows 2000 domain. On your comptuer do this:

1. On your computer, create a folder called 'Share' on your hard drive.
2. Move or copy the files you want to copy to the other computer to this folder.
3. Right-click the folder and choose 'Sharing and Security'.
4. Choose the button next to 'Share this folder'. It will name the share 'Share'.
5. Click the permissions button. Make sure that you see 'Everyone' listed under 'Groups or user names'. If it isn't, click the Add button and type 'Everyone' and press enter. It should now be added to the list. Click Ok to close that window.
6. Click the 'Security' tab and add 'Everyone' to the 'Groups or user names' as above. The default permissions and security permissions are read only. Click Ok to close the properties window.

Now go to the XP Home computer and browse to your computer either by typing the '\\yourcomputername' or '\\yourcomputerip' in the Run dialog.

You should see the 'Share' folder and be able to open it to copy the files. The drawback to this is that any user on your network can browse the 'Share' folder. If this is a one-time deal, just remove the share by doing steps 1-4 above and choose 'Do not share this folder'.


Hope this helps...

0
 
kenesoAuthor Commented:
>>Since the computer in question is an XP Home, he cannot join it to the domain

Yet another brilliant prove of what MS is ... even win98 did allow to join a domain ...

I tried the share folder suggestion ... but for some reason, unknown to me, and guess you too, it wouldn't work.
I did it 4 times ...

Anyway tim_holman's link did the trick.
LucF gets a few for the admin suggestion.

Thank you all for the time and effort.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.