?
Solved

Bind on RHEL 3 not resolving all web sites or it resolves main site but not sub domains.

Posted on 2004-09-06
7
Medium Priority
?
235 Views
Last Modified: 2010-03-17
RHEL 3 bind problem. It resolves web sites for a while then stops with hostname cannot be found error. Or it resolves the main url www.yahoo.com but no subdomains. It can still resolve some sites and not others.  All zone files look ok not sure whats happing. Also if I run dig www.yahoo.com all
yahoo servers are shown.
0
Comment
Question by:chetw18504
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11990866
i dont think that is a bind problem, but paste your conf files in here to see if you have any error
0
 

Author Comment

by:chetw18504
ID: 11990925
// generated by named-bootconf.pl

options {
      directory "/var/named";
      /*
       * If there is a firewall between you and nameservers you want
       * to talk to, you might need to uncomment the query-source
       * directive below.  Previous versions of BIND always asked
       * questions using port 53, but BIND 8.1 uses an unprivileged
       * port by default.
       */
      // query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
      inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };

      inet 192.168.1.211 allow { 127.0.0.1;         # localhost
                                  192.168.1.0/24;    # local Ethernet
                          } keys { "rndckey"; };


};

logging {
category lame-servers { null; };
};

zone "." IN {
      type hint;
      file "named.ca";
};

zone "localhost" IN {
      type master;
      file "localhost.zone";
      allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
      type master;
      file "named.local";
      allow-update { none; };
};

zone "home.com" {
      type master;
      file "home.db";
      allow-transfer {
          192.168.1.201; };
};

zone "1.168.192.in-addr.arpa" {
      type master;
      file "home.rev";
};

include "/etc/rndc.key";
$TTL 3D
@      IN      SOA ns.home.com.  chetw.home.com. (
      200409019      ; Serial
      7200            ; Refresh      - 2 hours
      3600            ; Retry            - 1 hour
      43200            ; Expire      - 12 hours
      3600 )            ; Minimum      - 1 hour
;
                  NS      ns.home.com.
                  NS      web.home.com.
                  MX      10      ns.home.com.

;
ns      A      192.168.1.211
web      A      192.168.1.201
xppro      A      192.168.1.10
www.web1      CNAME      ns.home.com.
www.web2      CNAME      ns.home.com.
www            CNAME      ns.home.com.

$TTL 3D
@      IN      SOA ns.home.com.  chetw.home.com. (
      200409015      ; Serial
      7200            ; Refresh      - 2 hours
      3600            ; Retry            - 1 hour
      43200            ; Expire      - 12 hours
      3600 )            ; Minimum      - 1 hour
;
                  NS      ns
                  NS      web

;
201            PTR      web.home.com.
211            PTR      ns.home.com.
10            PTR      xppro.home.com.
      

0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11991081
i think that is ok. only i correct this in the reverse resolution

NS ns.home.com.
NS web.home.com.

dot at the end
0
Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

 
LVL 40

Expert Comment

by:jlevie
ID: 11992662
Your server looks to be behind a firewall and that typically means that you want to uncomment (remove leading //):

     // query-source address * port 53;

That could well explain the behaviour you are seeing.
0
 
LVL 4

Accepted Solution

by:
jonnietexas earned 0 total points
ID: 11993124
Add this to your global section...

        forwarders { 151.164.1.8; 157.164.11.201; };
        allow-query { 192.168.1.0/24; 127.0.0.1; };

Where the 151 and 157 address is your ISP DNS server.
0
 

Author Comment

by:chetw18504
ID: 12010593
The solution is in the above statement I switched my named.conf file for a copy that I had edited and forgot to put in the forwarders {192.168.1.1: }; option into the new file. As soon as I added the option back everything worked fine again. A foolish oversite on my part. I should have looked the file over more closely before I posted the question
0
 
LVL 4

Expert Comment

by:jonnietexas
ID: 12010696
Cool. Glad I could help.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses
Course of the Month8 days, 21 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question