Default root password for RedHat Linux


Does anyone know the default root password for RedHat Linux?

Who is Participating?
net_sec_guruConnect With a Mentor Commented:
best bet is to reset it...

Boot into single user mode and then do a "passwd" to reset the root password.

If you are running Lilo you can enter the name of the OS you want to boot like: redhat -S (will boot into single user mode).

On an x86 system using GRUB as the boot loader, use the following steps to boot into single-user mode:

If you have a GRUB password configured, type p and enter the password.

Select Red Hat Enterprise Linux with the version of the kernel that you wish to boot and type a to append the line.

Go to the end of the line and type single as a separate word (press the [Spacebar] and then type single). Press [Enter] to exit edit mode.

Back at the GRUB screen, type b to boot into single-user mode.

On an x86 system using LILO as the boot loader, at the LILO boot prompt (if you are using the graphical LILO, you must press [Ctrl]-[x] to exit the graphical screen and go to the boot: prompt) type:

linux single

For all other platforms, specify single as a kernel parameter at the boot prompt.
there is no such thing as a default password for a root account.
If you lost your password yuo should boot in to single user so you can reset it.
DClaydenAuthor Commented:
How do I do that? On setup, I was asked to setup a user and password, which I did. But, when logged on as this user, if I try and change anything it asks for a root password (which I was never asked to set).
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.