MailScanner Unable to Reply back to Sender

I have Configured Mailscanner 4.33 with ClamAv 0.75.1 and sendmail 8.12.5 as MTA on Redhat 8.0
i have configured Mailscanner such that the infected email messages should detected my mailscanner should reply back to sender specifying the infected virus found from the sent email
as well as to receiver of the infected email

In /etc/MailScanner/MailScanner.conf

Notify Senders = yes
Notify Senders Of Viruses = yes
Notify Senders Of Blocked Filenames Or Filetypes = yes
Notify Senders Of Other Blocked Content = yes

The receiver of the message gets the warning infected email message

Now the problem is that the sender of the email message is not receiving any infected warning email message ???


Thanks in Advance
rajuraikarAsked:
Who is Participating?
 
jlevieCommented:
What does your maillog show when MailScanner tries to reply?

In /etc/mail/access is the localhost allowed relay access, e.g.,

# by default we allow relaying from localhost...
localhost.localdomain           RELAY
localhost                       RELAY
127.0.0.1                       RELAY

FYI: Notifying senders of viruses is a bad idea. The bulk of the viruses your server will see are sent by the virus itself and it forges the sender. So bouncing a message back won't go to the user who's PC is infected, but rather to some innocent party who's email address happened to be on the infected machine.
0
 
kenfcampCommented:
1) Ditto to jlevie's comment. Don't do that, Though your objectives are legitimate, you're just adding to the "spam" problem.

> Now the problem is that the sender of the email message is not receiving any infected
> warning email message ???

There could be a number of reasons for this.
1) Your domains reverse DNS isn't setup/setup properly (aol, earthlink, etc look at this)
2) You could be sending mail to a invalid account
3) The IP block your IP belongs to could be black-listed
4) Sendmai and or Mailscanner isn't setup properly
*But since the intended recipient is getting their message I don't think this is the problem

My advice would be to disable the feature, but if you want to be sure, get a copy of netbus or other trojan/virus (or infected email), and forward it to yourself.
*though you may need to temporaly disable spamassassin to do it as you may get one message but not the other

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.