No drive letter appears in Win 2000 when I moved a HD from computer A to computer B

Computer A died this afternoon. Win XP.  I moved the D: drive with my data to computer B which had only a C: drive. Win 2000. Jumpers seems correct as the BIOS says the second disk is there and all the qualites of it are presented accurately. Maxtor 120 GB. (it worked fine in computer A)  When I carry out the sequence My computer to the device manager it says the device is working correctly. When I go to My Computer > manage > disk management   I get a window which indicates the C: (disk 0) drive FAT 32 (healthy) and for the next drive  (disk 1) there is no drive letter and over the "Disk 1" there is a yellow triangle with an ! in it. (I believe this is FTDS) With "dynamic"  underneath it.  Right clicking on Disk  1 and selecting "properties" I get status: foreign  Capacity 0 mb  unallocated space: 0 mb device type: IDE(port 0. Target ID: 1, LUN:0) then Maxtor 6y120L0 (which is what it is) and adapter name: primary IDE channel. In a window below it: Volumes contained on this disk: there is nothing for volume and capacity.

Going back to right clicking on Disk 1 (where there is the yellow caution sign) there is an item "Import fireign disk"  is this what I need to do?

This Q is urget as I need the data to complete a grant application (fortunately I am pretty well backed up, but losing a day is not good ...
HealthMapsAsked:
Who is Participating?
 
matthew_netcentralConnect With a Mentor Commented:
HealthMaps:

I have had the same exact situation and have had no problems (and I have done this at least 100 times) right clicking, clicking import foreign disk.  It will even remember the drive letter (if not used) that if was previously assigned.  This is not dangerous.  I have a 120GB WD that i use back and forth between two computers, not even with a USB kit, just manually hooking it up, and each time i need to do this.  It works like a charm and i stand by mine and mcp_jon's suggestion.

Adios.

Md@networkcentralusa.com
0
 
Cyber-DudeCommented:
All you need to do is to asign drive letter to the second hard drive;
Right Click 'My Computer' and choose 'Manage' => 'Disk Management' => Right click the second drive and click 'Assign drive letter'... Continue from here...

Cyber
0
 
LimeSMJCommented:
Was this Maxtor hard drive part of a dynamic disk group in XP - Simple, Mirrored, RAID-5, Striped, or Spanned volumes?  The import feature you see is only for dynamic disk sets and can delete all of the data on the drive if imported incorrectly.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
mcp_jonConnect With a Mentor Commented:
You need first to import the foreign disk, and only then assign it a letter !

Best Regards !
0
 
mcp_jonCommented:
And don´t worry, if it´s in NTFS, Windows 2000 can also read it, even if it is in Dynamic mode, windows 2000 can still read it.

Hope I could help you out !

Best Regards
0
 
Ant0n1zCommented:
do as mcp_jon said. Just import foreign drive assign it a letter and I recommend DO NOT MESS WITH THE ACCESS RIGHTS!!
if you can see the files copy them , do not mess around with the rights,..... been there done that , the world heard me screaming... ;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.