Solved

External USB2 (and probably FireWire) drive: delayed Windows write error

Posted on 2004-09-07
16
3,110 Views
Last Modified: 2009-07-29
I have an external 120GB WD disc in a USB2 enclosure. The device keeps connecting and disconnecting occasionally and I get a "Windows - Delayed write failed" error. This happened on 3 PCs, with VIA and nForce chipsets on Windows XP. Same happened also when using a Seagate HD (both brand new). I also replaced the USB2 enclosure (tried both 3.5 and 5.25), USB cable, etc.
I also tried all the tips recommended on this very thorough discussion thread: http://forums.viaarena.com/messageview.cfm?catid=16&threadid=50469
I upgraded the BIOS and the system is configured correctly to page memory for programs (I also tried the "System Cache" option).
The same thing also happened on one PC when writing to a USB2 disk on key and also in the middle of a USB2 DVD-R burn.
I did not try it on other OS but heard this also happens with FireWire external drives.
It seems to be a MS bug but there is no MS documentation
0
Comment
Question by:GMsb
  • 5
  • 2
  • 2
  • +5
16 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 11997017
I have a USB 2.0 external drive that works fine, so I would not say it's an OS bug.  The delayed write error is happening because the system senses your drive losing it's connection at random times.  Since it is using a write-cache, this causes the error to appear.  Fixing sporadic USB connections involves trying different USB ports, and perhaps a powered USB hub.  I have noticed that USB behavior can vary from motherboard to motherboard, so it may just be a case of a marginal controller or port.  You could also get a PCI USB card and try that.
0
 
LVL 2

Expert Comment

by:texasjpm
ID: 11997056
Are you sure the port on the PC is a USB 2 port?
0
 
LVL 6

Expert Comment

by:icemanwol
ID: 12002795
What windows service pack are these computers running?
0
 
LVL 5

Author Comment

by:GMsb
ID: 12004189
I am sure it's USB2. I will try with a PCI USB2 card as well. Maybe it is a problem with certain controllers.
Win XP SP1. I should also check with SP2 but I read that it didn't help.
0
 
LVL 4

Expert Comment

by:gusdarino
ID: 12008439
In reading the previous threads something caught my attention.

1. You tested the USB2 HD on another computer and it worked fine.
2. You tried a different USB Cable, etc.

Where are you plugging in the power adaptor for the USB2 HD?
Try connecting the computer and the Power supply on another plug.  Preferebly in another room and or opposite wall.  Most houses are wired in series and switching plugs that are next to each other wont help.

The reason I recommend this is that I also run external HD's and CD-ROM's without a problem in 2k and XP.  You tried moving the drive to another machine and it worked fine.  The only thing that you did not test was moving the computer and USB2 HD to a different power source.  

Also check your UPS or Surge Protector.

Gus
0
 
LVL 1

Expert Comment

by:eXPaine
ID: 12024025
Have you tried accessing the external drive using WD's Data Lifeguard Tool?  I guess you have formated the drive in NTSF.   Do you have a FAT partition in that drive?
NTSF is a common culprit that involves in "delayed write" trouble among high-speed external devices.

In addition to the USB hardware controller, one important element that determines whether it's a usB?$!h is the chipset in your enclosure, such as Prolific or Oxford, etc., the latter may make life with an external enclosure a bit easier.  

It's very hard to be a successful matchmaker between USB2 or firewire devices.  They are very hardware-dependent and system specific.  Can you be more specific on your hardware and software parameters?

Other than trying different USB card(such as one with NEC chipset) or ports, you may also try the following:

Under the USB Controllers Properpties in Device Manager, find out to which USB root hub your external drive is connected.  then UNcheck the "Allow the computer to turn off this device to save power" under "Power management"
see if that may help.

Best of luck.
0
 
LVL 5

Author Comment

by:GMsb
ID: 12035552
I used an external power supply connected to the external enclosure. I used it on computer in different locations. This is not the case.
0
Google Storage: Standard vs. Nearline vs. Coldline

Google Cloud Storage has a number of classes to choose from. Although there are a lot in common, they vary in price and usage terms. This post explains Google Cloud Storage classes and helps to understand which  one to choose.

 
LVL 2

Expert Comment

by:icedrop-dcse
ID: 12039058
0
 
LVL 5

Author Comment

by:GMsb
ID: 12167422
I tried everything except using a USB2 PCI card. Everything failed so far. I also tried XP SP2. The external USB2 HD did not work properly on another PC. Tried it on different ports and with a different power source which is actually just a conventional power supply, actually it does not work at all without external power supply.

The on-board USB2 controller used is NEC. The motherboard is MSI KT3 Ultra.

I also went over the MS KB entries suggested by icedrop-dcse in the thread – no help there.

As for NTFS – I don't think it is the problem but I will try a FAT partition as well.

0
 
LVL 1

Accepted Solution

by:
HongChia_tan earned 500 total points
ID: 12220334
I came across this post from Jim Key in another group a while back and decided to save it.  Hope it might be of help.

Quote-

My friend Steve, the one with the "Delayed Write Failure" problem, sent me a
couple of postings he's come across in his search for a cure - thought it
might be helpful to some, and it points in the same direction about 128k
packet size for data transfer mentioned by J.P. Weiksnar...

First one:
---------------------------------
When a large data-transfer from an internal drive to an usb2.0 drive is
iniciated, the internal drive asks if the external drive is there, by
sending a
small data-package, in wich lies info like package-size,etc. (in other words
it says : hi external drive, are you there ? can I send ... data-packages of
... kb ? . The external drive then confirms by sending a small data-package
back. So the internal drive then sends another data-package to confirm the
confirmation (sounds weird, but this is the three-way rule. It's always
applied
in every data-communication). So the data-transfer begins. Internal drive
starts to send small packages, asking confirmation for sending bigger
data-packages, and starts to send bigger and bigger packages. For some
reason, after a while, it starts sending packages bigger than 128kb and
that's when
communication jams up (probably at the point when sending packages bigger
than 256kb), because windows is like defaulted for packages of maximum
256kb. Result : writeback is delayed, and communication is lost. So you get
the error : event-id : 50 / Windows delayed write failure / source : ntfs.

It's a writeback cashing problem, and it's most likely software-based.
And the only one who can really fix this is microsoft, but too bad it's not
at the top of their list (what did you expect...)

Here is a link to a guy who wrote his own test program to confirm that...

_http://www.bustrace.com/products/delayedwrite.htm_
(http://www.bustrace.com/products/delayedwrite.htm)

And his letter...

I looked at the specific I/O that was failing and I noticed that Windows was
attempting to write out 3FFh sectors (1023 sectors) in a single I/O. This
is approximately 512K worth of data in a single I/O. I thought this was
interesting as Windows typically does not send an I/O larger than 64K and very
rarely above 128K. The I/O eventually timed out but the drive was now "hung"
and further communication with the drive was impossible. Windows was left
in a
state of needing to read/write to the drive, but it couldn't. When Windows
cannot flush its buffers, it reports the "Delayed Write Failure" telling you
that data may be lost.
512K worth of data in a single I/O was a clue so I wrote a special test app
that would read/write starting with 1 sector and keep going up until 1024
sectors. I wanted to find out where the failure boundary was. As it turns
out,
both of my 1394 drives would crash when the request was larger than 128K.
In digging a little deeper, and in talking to various people, this seems to be
a known limitation with some (not all!!!) 1394 bridge chips. I was told
that a firmware upgrade might/should resolve it.
I searched long and hard for any firmware updates to my SmartDisk and ADS
Technologies drives but I couldn't find any. If you know of any such updates,
I encourage you to _contact me_ (http://www.bustrace.com/support/index.htm)
so that I can update this WEB site with that link information. Determined to
fix this problem, and get confidence back in 1394 hard drives, I decided to
write my own little filter driver to limit I/Os to no larger than 128K.
What has been the result of my driver? Well, in many months of running my
SmartDisk drive, I have not seen that Delayed Write Failure again. If you're
seeing this failure as well, it is highly likely that you are experiencing
the same problem I did.
What can you do to resolve this in your case? For one, contact your drive
vendor and/or 1394 enclosure company. They are the ones that should come up
with a resolution for you. If they have heard of the problem before, but do
not know the root cause, point them to this WEB site. I have described in
detail exactly what the problem is. If they have a driver writer on staff,
they
should be able to easily generate a driver to resolve the problem.
Please do not ask us for our driver. While it works fine in our case, it is
only intended as an internal driver and is not something we would consider
distributing outside the company. Thank you.
0
 
LVL 2

Expert Comment

by:texasjpm
ID: 12434936
I think that the Comment from HongChia_tan on 10/04/2004 02:22PM CDT Gives the best explanation of why te problem happens and what you need to fix it.
0
 
LVL 1

Expert Comment

by:HongChia_tan
ID: 12435057
I wonder if the origianl poster has his problem solved... it seems that there is not really any response though.
0
 
LVL 5

Author Comment

by:GMsb
ID: 12452186
Sorry I am asking this question on behalf of someone and I have some hard time getting answers from him,
If I'll not get answer in couple of days I'll grant the points to HongChia_tan  
0
 
LVL 5

Author Comment

by:GMsb
ID: 12453813
I got the answer from him:
I was not able to resolve it no matter what I tried. It seems this post proves this is a Windows issue. I do not believe each drive and USB chip manufacturer should create a driver to solve it. This has to come from Microsoft transparently.

Go I am ganting Hongchia the points
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Sometimes the best way to deal with an infected computer is to boot from external media and run your tools from there.  The reason you may wish to do this really depends on the infection.  Some malware is so recalcitrant that no matter what you do i…
A bootable USB key can be very handy now-a-days. My favorite USB key consists of our Windows 7 image, network card drivers (to connect up to a Ghost server), the latest BIOS updates for all of our PCs and CopyWipe (to erase a retired PC) Creating…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now