Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Information Store won't start probably permissions problem.

Posted on 2004-09-07
17
1,069 Views
Last Modified: 2012-05-05
Part two I have exchange installed in another domain, with child domains.

I am getting  a few errors when starting exchange:

the main one I think being that the information store is not starting properly in the event viewer I have:

Unable to initialize the Microsoft Exchange Information Store service.   - Error 0x80004005.

Also I get error ID 1121.

I pressume its a permissions thing, but what to change?
0
Comment
Question by:matjc
  • 6
  • 6
  • 4
  • +1
17 Comments
 
LVL 8

Expert Comment

by:xxgenius
ID: 12000129
what services aren't started? is the system attendant starting. why do you think its not running? any recent changes, i'm not familar with "part 1".
0
 
LVL 12

Expert Comment

by:ColinRoyds
ID: 12000355
0
 
LVL 12

Expert Comment

by:ColinRoyds
ID: 12000371
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 12

Expert Comment

by:BNettles73
ID: 12001312
The IS may not be starting due to several reasons ... can you list all of the errors you are seeing in the application logs, when you try and restart the IS?
0
 

Author Comment

by:matjc
ID: 12007340
ColinRoyds, I have checked with the polilcy check tool and it says everything is ok. I am running exchange 2003 all of the articles you pointed me to where 2000, this is the only exchange server -> HOWEVER the global catalogue server is in the parent domain.

BNettles73 here you go:
These are in the order that they appear in the event log:

Application:
     Source: MSEXchangeSA ; Event ID: 9098 ;The MAD Monitoring thread was unable to read its configuration from the DS, error '0x80004005'.
     Source: MSExchangeDSAccess ; Event ID: 2103 ; Process MAD.EXE (PID=608). All Global Catalog Servers in use are not responding: <forest DC>
     Source: MSExchangeFBPublish ; Event ID: 8197 ; Error initializing session for virtual machine <exchange server>. The error number is 0x8004011d.    Make sure Microsoft Exchange Store is running.
     Source: MSExchangeIS ; Event ID: 1121 ; Error 0x80004005 connecting to the Microsoft Active Directory.
     Source: MSExchangeIS ; Event ID: 5000 ;Unable to initialize the Microsoft Exchange Information Store service.   - Error 0x80004005.
0
 
LVL 12

Expert Comment

by:BNettles73
ID: 12007388
Looks like communications issues between your Exchange and Global Catalog server ... if the exchange cannot see the DC/GC then the IS will fail ... Do you have your settings configured to auto-discover or are they set manual? How many GC's do you have? Is Exchange on the same box?
0
 

Author Comment

by:matjc
ID: 12007511
Settings to auto-discover or manual -> where is this set?

GC's -> one I believe on the DC of the main forest DC.

Is there a requirement for a GC in the local domain?
0
 
LVL 12

Expert Comment

by:ColinRoyds
ID: 12007609
You should have a GC on all local networks as all resources are listed here, so when a service or client needs object it will contact the GC for the relevant info
0
 
LVL 12

Accepted Solution

by:
BNettles73 earned 500 total points
ID: 12007785
Open system manager > expand to the server > open the server properties and click on Directory Access > you can choose the drop down menu to view the servers that are auto-discovered for Domain Configuration, Domain Controller, and Global Catalog ... chances are they are on auto-discover (which they should be) ... you need to make sure your Exchange has a constant connection to a DC/GC ...
0
 

Author Comment

by:matjc
ID: 12007791
How do I (re?)-create the GC on the local domain controller or the exchange server? (I pressume the DC).

The parent (forest DC) and child DC are on the same subnet and can talk to each other.
0
 

Author Comment

by:matjc
ID: 12007832
BNettles73 : there are no GC's listed on the server properties, only the child domain controllers are listed.

Autodiscovery is turned on.  How do I get a GC locally (I pressume at the moment the only GC is in the parent domain)
0
 
LVL 12

Expert Comment

by:ColinRoyds
ID: 12007853
Open AD Sites and Services
+sites
+sitename
+servers
+the servername where you want the GC
+NTDS Settings
right click NTDS settings go to properties
put a tick in global catalogue
0
 
LVL 12

Expert Comment

by:BNettles73
ID: 12008021
Do you have a domain controller setup in the child domain?

I'd setup a DC in the child domain and configure replication accordingly ...

You can make a server a global catalog by -

Start the Microsoft Management Console (MMC) Active Directory Sites and Services Manager.
(From the Start menu, select Programs, Administrative Tools, Active Directory Sites and Services Manager.)
Select the Sites branch.
Select the site that owns the server, and expand the Servers branch.
Select the server you want to configure.
Right-click NTDS Settings, and select Properties.
Select or clear the Global Catalog Server checkbox
Click Apply, OK.
0
 
LVL 12

Expert Comment

by:BNettles73
ID: 12008026
I don't recommend you do this on your exchange server btw ... not really best practice
0
 

Author Comment

by:matjc
ID: 12008293
ok I have enabled GC on the child domain controller. I pressume this may take a while to propegate round.

I will restart the exchange server for ease of use and see what happens .. thanks for the help so far!
0
 
LVL 12

Expert Comment

by:BNettles73
ID: 12008500
check to see if it was auto-discovered ... if not, you may try forcing replication in sites and services ... and then check system manager
0
 

Author Comment

by:matjc
ID: 12008904
Thanks for your help, exchange at least starts now ..

In summary, just ensure that the exchange server can see a global catalogue, this may require this service being enabled on the local domain controller.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question