Solved

Problems sharing a printer

Posted on 2004-09-07
22
212 Views
Last Modified: 2010-03-18
I have two laptops, a desktop and a Netgear wireless router.  My desktop and one of my laptops can see each other and the laptop can print to my desktop printer that is shared, but my other laptop can't see any of my other computers or printers on the network.  This laptop can surf the internet but just can't see my other laptop or desktop on the network, i have configured my firewall on the laptop to have the network in its trusted mode, does anybody have any ideas for me to try and see what might be causing this problem, thanks ahead of time
0
Comment
Question by:jasondole
  • 12
  • 10
22 Comments
 
LVL 11

Expert Comment

by:Eric
Comment Utility
disable the firewall temporarily see if behavior persists

workgroup?  make sure all settings are the same including workgroup name, user accounts/pw and sharing mode (simple or advanced)

what OS's are each PC?  all XP?

can you ping the missing laptop?  (start, run, cmd(enter) , ping ipaddress)  
Try in both directions.

0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
they are all using windows xp, yes i can ping the computer, they all have the same workgroup name
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
Are they all configured for simple file sharing?  if so make sure the "guest" account is enabled on all machines.   Or make sure the same user name/pw exists on each machine.

Good chance its the firewall too.  What is it?  Norton internet security? Zone Alarm?  XP firewall?  Xp sp2 firewall?
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
Zone alarm, i have configured the zonealarm on the laptop that does not work the same as the two other computers, yes they are all configured for simple file sharing, i don't think the guest account has to do with my problem though
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
the guest account is used in simple file sharing for access.  I guess assuming the username/pw does not exist on each computer.  
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
yes,they do not exist on each computer
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
That is probably why.  make the same user on each workstation.
or
make sure the guest is enabled on all.

I dont like the guest account... i prefer option 1 and disable the guest account :)
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
i don't think that is the case because i just put a user name and password on the laptop that can see the desktop and print and nothing changed, if that was the case, then my computer should not of worked because the Desktop does not have a user name and password. Do you have other ideas as to why it might not be working?
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

if that does not answer it disable any personal (software) firewalls and retest.
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
would the router matter because it worked when i used a linksys router but since i have switched to the netgear, it does not work,  but why would the router only make a difference for one computer and not all of them, just some food for thought...I had the same problem when i tried D-Link...
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
I could see the computers when i type the ip address in, how can i check to see if there is a problem with the naming of the computer or dns, would that cause the problem
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 11

Expert Comment

by:Eric
Comment Utility
can you see files on the drives or map the printer?
pinging takes no authentication.
printer and file sharing does.

if everything works via IP addresses, check your network settings.  props of tcp/ip advanced.  make sure enable netbios over tcp/ip is enabled.
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
the netbois is enabled, when i try to connect to the workgroup, it says Workgroup is not accessbile. You might not have permission to use this network resource.
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
I do not think the router would play part.  In a Workgroup you do not use DNS.  Your only using DNS when it comes to internet use. (firewall obtains dns info from your ISP and forward all client requests to it)


the firewall could be blocking netbios traffic or something.  just disable it for a few minutes and see if it clears up.

you should be pretty safe w/o it for a little bit, you have an internet gateway/firewall in place.
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
I have diabled the firewall and the same problem persists, i think it has something to with teh naming of the computers because if i type the ip in the search for comptures, it finds the other computers.
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
i updated my firmware on my router and now i can see my own computer within the workgroup but not any of the other computers but before i was unable ot even browse the workgroup
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
does the node type of the laptops connection matter, the laptops computer that is not working node type is peer-to-peer where as the other laptop that is working node type is hybrid, if so, how do i change the node type
0
 
LVL 11

Accepted Solution

by:
Eric earned 175 total points
Comment Utility
node type? heh
wtf is that :o

so its clearly a netbiios problem.

what are the names?  some names may not be compatible.   they are not the same are they?
all netbios names must be unique.

this will not tell you why, but you could put this in your host file (just search for "host")
its in windows dir dirvers/etc maybe?

ip1     computername1
ip2     computername2
ip3     computername3

you will see a
127.0.0.1     localhost.     (use the same fromat)

0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
i fixed it, it was dealing with the node type, thanks for your help
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
where is that setting and how did you change it?  i never mess with the default network settigns.. i dont even see that one! :o

Thanks
0
 
LVL 1

Author Comment

by:jasondole
Comment Utility
i had to go into the registry and change the value of the ntb to 8 instead of 2
0
 
LVL 11

Expert Comment

by:Eric
Comment Utility
:|
hehe hrmm.
interesting.  how did it get wrong.. must be a toggle setting somewhere.

oh well it works :)
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

Suggested Solutions

Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
A common practice in small networks is making file sharing easy which works extremely well when intra-network security is not an issue. In essence, everyone, that is "Everyone", is given access to all of the shared files - often the entire C: drive …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now