• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1532
  • Last Modified:

How to configure an Oracle Connection Pool using oci8 from Weblogic 7.0

Gentlemen,

As part of our experiments, we are now trying to configure an Oracle Connection pool from Weblogic 7.0.

 

The Connection pool parameters we are using are on the Weblogic console (services->jdbc->connection pools):
 

Name: OracleConnectionPool

URL: jdbc:oracle:oci8:@(description=(address=(host=devt_oracle)(protocol=tcp)(port=1521))(connect_data=(SID=BizAgiOr)))

Driver ClassName: oracle.jdbc.driver.OracleDriver

Properties (key=value) : dll=ocijdbc8
                                    DatabaseName=BizAgiVision
                                    protocol=oci8

 

Since we are using the oci8 protocol, we installed the Oracle 8 client on my machine.

 

The URL connection string already worked in one of our coworker’s machine.

 

The classpath on startWLS.cmd (Weblogic start script) is


set CLASSPATH=%JAVA_HOME%\lib\tools.jar;%WL_HOME%\server\lib\weblogic_sp.jar;%WL_HOME%\server\lib\weblogic.jar;
set CLASSPATH=%CLASSPATH%;%MSSQLDRIVER_HOME%\msbase.jar;%MSSQLDRIVER_HOME%\msutil.jar;%MSSQLDRIVER_HOME%\mssqlserver.jar;
set CLASSPATH=%CLASSPATH%;C:\Downloads\Oracle\classes12.zip

where obviously classes12.zip was copied in this said path in my machine. .

 

The string "C:\Downloads\Oracle\classes12.zip" was also added to CLASSPATH on my machine’s environment variables.


Unfortunately, we are obtaining this exception upon Weblogic startup:

<Sep 7, 2004 5:36:12 PM GMT-05:00> <Error> <JDBC> <001060>
<Cannot startup connection pool "OracleConnectionPool" weblogic.common.ResourceException: weblogic.common.ResourceException:
 Could not load 'oracle.jdbc.driver.OracleDriver

 If this is a type-4 JDBC driver, it could occur if the JDBC
 driver is not in the system CLASSPATH.

 If this is a type-2 JDBC driver, it may also indicate that
 the Driver native layers(DBMS client lib or driver DLL)
 have not been installed properly on your system
 or in your PATH environment variable.

 This is most likely caused by one of the following:
 1. The native layer SO, SL, or DLL could not be found.
 2. The file permissions on the native layer SO, SL, or DLL
    have not been set properly.
 3. The native layer SO, SL, or DLL exists, but is either
    invalid or corrupted.

 For more information, read the installation documentation
 for your JDBC Driver, available from:
 http://e-docs.bea.com

        at weblogic.jdbc.common.internal.ConnectionEnvFactory.makeConnection(Con

nectionEnvFactory.java:220)…(Exception continues..)

 

Have you ever had this kind of problem before?

Thanks in advance.


0
eduardotorres17
Asked:
eduardotorres17
  • 3
  • 2
  • 2
  • +1
1 Solution
 
objectsCommented:
does the error include the complete stack trace?
0
 
CEHJCommented:
You may need to set Weblogic's own classpath. See

http://www.weblogic.com/docs51/classdocs/oraclethin.html
0
 
objectsCommented:
Try using the -classpath option on the java startup command (if it is a classpath problem).
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
jLasithaCommented:
Do you have Oracle client on your machine..?
0
 
Giant2Commented:
you must set the classpath for Weblogic.
Read this:
http://www.weblogic.com/docs51/admindocs/classpath.html#cpwls

Hope this help you.

Bye, Giant.
0
 
Giant2Commented:
0
 
CEHJCommented:
>>you must set the classpath for Weblogic.

(already mentioned)
0
 
Giant2Commented:
>>>you must set the classpath for Weblogic.
>(already mentioned)

whoooops!

eduardotorres17,
could you tell us if the suggestions given to you solve your problem?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now