Forbidden to access webpages...even from localhost ( Linux FC2 )

Hello All,

I am trying to set up certain apps like mrtg, and webalizer. Actually they are already installed. The problem is when I try to access any of the pages even from localhost I get a Forbidden page. I can access all other pages just not these 2. Read access is permitted. Don't know what gives, any ideas?


GR
GR999Asked:
Who is Participating?
 
ramazanyichConnect With a Mentor Commented:
1. check your apache error.log it should say more details about error.
2. Check that files are readable by user who owns the httpd process (by default it is user nobody)

0
 
samriConnect With a Mentor Commented:
In addition to those recommended by ramazanyich:

try to locate any html file in the respective folder, for example for mrtg, try to access http://localhost/mrtg/somefile.html

If this is the case, then you need to either create a default index file (http://httpd.apache.org/docs-2.0/mod/mod_dir.html#directoryindex) so that Apache would attempt to load this file in the event that the request is not to a file.

Another option would be fixing the Option directive in the respective Directory tag .  Make sure +Indexes is added to the Options (http://httpd.apache.org/docs-2.0/mod/core.html#options) list.  This would enable directory browsing for those folder that does not have default index file.

Hope this help.
0
 
GR999Author Commented:
Thanks for the help guys. I appreciated the quick responses. I figured it out. Those 2 programs (on Fedora Core 2 at least) have aliases associated with them and need their access configured in /etc/httpd/conf.d. They don't allow any access as a default...go figure. Thanks for the help I have raised and split the points evenly.


GR
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.