Solved

Access Denied: XP Home shared files unaccessible to XP Pro computer

Posted on 2004-09-07
12
229 Views
Last Modified: 2010-04-11
I have two computers that I am trying to network. The first is a desktop running XP Home (HOME) and the second is a laptop running XP Pro (PRO). They are connected to a Linksys wireless router with PRO having a wireless connection and HOME being wired. On both computers, I can see both machines in the workgroup window and can ping each machine from the other. The problem is that I cannot access HOME from PRO but I can easily access shares on PRO from HOME. I have the same username on both machines and have tried nearly every suggestion that I have come across. I also have disabled the firewalls on both machines. Please help!

Thanks in advance.
0
Comment
Question by:lewisressler
12 Comments
 
LVL 9

Expert Comment

by:activematx
ID: 12002485
What client and services are you running on both machines?

Network Settings > LAN Settings > Properties
0
 
LVL 2

Expert Comment

by:jasperomalley
ID: 12002514
The laptop doesn't happen to be joined to a Windows NT/2000 domain by any chance (maybe the one at work)? What error message do you get on the Pro machine when you try to access the shares on the Home machine?
0
 

Author Comment

by:lewisressler
ID: 12002794
I am running 'Client for Microsoft networking' as well as 'File and Print Sharing for Microsoft Networks'. I am also running NetBIOS over TCP/IP and have tried running NetBEUI over TCP/IP.

The laptop is not part of any domain. The error message states: \\Computer_name is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access is denied.
0
 
LVL 15

Expert Comment

by:vico1
ID: 12003018
Disable your windows firewall, or modify it to accept request from the local network.

You could also add user permission by doing the following:

Click on start menu
click on run
type control userpasswords2 then click ok
then add user account for the other system vice versa.

let me know if that helped
vico1
0
 
LVL 1

Expert Comment

by:smori
ID: 12003702
You can also access using the IP address. But the folder you are trying to access should have been shared already. By default you can access the admin$ share. So try \\<IP address>\admin$.
thanks
0
 
LVL 4

Expert Comment

by:harryballz
ID: 12004371
When you create a password for a User Account the very last thing it asks is if you would like to make it "Private"...

If you say yes...no matter what you share out of your profile (Desktop, My Docs) will not be availbale on the network and and you will get the "You might not have permission to use this network resource. Contact the administrator" error.

Remove the password from the User Accounts in question...then re-enable it but say NO to make private.  Reboot.

From Pro:
START>
RUN>
\\XP Home box\share  :-)
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Expert Comment

by:mlk65
ID: 12005297
Hi!

The Xp Pro, when using in workgroup otherwise as work in domain (More : "How to Set Security in Windows XP Professional That Is Installed in a Workgroup" http://support.microsoft.com/default.aspx?scid=kb;en-us;290403 )

The reg key:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"ForceGuest"=dword:00000000
U can import this setting to registry with "regedit.exe /s this_reg_settings.reg" command.

0
 

Author Comment

by:lewisressler
ID: 12093598
First of all thank you for all of your replies. I have tried everyone's various suggestions but none have worked for me. I have tried literally dozens of different suggestions. I starting to think that XP Home was not meant to be networked. Any other suggestions? Thanks.
0
 
LVL 4

Accepted Solution

by:
harryballz earned 500 total points
ID: 12094637
My guess is you probably ran the Microsoft Network Setup wizzard and "fed" it bad info on the XP HOME PC?  I would start over clean...Go to Device Manager> R-click and unistall your 10/100 Network Adapter and reboot.  This will re-install it "automagically" with the default working settings.  Then R-click the folder you want to share and (the first time you share pick "Just Enable Sharing" via the link after clicking on it).  Don't run the network setup wizzard.

The folder will now show up in My Network Places from the Pro Laptop or just do a:

START>
RUN>
\\XP Home box\share name



0
 

Author Comment

by:lewisressler
ID: 12096387
Thank you, harryballz. Now I can access the shares on my XP Home machine with my Pro Laptop but I still cannot access the computer through 'My Network Places'. I have to type the path to access the shares.  I am fine with mapping a network drive in 'My Computer' but was just wondering if there was anything I could do to allow access through 'My Network Places'. I can see XP HOME from my PRO laptop but I still get access denied.
0
 
LVL 4

Expert Comment

by:harryballz
ID: 12097866
Hey lewisressler,

By default XP Pro uses the "WORKGROUP" workgroup and XP Home use the "MSHOME" workgroup.

R-click the MY COMPUTER icon > Properties > Computer Name TAB and change one of them so they both match - reboot.  Then My Network Places will work better :-)
0
 
LVL 4

Expert Comment

by:harryballz
ID: 12097882
You might have a bad setting on the PRO box as well....could use the same solution on it.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Article by: IanTh
Hi Guys After a whole weekend getting wake on lan over the internet working, I thought I would share the experience. Your firewall has to have a port forward for port 9 udp to your local broadcast x.x.x.255 but if that doesnt work, do it to a …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now