Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 214
  • Last Modified:

Encapsulation for serial devices

Hi, I have two 2501 routers I am connecting to each other via a back to back serial cable.

cable router---------->2501a<------------>2501b
                                             serial



Users connected to 2501a get good speeds to the internet
Users connected to 2501b get TERRIBLE speeds to the internet.

Could it be because of the serial cable 2501b users must traverse before hitting the WAN? I am using PPP encapsulation on the serial interfaces. Is this bad?
thanks
0
dissolved
Asked:
dissolved
4 Solutions
 
pedrowCommented:
no. ppp is perfectly acceptable.

In this back-to-back configuration have you configured one of the sides serial interfaces to do the clocking? Do you see interface resets on the serial interfaces?

Maybe a show int output from each side and/or config output from those interfaces might shed some more light.
0
 
Don JohnstonInstructorCommented:
What speed do you have from the cable modem?

What speed have you set (clockrate) for the serial link between the two routers?

-Don
0
 
dissolvedAuthor Commented:
Well its like this
(refer to my above diagram)

The 192.168.1.0 network is behind one cisco router, the 2501a. The 2501a is connected to the cable router (gateway) via ethernet.   Download speed is  a solid 378kbps for these users.

Now, users on the 192.168.2.0 network, who are behind routers 2501a AND 2501b, have a download speed of 59k.  I was thinking the serial was the bottleneck since PPP encapsulation is being used on the s0 interfaces of both routers where they connect.  Clock rate is set to 64000 on router 2501b.  
Thanks
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
pedrowCommented:
maybe setting the clock rate on both side to 1544000 might help.
0
 
dissolvedAuthor Commented:
You have to set the clockrate on both ends???  Maybe that's the problem lol

i'll try that pedrow thanks.
0
 
PennGwynCommented:
Gee, users are getting 59k over a link that's set to 64k tops.  That's not bad at all!

pedrow has a good idea, though.  You haven't told us much about the serial link, but it can *probably* be clocked much faster (he suggests T1 speed).

0
 
mikebernhardtCommented:
You only need to set the clock rate on the DCE side. But that is your maximum bandwidth, in bits/sec. So it's obvious why you only get 59K.
0
 
dissolvedAuthor Commented:
thanks a lot guys. That did it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now