Solved

Veritas Backup Exec and Microsoft CRM - cannot backup exchange

Posted on 2004-09-08
7
854 Views
Last Modified: 2008-01-09
Since installing Microsoft CRM on an SBS 2003 server we cannot backup exchange (give or take a few days we cannot be sure that the problem occured at the same time as the install)

When trying to select the public or mailbox stores we get an access denied error.

I have been in frequent contact with Veritas who have tried everything to assist. they are not keen to acknowledge that CRM is causing the problem and we have been going round in circles looking at user permissions (of the veritas account). Frequent reinstalls of BE, recreation of user accounts, Countless sgmon.exe logs have been studied by Veritas who have been very helpful but have not resolved the problem.

I am not 100% sure that the CRM install is causing the problem, however, I can only imagine that it has altered permissions in exchange somewhere. I have installed BE on a remote machine and still have the same problem. indicating to me the issue lies in exchange and not in BE or a problem with the user account.

A windows NT Backup of  exchange 'appears successful' but the data it backs up is a few 100 kb and not the hundred or so MB it should be.


A solution would be great but i think thats unlikely as how many people have these 2 pieces of software on an sbs 2003 box ? Not many i suppose.


Uninstalling CRM is my last resort - so before i go ahead and do it, does anybody have any suggestions/ideas?

Thanx
0
Comment
Question by:sloopeth
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 6

Expert Comment

by:acmp
ID: 12004664
We had something similar. When we tried to connect to the exchagne server it worked OK, until the backup wanted to connect then it was 'access denied'. We changed to useing the IP address for the exchange server and this worked.

OK, our problem had nothing to do with CRM or 2003, but it's worth a try.

acmp<><
0
 
LVL 4

Author Comment

by:sloopeth
ID: 12004805
worth a bash - no luck tho :(
0
 
LVL 3

Expert Comment

by:frieked
ID: 12010136
Please paste the backup exec log for the failing backup.

Also, please check event viewer for any relevant entries around the time you do your backup and post them here.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 4

Author Comment

by:sloopeth
ID: 12014596
having reinstalled several times i no longer have the backup logs however the error was quit simple

'access denied'

the log really isnt the fault tho - the fault is that when selcting the mailbox stores within the BEjob selection it will not allow you - bringing up a dialogue box asking you to select another account.

trust me this is nothing to do with BE or user account permissions i have spent weeks troubleshooting the issue with Veritas who have set up an idertical test scenario.

the problem is either deep in exchange caused by either an unknown factor or the install of CRM

nothing in the event log of note.

you can have some sgmon logs if u like


beserver: 0x0a48 -1-0907:164916:Client 'ACS-SERVER' connected('','ACSTECH\elephant'): 0x1eb2230
bengine: 1b60 07/09/2004 16:49:16: sis temp path=C:\DOCUME~1\elephant\LOCALS~1\Temp\
bengine: 1b60 07/09/2004 16:49:16: MAPIAdminService::CreateMsgService Failed!  hr = 0x8004010F
bengine: 1b60 07/09/2004 16:49:16: Somehow we failed but without setting the return code  hres =8004010f
bengine: 1b60 07/09/2004 16:49:16: MAPIAdminService::CreateMsgService Failed!  hr = 0x8004010F
bengine: 1b60 07/09/2004 16:49:16: Somehow we failed but without setting the return code  hres =8004010f

bengine: 1b60 07/09/2004 16:49:18: MAPIAdminService::CreateMsgService Failed!  hr = 0x8004010F
4308: CollectPerfMon - exit success actually open failed
bengine: 1b60 07/09/2004 16:49:18: Somehow we failed but without setting the return code  hres =8004010f
bengine: 1b60 07/09/2004 16:49:18: MAPIAdminService::CreateMsgService Failed!  hr = 0x8004010F
bengine: 1b60 07/09/2004 16:49:18: Somehow we failed but without setting the return code  hres =8004010f
beserver: 0x0a64 -1-0907:164918:Client 'ACS-SERVER' Disconnected:0x1e9d420
0
 
LVL 4

Author Comment

by:sloopeth
ID: 12052348
fixed myself - uninstalled crm + crm exhchange connector

reinstalled exchange + crm

0
 

Accepted Solution

by:
PashaMod earned 0 total points
ID: 12094550
Closed, 500 points refunded.
PashaMod
Community Support Moderator
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your app took Google’s lash recently, here are the 5 most likely reasons.
Curious about the latest ransomware attack? Check out our timeline of events surrounding the spread of this new virus along with tips on how to mitigate the damage.
This video will demonstrate how to find the puppet warp tool from the edit menu and where to put the points to edit.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question