Solved

(No Answer Question) - WinXP + Mac file sharing - (No Answer Question)

Posted on 2004-09-08
25
1,674 Views
Last Modified: 2013-11-13
We have not been successful in connecting a Windows XP and a MacOS (either OSX or 8.6) together over a home LAN (router Ethernet) for file sharing.  Can someone walk us through the procedure, or recommend a source?
0
Comment
Question by:eleanorb
  • 9
  • 6
  • 4
  • +3
25 Comments
 
LVL 30

Expert Comment

by:weed
ID: 12007679
8.6 is a lost cause unless you have 3rd party software.

For OS X you just need to have filesharing turned on at the PC, a working ethernet network, then use the Network window on the Mac to view the machines on the network that have something to share. You can also use Go>Connect To Server and type smb://windowsIPaddess.
0
 

Author Comment

by:eleanorb
ID: 12012754
Uh, do I need to post a separate question to get the instructions for the XP side?  I should have made it clear that that was the problem, but there wasn't a category for Windows XP...

Eleanor
0
 
LVL 30

Expert Comment

by:weed
ID: 12013098
Yeah that would be a good idea. Shouldn't take much.
0
 

Expert Comment

by:fede_dev
ID: 12014615
Is better to use osx what version of osx do you have?

fede
0
 

Expert Comment

by:fede_dev
ID: 12014889
However:

Procedure A) the mac see winXp

1- on the winxp pc
  you have  to create a folder on winXP available to the network:
  create the folder  ->ebshare
  right-click the folder and choose Properties
  click sharing tab then put on "share this folder on the network"
  in the box "Share name:" write the name you want the folder has on the network -> ebxpdoc

2 on the mac (panther)
   open a window in the finder
   click network in the sidebar
   you have to see the pc name or the group in the pc ->workgroup
   click workgroup (or the name of the pcgroup) or local to see the pc only
   double-click the pc with win xp (you know the name!)
   the dialog for your admission appears
   write name an password of your account on the pc (I hope that you have one)
   you see a dialog with a list of the shares (disk or folder)
   choose the correct folder an then it has to open and you see the content
   at this point if everything is ok you could drag files between pc and mac

have a good luck!

fede
0
 

Author Comment

by:eleanorb
ID: 12025546
Thank you, fede.  We set up the PC as stated.  The address appears in the network window on the Mac OSX, but when I click connect, the window Connecting to smb://192.168.1.4 appears and stays a while, then get error -36.  In File sharing on the Mac, I have checked Personal and Windows file sharing.
0
 
LVL 30

Expert Comment

by:weed
ID: 12028219
0
 

Author Comment

by:eleanorb
ID: 12032339
The page that weed provided had a lot of suggestions, but so far none are helping.  

ping doesn't return a response, using either the XP name or the IP address:

eleanorob% ping fumikosan
ping: unknown host fumikosan

eleanorob% ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
ping: sendto: Host is down
ping: wrote 192.168.1.4 64 chars, ret=-1
ping: sendto: Host is down
ping: wrote 192.168.1.4 64 chars, ret=-1

I can't figure out how to "set Network DDE and Network DDE DSDM services to automatically start."

Using the XP folder name (smb://192.168.1.4/ebshare) calls up a login screen (SMB/CIFS Filesystem Authentication) but still shows the zebra bar for a long time working to connect -- I didn't wait for the error, because then I get kernel panic when I try again.  Also, the zebra bar appears before I enter anything in the login screen.  

I corrected permissions, using Disk Utility, and then restarted the Mac.

I tried entering the name of the XP computer in Netinfo, but that doesn't seem to make a difference.

After these various efforts, ping now:

eleanorob% ping 192.168.1.4
PING 192.168.1.4 (192.168.1.4): 56 data bytes
^C
--- 192.168.1.4 ping statistics ---
17 packets transmitted, 0 packets received, 100% packet loss

Any more suggestions?  We're at our wit's end...
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12035198
This *sounds* like you're running some version of 10.3, right ?

In System Preferences, Sharing, make sure that you're not using the OS X firewall - at the very least, not while trying to sort out this issue. If you must use it, make sure to leave the box for Windows Sharing. But I suggest you leave the firewall off.

Go to the folder: Applications, within that, Utilities
Launch the utility, Directory Access
Click the lock in the lower-left corner and enter your OS X (username &) password to authenticate.
Double-click the SMB entry, and you will see the option to set the Workgroup. Enter the same Workgroup as you have set on the PC running XP. Quit out of Directory Access,  to save the change.

To make sure this matches what you have on your PC, Right-click on My Computer, and click on the Computer Name tab.
The default is: WORKGROUP but you may have set it to something else along the way.

On the PC, go to Start/Settings/Network Connections, and choose to "view network settings" (either that or right-click and choose "Open").
Right-click on your the icon for your Lan connection, & choose Properties. Click on Internet Protocol (TCP/IP), and choose Advanced.
Verify that "Enable TCP/IP Filtering" is NOT on. At least, not while trying to resolve this issue.
(If you have a Router with Firewall features, you're much better of using that anyway)

Now Explore "My Network Places" and in the top bar, enter:
\\192.168.1.4
and hit return.
The username and password you enter must be those of the OS X user that is logged in at the Mac, or those of the Admin (main) account if that is different.
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12035205
Hmm... well, make that the IP for your Macintosh, the .4 is the XP machine. Apologies there.
0
 

Author Comment

by:eleanorb
ID: 12035292
No, 10.2.8 Mac OS.  Instructions still apply?
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12035727
Yes, however, for 10.2 , there is an added step:
 open System Preferences/Accounts, and edit the user, and select, "Allow user to log in from Windows"
You will still use /Applications/Utilities/Directory Access   to change the Workgroup setting for your Mac OS X machine, and again, they must match on the PC and on the Mac.

http://docs.info.apple.com/article.html?artnum=107083
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:eleanorb
ID: 12040163
I made the workgroup in XP match the one in the mac.  Then I restarted the PC, per a dialog there.  Etc.

But, when I got to the step "Now explore my network places and in the top bar enter:"
I can't find a top bar or anywhere to enter the IP.  To confirm, I am right-clicking "My Network" and then selecting "Explorer" -- right?  No place to enter.  (I also tried using the web brower Internet Explorer and entering //192.168.1.3, to no avail.)  (Did you really mean to use back-slash characters??)

Eleanor
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12040538
yes, backslashes.

Where it says:

My Netwrok Places

in that field at the top of the window, click the cursor, and hit return. "My Network Places" should become hightlighted. Or, click and drag across "My Network Places" to select & highlight it.
Then type in:
\\129.168.1.3

the above entry should completely repacle "My Network Places"

if you leave out the back-slashes, it doesn't work .

Then hit return.
It will take a moment, but you'll be presented with the dialog for username & password. These are the ones for the Mac, of course.
0
 

Author Comment

by:eleanorb
ID: 12081061
to heteronymous Well, I have reached the limit here.  I now have to confess that the Windows XP system I am working with is a Japanese system, alike in most respects, but it just doesn't have any address slot in the Explorer display, or place to type in the \\ address.  The closest is a function to "Add MyNetworkPlace" and I tried that, but so far it doesn't work.  I won't blame you if you don't want to continue under these circumstances, and I will give you the points just for trying. (split with fede_dev).
0
 

Expert Comment

by:fede_dev
ID: 12083490
don't give up (problems need dedication);
The problem seems to be the network.
Could you ping the two machines?
You must ping the two IP to have a succesful connection.
Relax and give us another chance.

have a good luck

fede
0
 

Author Comment

by:eleanorb
ID: 12083585
Our little network has two Macs (OSX and 8.6), one PC notebook, and a printer.  From the Mac OSX, I can ping each of the other three successfully.  
0
 

Expert Comment

by:fede_dev
ID: 12083874
try to use smb browse on osx to mount the share folder of window xp
here is the link:
http://www.versiontracker.com/dyn/moreinfo/macosx/13795
that's a freeware utility.

bye
  fede
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12084272
Double-clik on "My Network places" on the Desktop, to open that window, go to the top of that window to the View menu.
Click and drag down to Toolbars, and select "Address Bar", which will then show you the address bar/field.

Then my method described above should work for you
0
 

Author Comment

by:eleanorb
ID: 12089523
To heteronymous:  After I select Address Bar (in the Explorer display), I get a small boxed area to the right of the window, which says (in Japanese) 'Address (D)', but it is grayed out and not clickable.

To fede_dev:  I downloaded smb browse and it shows the links (user name, workgroup, etc.) which is cool and useful, but when I click "Mount" it turns blue for a few seconds, then un-blue, but no other respoonse or messages.  I tried both \\192. etc. and just 192. etc in the URL space, and both IPC$ and ADMIN$ under user name.
0
 
LVL 3

Expert Comment

by:daniel416
ID: 12156790
so sorry to hear you're having so much trouble eleanorb!

in case you haven't tried this: it is also possible to connect both machines directly with an ethernet cable (*not* crossover, no need for a hub), make sure that the mac ip begins with 169.(make a new network location in network preferences. setting it to tcp/ip - using dhcp should work since there are no dhcp servers around) and follow the previously posted instructions to connect. You should be prompted for your os x user id from xp

AFAIK, you don't need to install smb  on os x. it comes ready to use.

here is an article that i hope helps:
http://www.macdevcenter.com/pub/a/mac/2002/11/19/mac_pc.html

let us know how you're doing!
0
 
LVL 9

Expert Comment

by:heteronymous
ID: 12159221
Here is another method:

Right-click on My Network Places,
and then select:
Map Network Drive

In the window, let it assign whatever letter appears for "Drive" (probably  = z:   )
and in the field named "Folder" enter in:
\\92.168.1.4\eleanorb

assuming that is your Admin (main user) account name on the Mac.
and from there you should be asked the username & login (these will be the ones for the Mac user, what you enter on the Mac for logging in or installing software).

Just how are your computers connected, physically ?
Is there a Router (linksys/d-link/asante/belkin, etc.) that is setup to assign IP addresses, via DHCP ?

On the PC, go to Settings/Network Connections/Local Area Connection , and right click on that (Local Area Connection). It might say "Local Area Connection 2" or what-have-you, don't worry about that. Right-click on it, and go to Properties.
Make sure that "Client for Microsoft Networks" , and "File and Printer Sharing for Microsoft Networks" and "Internet Protocol (TCP/IP)" is clicked on. That last one really must be, if you can ping the PC...
Click on Internet Protocol (TCP/IP) and then below click on the Properties button.

Please tell us what is in the window that appears. all of the numbers are relevant

On the Mac, go to System Preferences, Network, and for Built-In Ethernet,
what are the settings under TCP/IP ?

Don't give up !
0
 

Author Comment

by:eleanorb
ID: 12206957
Okay, guys, thanks for your continued energy!  

The Japanese laptop has, after three months in New York, had to return to Japan, so the problem has disappeared, along with the opportunity.  I am sad, but Immigration will win in the end.  I will save the later suggestions to try if/when she returns to my little LAN.  I am now appealing to customer service to see if I can award some points without an Accepted Answer.


0
 

Accepted Solution

by:
WesLennon earned 0 total points
ID: 12208587
Hello everyone, eleanorb has asked me to split the points for all your efforts in this note:

Since I could not pursue the problem to resolution, I don't want to penalize the experts who put so much energy into it.  It was my fault that we could not arrive at a solution.  So, I would like to assign points in proportion to the contributions each made:

      heteronymous      50% = 250
      daniel416            10% = 50
      fede_dev            30% = 150
      weed            10% = 50

As this is for contribution and not an answer, I will accept myself at 0 points to PAQ the question, this is really the only way it can be done.

Thank you,

Wes Lennon
Director of Community Services
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
iphone IOS 8.1 hotspot 5 1,230
Apple Laptop Boot Connect 2 60
Mac Mini (Mid 2011) - AirDrop not in Finder 6 80
Wireless coverage 7 42
SUMMARY Enterprise backup in a heterogeneous network is a subject full of complications and restrictions. Issues such as filename & path structure, attributes and extended metadata always tend to complicate the subject to the extent where either …
In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now