Solved

Strange  Error in OL2003 - The message store has reached its maximum size?

Posted on 2004-09-08
17
23,975 Views
Last Modified: 2011-08-18
Some of the users on the LAN started receving a strange error after return back from the holiday weekend.

About 1/2 dozen of my 120 users were unable to receive new mail, thats how many reported, all of them get the OL2003 Maibox Clean Up dialogue box ( http://www.depts.ttu.edu/itts/documentation/outlook/pics/mailboxcleanup.gif )i am not sure if this is happening to others, it hasn't happend to me and to few others i spoke with.

This is the setup
Exchange Server 2000 Standard running on a Win2k DC.
All users on WinXP, Outlook 2003, the people who have reported the problem are all Notebook users.

When i go into Outlook and disable the cached mode, all mail appears, when i go in there and re-enable it, the same problems occurs, Outlook 2003 pops up a message saying that your mailbox is full and gives multiple options on cleaning up, but the mailbox is not really full, for one user we took out almost everything except for maybe 3MB, all users have a 75MB quota limit, the mailbox size is fine.

I have deleted recreated the .OST file and still the same problem, the strange thing is it is not happening to all the users, but it has happend to quite a few and it could be a possible sign to something bigger waiting to happen.

I checked my priv1.edb and priv1.stm files, .edb is 9.5GB and .stm is about 6.2GB combined they are close to 15.7, does this mean that i am reacing my exchnage standard 16GB limit ?

This is the error from Outlook send receive:
Task 'Microsoft Exchange Server' reported error (0x8004060C) : 'The message store has reached its maximum size.  To reduce the amount of data in this message store, select some items that you no longer need, permanently (shift + del) delete them.'

This is the error from the sync logs created in the Sync Issues folder of OL2003:
9:16:30 Synchronizer Version 11.0.6352
9:16:31 Synchronizing Mailbox 'Smith, John'
9:16:31 Synchronizing Hierarchy
9:16:31 Synchronizing server changes in folder 'Inbox'
9:16:31 Downloading from server 'myexchservername.mydomain.local'
9:16:31 Error synchronizing folder
9:16:31              [8004060C-53F-8004060C-560]
9:16:31              The message store has reached its maximum size.  To reduce the amount of data in this message store, select some items that you no longer need, permanently (shift + del) delete them.
9:16:31              Microsoft Exchange Server Information Store
9:16:31              For more information on this failure, click the URL below:
9:16:31              http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=8004060c-53f-8004060c-560
9:16:31 Synchronizing server changes in folder 'Sent Items'
9:16:31 Downloading from server 'pcacement.cement.local'
9:16:31          1 item(s) added to offline folder
9:16:32 Done
9:16:32 Microsoft Exchange offline address book
9:16:32 Download successful

The link takes you to a solution i already tried and is not applicable. I recreated the .ost file and still the problem persists. The only way i can get the mail into the users local outlook is when i disable the cached mode, they log on to OWA fine and can see all their mail.

I check the Event Viewer on Exchange and nothing that sticks out that points to the problem.

Any help in resolving this issue would be much appreciated.
Thanks in advance.
0
Comment
Question by:z969307
  • 7
  • 4
  • 3
  • +2
17 Comments
 
LVL 15

Expert Comment

by:Yan_west
Comment Utility
The good news is that a new functionality has been added to Exchange 2000 and 2003 which will temporarily increase the database size by 1GB to 17GB.  This will allow the Mailbox Store to remount, and give the Administrator a window in which to delete unnecessary database content and prepare for offline defragmentation.  In Exchange 2000 this functionality is included in the Post-Service Pack 3 Rollup.  In Exchange 2003 this is built into the product, however a registry value must be added to enable this function.  

For more detailed information on this topic, see the following Microsoft Knowledge Base article:

828070 Exchange Server Mailbox Store Does Not Mount When the Mailbox Store

http://support.microsoft.com/?id=828070

0
 

Author Comment

by:z969307
Comment Utility
Are you implying that I've reached my 16GB limit ? does the size of  priv1.edb and priv1.stm counted as one to total 16GB? I thought priv1.edb needs to reach 16GB before functionality gets disabled.

0
 
LVL 15

Expert Comment

by:Yan_west
Comment Utility
Exchange Server does not include a utility that allows you to determine how much free space is available in an Exchange Server database. You may need to determine how much space is available to help you decide whether you need to perform an offline defragmentation.

http://support.microsoft.com/default.aspx?scid=kb;en-us;186291&Product=ech
0
 

Author Comment

by:z969307
Comment Utility
i can look at the file size in win explorer, or is that inacurate ?
0
 
LVL 15

Assisted Solution

by:Yan_west
Yan_west earned 250 total points
Comment Utility
I do not think this is very accurate.. Doing an offline defrag of your mailstore if your DB is big would be a good thing anyways... Like microsoft says: "Exchange Server does not include a utility that allows you to determine how much free space is available in an Exchange Server database".. This is ridiculous if you ask me.. but hey.. that's microsoft for you.
0
 
LVL 12

Accepted Solution

by:
BNettles73 earned 250 total points
Comment Utility
If you go into cached mode and disable it all the emails appear ...


You need to check the client settings to make sure the users are synchronizing upon exit ... If the clients are caching data and not synchronizing the deletes back to the server then naturally their mailboxes have probably reached the limit and cannot receive email.

If you have some users still receiving data then your IS is mounted and you are not experiencing issues where the db has reached the maximum limit. I've seen this several times since we have O2K3 in Cached Mode running on several thousand clients ...

A good way to test this is to directly connect to a users mailbox (not using the cached mode) and delete email to bring it under the mailbox restriction limit.
You can also check sizes using System Manager ... expand the server and click on the mailboxes folder ...

If you need more info let me know
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
Use system manager to view all of the mailboxes on the store ... you can export a list to a CSV if necessary ... however, this only shows sizes of mailboxes, not the true size of the database ....
0
 

Author Comment

by:z969307
Comment Utility
I've check the folder size of the affected users and like i mentioned earlier, they are all within their limits, as i am replying I just checked the mailbox sizes under Exchange System Manager and all except a few (7) (not the ones affected) are approaching their limit and only 1 is over the limit and they are not affected with this issue.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
Didn't you say you deleted email from the cached client ... but then directly connected and the email was there?
0
 

Author Comment

by:z969307
Comment Utility
yes that is true, on one of them when i was troubleshooting, but before i even did that, I disabled cached mode and connected and all the mail appeared, then i went back and re-enabled it and the same error poped back up and then i went thru the process of deleting a lot of messages, but mind you, this user was way below and within their quota to begin with.
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
ahh ... my mistake ... you did make sure the deletions were synchronized before closing outlook though ... right? I left a comment on your other post btw ... make sure you get a good backup before and after ... prior to running the offline defrag
0
 

Author Comment

by:z969307
Comment Utility
yes i did, thanks for all your help.
i am gonna close this as the other one is more applicable.
0
 
LVL 21

Expert Comment

by:traval
Comment Utility
When you go into the Exchange Server properties -> Advanced tab, does it say "Outlook is running in non-Unicode mode against the Microsoft Exchange Server" at the bottom?  If so any chance this server was upgraded from Exchange 5.5, or the clients were upgraded to OL2003?

This sounds like a jammed up OST or PST file more than an issue with the mailbox itself, especially given the abililty to access via OWA.  Since turning off cached mode appears to work, then the OST file is the culprit in my opinion.

Try creating a new profile for a user who is having this problem, on either the same computer or a different one.  Setting the new profile to use cached mode will create a new OST file.
0
 

Author Comment

by:z969307
Comment Utility
traval,
well when you say upgraded what do you exactly mean, on top of exchange 5.5 ? no it was not, it was a clean install of win2k and ex2k in mixed mode, we migrated our 5.5 to this box.

I didn't setup a new profile, but i did try deleteing the .ost file on couple of computers

the problem was narrowed down to the 16GB limit on the database store, so doing an offline defrag should fix this issue, hopefully,.
0
 
LVL 21

Expert Comment

by:traval
Comment Utility
If I am following the post correctly, users can access their mailboxes thru OWA.  Think about this for a second and then explain to me again why this is an information store problem.  Does OWA access some different Information Store than the Outlook client does?  Do IS maximum size limitations only come into play depending on the client used to access them?

The information store databases (Priv.edb and Pub.edb) for Exchange Server 5.5 Standard Editions are limited to 16 GB each. After the limit is reached, the Exchange Server database engine stops taking transactions and notifies the information store to shut down.  According to your statements you are not at this point in size on either and your IS is mounting.  So I think what you have "narrowed down" to is a red herring, but good luck.
0
 
LVL 1

Expert Comment

by:mhdcommunications
Comment Utility
Try renaming the OST file to another name and restart outlook with cache mode. It worked for me! :)
0
 

Author Comment

by:z969307
Comment Utility
Dude this question has been closed for 6 + YEARS, we are on Outlook 2010
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now