Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2714
  • Last Modified:

Connecting from Linux to Windows through Samba

I'm having a problem connecting from a Linux box to a Windows2000 machine using samba. When I run

smbclient -L gonzo

I get the following:

added interface ip=10.0.0.5 bcast=10.0.0.255 nmask=255.255.255.0
timeout connecting to 10.0.0.4:139
Error connecting to 10.0.0.4 (Operation already in progress)
Connection to gonzo failed

What does this mean, and what do I have to do to make it work?

The Windows2k machine has one folder shared, which has read permission for everyone. I've checked that the workgroup settings are ok and everything else seems to be ok with the w2k box. I've also got another linux box (server) running a samba server in my network. Connecting to it from both the  w2k and linux machines works fine.

Thanks for any comments or suggestions!
0
fredrikbostrom
Asked:
fredrikbostrom
5 Solutions
 
jlevieCommented:
Is the w2k box at 10.0.0.4?

Does this Linux system have a firewall active that could be blocking things?

It would be helpful to know what Linux you are running.
0
 
fredrikbostromAuthor Commented:
Yes, the w2k is at 10.0.0.4 and the Linux is at 10.0.0.5.

I'm using SuSE linux and I haven't configured a firewall although there might be some default settings. But considering that the connection to the linux server (at 10.0.0.10) is working (samba to samba), shouldn't the connection to the w2k box work?
0
 
stanford_16Commented:
fredrik,

I have three suggestions:

First, try restarting your samba processes (smbd and nmbd).  This can get rid of current (failed connections).

Second, go ahead and add the username to your smbclient connect command.

# smbclient -L gonzo -U <username>

Third, get the name service out of the way and try

# smbclient -L gonzo -U <username> -I <gonzo's_IP>

Good luck!
A
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
fredrikbostromAuthor Commented:
Thanks for your suggestions. Unfortunately non of them provided me with a solution. The same error message is displayed after each command. I don't have smbd and nmbd running on the linux box from which I'm connecting to the w2k. The only remotely relevant process running is smbfs and executing /etc/init.d/smbfs restart gives me

Umount SMB File System                                                         unused
Mount SMB File System                                                          unused

if that is of any help. Tkanks!
0
 
KoorooCommented:
smbclient "\\UNC_PATH\SHARENAME" -I 10.0.0.4 -U username

so you should try something like : smbclient \\gonzo\share -I 10.0.0.4 -U Administrator

0
 
ivyfranklinCommented:
Also, you might need to add the following to Kooroo command assuming that the windows box's name is gonzo

-U gonzo\Administrator
0
 
aadilfahadCommented:
smbclient "\\UNC_PATH\SHARENAME" -I 10.0.0.4 -U username
smbclient \\gonzo\share -I 10.0.0.4 -U Administrator
or further help

www.linuxjalali.com
0
 
fredrikbostromAuthor Commented:
Thanks for your great comments. As it seems, you are all right. The problem was merely a firewall on the w2k box disallowing incoming traffic. The problem was resolved by making it allow incoming events from the local subnet.

Thanks for your help!
0
 
terry_coleCommented:
If you are having this issue with XP and your firewall is off and you still have this problem.
Enable the firewall then disable it again.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now