Game Won't Connect to Internet Using Shared Internet Connection


I have just set up a home network (2 PC's connected via crossover cable).
I habe the game Diablo II installed on both machines.
When i try to connect to (game server) in Diablo II it says that i may not have a modem installed.
Internet explorer connects fine and browses the web normaly.

How can I give Diablo II access to the shared internet connection?

It connects fine on the Network Server but not the Client.

Thanks In Advance
Who is Participating?

Improve company productivity with a Business Account.Sign Up

Anthony_EConnect With a Mentor Commented:
Is the inbuilt XP firewall on your LAN connection on? if so try turning that off also try turning off any other 3rd party firewall, I have the exact same setup at home and it works fine for me, have you tried different realms? maybe they have given you an short ipban?
Your connection-sharing is also doing NAT (Network Address Translation).  Some protocols aren't NAT-friendly -- they do things like repeat the IP address inside the packet contents where it doesn't get translated, so when the packet arrives its source address no longer agrees with its headers.  I don't know if Diablo II is one of these....

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Mayb this one could help a little
mms_masterAuthor Commented:
Thanks Anthony_E, i can't beleive I didn't think of that lol
The simplest thing it could have been lol
Thanks to everyone else for trying to help me aswell

not a prob, so what was it a firewall on your lan connection?
mms_masterAuthor Commented:
I have norton firewall installed on both pc's.
On the server it automatically permitted internet connection but on the client it didnt so i didnt think to check it.

I tried turning them off first like you suggested and that worked so thats how I realised that it wasn't permitted to access the internet.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.