Solved

cygwin running LegOS or BrickOS on WinXP

Posted on 2004-09-08
9
258 Views
Last Modified: 2010-05-18
I followed the instructions as per the sourceforge site:
http://legos.sourceforge.net/files/windows/cygwin/legOS-0.2.4.html

Seems like everything went ok, until step #6.

In the LegOS directory I enter the following command:
"make realclean"

I get this error:
bash: make: command not found

Also, I don't know if this is part of the problem, but my directory structure didn't exactly match the site's structure. The command "cd /" went into my cygwin directory so I would have to traverse into the LegOS via the cd command.

Thanks for your help :)
0
Comment
Question by:polkadot
  • 4
  • 3
9 Comments
 
LVL 45

Expert Comment

by:sunnycoder
ID: 12013597
Hi polkadot,

There could be two reasons

1. Make is not installed on your system. Search for make executable. If it is not found, then you have to install make

2. Make is installed on your system but the directory in which it is installed is not in your PATH variable. In this case, edit PATH variable in your profile and add the directory in which make is installed

cheers
sunnycoder
0
 
LVL 2

Accepted Solution

by:
aleric earned 500 total points
ID: 12033460
3. Make is installed and in your PATH, but it depends on a library that for which you don't have read permissions.

4. There is a 'make' in your path but it is a script that starts with '#! /foo' and '/foo' is not in your PATH (or not installed).
0
 
LVL 45

Expert Comment

by:sunnycoder
ID: 12033511
Hi aleric,

3. -> make will generate error ... This is shell unable to locate make
4. -> Still make will be found and error message will be bad command interpreter or something similar
0
 

Author Comment

by:polkadot
ID: 12034413
ok.... how do I fix it?

I have asked a similar question and gotten this response on another post:

Comment from Tintin  
Date: 09/09/2004 06:05PM EDT

make is a standard Unix development tool.

As BrickOS has a dependency on an older version of cygwin (B20), so you are relying on the cgywin version that's available from the BrickOS website to include everything you need.   This appears not to be the case.

The Cygwin website (http://www.cygwin.com/) says:

The last Bxx release was in December 1998. The Bxx releases are no longer available. In fact, older versions of the DLL or utilities are not usually available on this web site. Any cygwin program built from December 1998 onward should work correctly with newer DLLs.
 
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 45

Expert Comment

by:sunnycoder
ID: 12041230
Hi Polkadot,

You sure were in a hurry .... Was the problem solved ? May I suggest that you accepted an incorrect answer and should post in community support to get this question closed properly.

http://www.experts-exchange.com/Community_Support/

sunnycoder
0
 
LVL 2

Expert Comment

by:aleric
ID: 12042355
Sunny coder,

now you go a bit too far imho.  I have 28 years of computer experience, 14 years of which
are with all kind of UNIX Operating Systems.  Although I agree that the 'accepting' of
my answer without an additional reply is a bit strange and therefore might be accidental,
your pre-assumption that it is an incorrect answer is an incorrect insult.

The fact that you (apparently) don't know that this kind of situations CAN cause that
error - and then, when you try it out on one Operating System (your current one), it
doesnt work, does NOT mean that it is incorrect.  There are two possibilities here:

1) You have the first hand experience (like me, and that WAS on linux) that the
     scetched situations can cause the  error message that polkadot asked for.
2) You never had this experience.

Apparently you never run into this problem.  But that doesn't mean I am lieing.
With THAT error he should be checking which 'make' is being tried to be executed
and if he is using 'bash' that can be done with GNU which version 2.16
(which --version will tell you if you have that, otherwise you can get it
from http://www.xs4all.nl/~carlo17/which/index.html
And then check if it is a shell script.  If it is check the interpreter that it uses
in the same way.  If not check the executable in the following way:
Use 'ldd' to find out if all shared libraries can be found, and use 'ls' to check
if each of them exists and is readable (check the permissions of each directory
in their path too).  

That fact that that makes sense is because it IS possible that one has to look
for the problem there: I have had the same problem in the past and 3 and 4
have both been the cause.

In logic:

<certain environment>  && (case3 || case4) --> <given error>
<your environment> && (case3 || case4) --> !<given error>

Then your  conclusion that  !case3 && !case4  is a bit wrong.
0
 
LVL 45

Expert Comment

by:sunnycoder
ID: 12042503
Hi aleric,

Perhaps I should have expressed myself better. My point was, errors will be generated in conditions 3 and 4 but in those cases error message will not be "bash: make: command not found"

The error message clearly says that bash was not able to locate make executable. Both the points you made would never generate this message.

> Make is installed and in your PATH, but it depends on a library that for which you don't have read permissions.
This should generate errors while installing make ... If you copied the executable, then error will be generated from within make when it uses a function from the library which is not there. Bash will be silent as long as it can find and execute make

>There is a 'make' in your path but it is a script that starts with '#! /foo' and '/foo' is not in your PATH (or not installed).
Bash will whine here but it will whine about not being able to find the command interpreter and not make.

Both scenarios are completely different and will not generate the above error message. The only scenario which I think I forgot was, make was installed and in PATH but did not have execute permissions.

I did not mean to offend you and I apologise if I did, but I am very much inclined to believe my reasoning and whatever little experience I have had with Linux.

sunnycoder
0
 
LVL 2

Expert Comment

by:aleric
ID: 12046048
Well, I disagree with your "Both the points you made would never generate this message".

That exact error "bash: make: command not found" has occured for me, on linux, in the past
when in fact there was a problem with a library or interpreter.  You're never too old to learn
something new sunnycoder, never say never.

I might not have as much "expert points" on EE as you, but as you to 'littel experience with
linux' then you can trust me when I say it has happened to me in the 10+ years that I am
using linux on a daily basis, and therefore it makes sense to check this: it could be the case
that there was a problem with a library or an interpreter.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
debian 3 question 26 129
tallylog file 2 2,598
whats a headless user in linux 3 134
specifying dependencies for an rpm 2 42
Have you ever been frustrated by having to click seven times in order to retrieve a small bit of information from the web, always the same seven clicks, scrolling down and down until you reach your target? When you know the benefits of the command l…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now