Solved

Cannot Load Mysql extension please check PHP configuration" --- phpMysqladmin   ---cannot load mysql.so

Posted on 2004-09-08
6
80,526 Views
Last Modified: 2011-08-18
I am trying to install phpMyadmin ..for using it as a client for my mysql database .I am doing this on Red hat Linux ,and PHP 4 and Mysql .

I am getting the following error
" Cannot Load Mysql extension please check PHP configuration"

When I see the documentation I see the below documentation
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
"To connect to a MYSQL server PHP needs a set of Mysql fucntions called the "Mysql extension".This extension may be a part of the PHP distribution otherwise it needs to be laoded dynamically .Its name is probably mysql.so or php_mysql.dll .PhpMyadmin tried to load the extension but failed.

Usually the problem is solved by installing a sofware package called "PHP-MYSQL'" or something sililar
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Thanks for your time
0
Comment
Question by:micro_learner
6 Comments
 
LVL 2

Accepted Solution

by:
montasirma earned 500 total points
ID: 12013035
After installing PHP on Redhat, add the package it is asking for (PHP-MySQL), then edit the php.ini file (you will find it in /etc/php.ini). Scroll down to the "Dynamic Extensions" section and remove the semicolon beside the line: extension=mysql.so

After that restart the httpd service (service httpd restart) then try to install PHPMyAdmin again. This should make the installation complete without problems.
0
 

Author Comment

by:micro_learner
ID: 12016271
Thanks montasirma ..thats awsome..thanks appreciate your help
0
 

Expert Comment

by:secondironman29
ID: 12735942
am trying to install phpMyadmin ..for using it as a client for my mysql database .I am doing this on win 2000 prof  ,and PHP 4 and Mysql .

I am getting the following error
" Cannot Load Mysql extension please check PHP configuration"

When I see the documentation I see the below documentation
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
"To connect to a MYSQL server PHP needs a set of Mysql fucntions called the "Mysql extension".This extension may be a part of the PHP distribution otherwise it needs to be laoded dynamically .Its name is probably mysql.so or php_mysql.dll .PhpMyadmin tried to load the extension but failed.

Usually the problem is solved by installing a sofware package called "PHP-MYSQL'" or something sililar
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Thanks for your time
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 

Expert Comment

by:williambericson
ID: 13184914
If you are having this problem in windows (unable to load Mysql extension) - do not forget that
the apache httpd.conf file has a variable for where php.ini is and for PHP5 is seems to default to
c:\PHP

If your php.ini file is in c:\winnt  then edit the C:\Program Files\Apache Group\Apache2\conf\httpd.conf   file

# configure the path to php.ini
PHPIniDir "C:/WINNT"


This solved that problem for me after I had done all the things most notes say to do ...
(like uncomment      
extension=php_mysql.dll    in  c:\winnt\php.ini
and set
; Directory in which the loadable extensions (modules) reside.
extension_dir = "c:\php\ext"                 in  c:\winnt\php.ini
0
 

Expert Comment

by:ashokrathod78
ID: 14491716
Hello,

Please i have same problem but how to install PHP-MYSQL package?
I have installed PHP5 and mySQL5 still i can not open that phpMyAdmin.

I am using XP OS
0
 

Expert Comment

by:dstonek
ID: 15129546
Fedora3
I am having the same problem "Cannot Load Mysql extension please check PHP configuration" --- phpMysqladmin
I know almost anything about servers.  I have a site of phtotography I had to move from a shared server to a dedicated one.  It is supposed there is installed Apache PHP-MySQL.
My php.ini has a section [MySQL] where |extension=mysql.so| is enabled
I've |service httpd restart| and |service mysql restart|
Please help
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
mysql Encryption with PHP 8 103
xampp tool 12 51
Sql query on a varchar that is numeric. 8 38
PHP: concatenate query 13 68
All XML, All the Time; More Fun MySQL Tidbits – Dynamically Generate XML via Stored Procedure in MySQL Extensible Markup Language (XML) and database systems, a marriage we are seeing more and more of.  So the topics of parsing and manipulating XM…
Introduction Since I wrote the original article about Handling Date and Time in PHP and MySQL (http://www.experts-exchange.com/articles/201/Handling-Date-and-Time-in-PHP-and-MySQL.html) several years ago, it seemed like now was a good time to updat…
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question