• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 646
  • Last Modified:

dreamweaver iis wwwroot what or how do I fix my permissions

HI yea,
I have just rebuild my XP Pro PC, I use dreamweaver mx7.0.1 , I also have a few extensions for dreamweaver like pureupload and what nots.

On loading IIS on to my pc and creating my dir in wwwroot I find I cannot wirte to my access database, I want to use pure upload to upload images to my site in my wwwroot and cannot, this I find to permissions.
I want to be able to create a dir inside my wwwroot when ever I am building a site before I upload it to the server (i.e sometimes i am build a few sites at once so will have a few different dir's insite my wwwroot). the sites i build read and write to an access database. how or what are my safe settings for the permissions. i use the the same pc for surfing the web at times but i use it all the time for building websites that i then upload to my isp. please can some one give me a step by step as to how to set my setting so i can read and write to databate and upload images using pureupload. I am really at logger heads. and when it comes to configuring the permissions i am really stupid, thus me requesting the step by step as to how i should set them. note that I am using a stand aloone pc.


Regards


Kenny





0
thatelvis
Asked:
thatelvis
  • 9
  • 3
  • 2
  • +1
1 Solution
 
webwomanCommented:
You don't do permissions from Dreamweaver. You do them on the web server directly. You don't need to worry about permissions on YOUR computer at all -- only those on the web server or your testing server.

Unless you have a testing server set up and configured with your site in DW, NONE of your database pages will be able to be tested without uploading to your live server and testing them there.
0
 
thatelvisAuthor Commented:
lol I know one does not do the permissions from dreamweaver. and yes thank you i realise that one needs to do them from the server. so I am using the C:\Inetpub\wwwroot on my computer , this is where i build my sites and this is where I have always built them. lol I know I need to upload them to the server but what my question is and still is is how to set the permissions on the C:\Inetpub\wwwroot to allow me to read and write to my access database that i have in one of my site and also i will be building a site that will allow a user to upload images to it.

so I will ask again, I want to know in a step by step approach as to how to set the permissions so i can read and write to my database. and upload images to my site which is in C:\Inetpub\wwwroot. note i have many other sites inside C:\Inetpub\wwwroot which i update from time to time and when I have them working as how i like them then and only then do i upload them to my ISP.


Kennu
0
 
alexhoganCommented:
From IIS:

Go to the site that you wish to modify directory permissions
Select the directory
Right click on the directory and select 'Properties'

The Properties dialog box will open

The first tab is Directory
In the Local Path group there will be 6 check boxes
Insure that the Read and Write check boxes are checked

Select the Directory Security tab
In the Anonymous access and authentication control group click on the edit button
Insure that anonymous access is checked.

0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
thatelvisAuthor Commented:
Thank you Alex,

Ok now I find yes I can write to the access database but I cannot upload images to a dir. I dont seem to have the permissions to upload something to my server. any clues as to what I should do.


Regards

kenny
0
 
alexhoganCommented:
Are you trying to upload to the same directory?

If not, did you set the same permissions to that directory that you did for the database?

0
 
thatelvisAuthor Commented:
Hi Alex,
In my wwwroot I have a dir called

C:\Inetpub\wwwroot\spudTest

inside that I have

C:\Inetpub\wwwroot\spudTest\db

and inside the db is where my access database is. I had believed that if i set the permissions for spudTest that my dir db would also inherite the same settings, am I mistaken here.

regards


Kenny
0
 
thatelvisAuthor Commented:
Hi Alex,
I have set the the permissions in the following way. I have gone to


C:\Inetpub\wwwroot\spudTest and reight clicked spudTest and choose permissions, from there I choose Security, I choose my PC name / user in the "Group or User names" and below that in the permissions for meme I select ALLOW Read    and     Write . I click OK and the window closes.


Kenny
0
 
alexhoganCommented:
That's right.

All the directories underneath, if you included inherit, will have the same permission level.
0
 
thatelvisAuthor Commented:
Hi again,
Sorry how can i include inherit, I cannot seem to find it.

regards

Kenny
0
 
thatelvisAuthor Commented:
Hi Alex, I am going to bed now as I am very tired. I will be online first thing tomorrow morning and would be grateful to carry on with your help. if not thank you.




Regards

Kenny
0
 
webwomanCommented:
Setting the permissions on your computer has nothing to do with how they're set on the server.

>>lol I know I need to upload them to the server but what my question is and still is is how to set the permissions on the C:\Inetpub\wwwroot to allow me to read and write to my access database that i have in one of my site and also i will be building a site that will allow a user to upload images to it.

You don't NEED to set permissions on YOUR computer -- you need to set them ON THE SERVER. You can set them on your machine and have it working perfectly, but it WILL BREAK when you upload it UNLESS you also set the permissions on the server. Since your machine doesn't make a hill of beans difference as to whether the LIVE site actually works, why bother?

Also, unless other people are accessing the site on your computer, you don't need to set permissions. YOU have full access to your own machine. Realize too, that if you set write access on the entire folder, anybody can write ANYTHING, any file, to that folder.

And finally, it's not your account that needs write access -- it's the IUSR_machine account.
0
 
thatelvisAuthor Commented:
Webwoman I need to set permissions on my wwwRoot, I have asked how to set them step by step. I realise the setting on my server are set by my isp and do not compromise what i want to do as I have done it before. so I wanted to know in a step by step fashion as to how to set the permissions on my wwwroot to allow me to read and write to my database and to upload images. I have built sites on my pc and tested them in my wwwroot before that allow me to upload images.  I have found when I have had eventhing build on my pc in my wwwroot before and upload it to my isp then everything works find. I dont want to set permissions on my PC that will compromise my security when I surf the web and leave me whole open to outside attack because of something I might have done to set permissions that dont need to be set.

so if you are not going to give me a step by step approach as to how to set my permissions can I ask that you no longer reply to my questions again and have a nice day.



regards

Kenny
0
 
Saqib KhanSenior DeveloperCommented:
First of all I would ask What kind of Server you are running, where you running, and where you storing Files.

For learning purpose maybe you have a Local Web Server Running on your machine?
OR you have a site setup with your host and you trying to make changes there?

alexhogan you should spread your knowlege as much as you can:)
0
 
thatelvisAuthor Commented:
I am running XP pro with IIS. this is the same pc as i am also running dreamweaver to build my site.


In my wwwroot I have a dir called

C:\Inetpub\wwwroot\spudTest

inside that I have

C:\Inetpub\wwwroot\spudTest\db

I need to have the rights or to know how to set the rights to write files to folders. I am not too clued up as to how to set the rights so would need to be told in a way you would talk to a simple person lol.


regarsd

Kenny

0
 
Saqib KhanSenior DeveloperCommented:
I believe by default Windows XP has different Permissions setting.

So Go to Tools > Folder Options on the bottom of it somwhere there is a option like Sime File sharing or something(recommened) which is actualy not recommened so disable  it.

Apply settings to all folders, and Now Right Click on your Images Folder Choose Security Tab and Add IUR_MachineName account to it with Read/Write Permissions.

Good Luck.
0
 
thatelvisAuthor Commented:
Thanks Alex, I managed to get it working with the following.

Windows 2000 and NT instructions: 1 Locate the database file or the folder the database is contained in within Windows Explorer. Right-click the file or folder and select Properties.
2 Select the Security tab if using Windows 2000. If you are using Windows NT, select the Security tab and then the Permissions button.
3 In the File Permissions dialog box, click the ADD button to add the IUSR_computername account to the list of accounts if it's not already listed.  
4 In the Look In drop down list, select the computer name of the workstation or server. Scroll through the list, select the IUSR_computername account and click Add.
5 Click OK to accept changes, and add the account to the permissions list.
4 Once the account is listed, make sure Full Control is checked and click OK.

Windows XP instructions: 1 Locate the database file or the folder the database is contained in within Windows Explorer. Right-click the file or folder and select Properties.
2 Select the Security tab and click Add. The Security tab on Windows XP can sometimes be hidden. Follow these steps to enable the Security tab:
   Select Tools > Folder Options in Windows Explorer.
 Locate and clear the 'Use simple file sharing (Recommended) option in the Advance Settings of the View tab.

Note: For more information visit Microsoft's Use Access Control to Restrict Who Can Use Files page.
3 In the Select Users or Group dialog box switch to the advanced view if necessary. Click on the Advanced button if available.
4 Verify that the Built-in Security Principals is listed in the Select This Object Types property. Click the Object Types button and check the appropriate selection if needed.
5 Click the Find Now button to list all accounts that match the criteria.
5 Locate and select the IUSR_computername account from the list generated and click the OK button to add the account to the permissions list.
4 Apply the change by clicking the Apply button.

Note: You may need to change permissions for the system's temporary directory, as Access also uses that directory. Please refer to the Microsoft KnowledgeBase article Q253604 on this topic.

Note: For added security, within IIS or the web server being used, permissions can be set so that Read permission is turned off for the web folder in which the database is contained. Browsing the folder won't be permitted, but the web pages will be able to access the database.

regards

Kenny
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now