• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1551
  • Last Modified:

IIS 6 Mail STUCK IN QUEUE

I have recently installed Win2003 Server Web Edition and configured SMTP as i had on my other working web server running II5.  I copied over my webs, and the forms I use to email information back to the office are just sitting in the queue and i am at a loss as to why. I enabled logging and here is how it reads. Please HELP! THANKS!

Here is the contents of the logfile also.

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2004-09-09 06:57:00
#Fields: time c-ip cs-method cs-uri-stem sc-status
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 EHLO - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 MAIL - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 RCPT - 0
06:57:00 192.168.1.2 RCPT - 0
06:57:00 192.168.1.2 RCPT - 0
06:57:00 192.168.1.2 RCPT - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 - - 0
06:57:00 192.168.1.2 BDAT - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 EHLO - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 MAIL - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 RCPT - 0
11:07:04 192.168.1.2 RCPT - 0
11:07:04 192.168.1.2 RCPT - 0
11:07:04 192.168.1.2 RCPT - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 - - 0
11:07:04 192.168.1.2 BDAT - 0
11:17:52 192.168.1.2 - - 0
11:17:52 192.168.1.2 QUIT - 0
#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2004-09-09 15:17:53
#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 220+tanco-server.thetanco.com+Microsoft+ESMTP+MAIL+Service,+Version:+5.0.2195.6713+ready+at++Thu,+9+Sep+2004+10:17:53+-0500+ 0 0 124 0 0 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 EHLO - SPARE-SERVER.thetanco.com 0 0 4 0 0 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250-tanco-server.thetanco.com+Hello+[192.168.1.30] 0 0 50 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 MAIL - FROM:<UniformOrders@thetanco.com> 0 0 4 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250+2.1.0+UniformOrders@thetanco.com....Sender+OK 0 0 49 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 RCPT - TO:<CBongner@thetanco.com> 0 0 4 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 RCPT - TO:<RRamey@thetanco.com> 0 0 4 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 RCPT - TO:<SHill@thetanco.com> 0 0 4 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 RCPT - TO:<ahelbling@thetanco.com> 0 0 4 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250+2.1.5+CBongner@thetanco.com+ 0 0 32 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250+2.1.5+RRamey@thetanco.com+ 0 0 30 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250+2.1.5+SHill@thetanco.com+ 0 0 29 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 250+2.1.5+ahelbling@thetanco.com+ 0 0 33 0 16 SMTP - - - -
2004-09-09 15:17:53 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 BDAT - 1115+LAST 0 0 4 0 16 SMTP - - - -
2004-09-09 15:28:04 192.168.1.2 OutboundConnectionResponse SMTPSVC1 SPARE-SERVER - 25 - - 451+Timeout+waiting+for+client+input 0 0 36 0 610782 SMTP - - - -
2004-09-09 15:28:04 192.168.1.2 OutboundConnectionCommand SMTPSVC1 SPARE-SERVER - 25 QUIT - - 0 0 4 0 610782 SMTP - - - -
0
Ahelbling
Asked:
Ahelbling
  • 4
  • 4
1 Solution
 
AhelblingAuthor Commented:
and this is what is listed in the System Event Viewer:

Message delivery to the host '192.168.1.2' failed while delivering to the remote domain 'thetanco.com' for the following reason: The semaphore timeout period has expired.
0
 
meverestCommented:
Hello,

'SPARE-SERVER' is issuing BDAT, but tanco-server either does not acknowledge that protocol, or it's implementation is broken.

A third possibility is that there is some firewall or trabsparent proxy that is failing to support bdat command.

Any of these things likley?

Cheers.

0
 
AhelblingAuthor Commented:
I am unfamiliar with BDAT, so another thing i found very interesting is that when i reboot the server with messages in the queue, upon logon, they are sent. But once booted, if I send another email it then gets stuck in the queue until I reboot again.  I can send emails with Outlook Express using SMTP with no problems.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
meverestCommented:
try setting up the server to send all outbound emails via smart host set to whatever you have set for the smtp (outbound) server in outlook.

cheers.
0
 
AhelblingAuthor Commented:
Okay - did that and the 2 messages are still sitting in the queue.
0
 
meverestCommented:
What does the log tell us now?

Also, try creating a new domain "thetanco.com" of type 'alias', open properties and disable 'EHLO' (ie only send HELO)

Cheers.
0
 
AhelblingAuthor Commented:
i found it - it was an smtp filter form Symantec Antivirus CE. thanks though!
0
 
meverestCommented:
suggest paq
0
 
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now