Solved

Suidperl : permission denied

Posted on 2004-09-09
10
291 Views
Last Modified: 2012-08-13
Hello,

whenever I try to execute suidperl (as root)
I get Permission denied...

the file permissions are:

permission 4755
user: root
group: root

Any hint?

Thx!

Dave.
0
Comment
Question by:dcrudo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 16

Expert Comment

by:OliWarner
ID: 12022903
chmod it to something higher... try 255
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12022909
my bad, chmod it to 111
0
 
LVL 1

Author Comment

by:dcrudo
ID: 12023975
I've tried... still not working...

I've tried to change permission, owner... everything... it really seems not to work...

I'm using Redhat FC1...

Thx!
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 16

Expert Comment

by:OliWarner
ID: 12024263
stupid question but you've got perl5 installed?
0
 
LVL 1

Author Comment

by:dcrudo
ID: 12024489
I have:

PHP Version 4.3.4

Do I need PHP 5 to use suidperl?
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12024530
you need perl installed, not php
0
 
LVL 1

Author Comment

by:dcrudo
ID: 12024622
Sorry...

I think I'm a little burn out ;)

Perl version is: 5.008003

0
 
LVL 16

Accepted Solution

by:
OliWarner earned 250 total points
ID: 12024737
I know the feeling, i've been on an all nighter
right... i'll have another look into the problem...
0
 
LVL 1

Author Comment

by:dcrudo
ID: 12055219
In the end I compiled speedyCGI and build a a binary... so I will use this one as a replacement for suidperl...
0
 
LVL 16

Expert Comment

by:OliWarner
ID: 12064942
yeah not such a bad choice there - good luck with it!
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
#Citrix #POC #XenDesktop #vCenter #VMware #ESX
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question