Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 823
  • Last Modified:

Exchfilt.dll Not Being Loaded Isapi Filters

Hi all,

Currently experiencing a problem since exporting IIS to a new Pc. Upon entering the properties for the required website, then Isapi filters, Exchange Web Component (exchfilt.dll) has a red arrow pointing down, obviously reporting an error. I have checked file location etc, but to no avail. The new Pc running IIS is a new install of the Os (Windows 2000) so file versions etc should be correct. Obviously as a result of this, webmail is no longer functioning. Any help here would be greatly appreciated.

Many Thanks,

Paul
0
exedos
Asked:
exedos
  • 3
  • 2
1 Solution
 
BNettles73Commented:
Try this ...

Start the Microsoft Management Console (MMC) Internet Service snap-in.
Expand the Default Web Site.
Right-click the Default Web site, and then click Properties.
Click the ISAPI Filters tab.
In the Filter Name field, highlight Exchfilt, and then click Remove.
Click Ok to save changes

Right-click the Default Web site, and then click Properties.
Click the ISAPI Filters tab, and then click Add.
In the Filter Name field, type Exchfilt.
In the Executable field, type c:\Winnt\System32\Exchfilt.dll (assuming that Windows NT is installed on drive C), and then click Finish. NOTE: The status of the Exchfilt filter always shows a red arrow pointing down to indicate it is not loaded. This is not true, and the filter will work anyway.
0
 
exedosAuthor Commented:
Hi, thanks for your reply. Have tried this, problem still seems to exist. On previous IIS server, the arrow was green. Still no webmail.

Thanks,

Paul
0
 
BNettles73Commented:
Have you tried reinstalling Exchange over top of the existing? (make sure you have a good backup before and after of exchange and the IIS metabase) ... btw ... I am definitely not saying to uninstall ... sometimes simply reinstalling exchange over top can resolve quirky issues ... keep in mind you'll need to reapply service packs afterwards ...

Before doing anything ... you may want to check your permissions -

Make sure that all exchange virtual directories have basic and integrated authentication enabled - and additionally, /exchweb has anonymous enabled ...

btw ... are you running exchange 5.5 or 2000?
0
 
exedosAuthor Commented:
Hi, thanks again for the reply. Havent tried an Exchange re-install as its in place and running ok at the moment, we are just trying to momve IIS to a standalone server. Its Exchange 2000.


Thanks,

Paul
0
 
exedosAuthor Commented:
If its any further help, an event with the ID of 14 in the system log, stating 'The http filter DLL f:\bin\exchfilt.dll failed to load. The data is the error.


Any further help much appreciated,

Paul
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now