Disk Quotas with Samba

I have Samba 3.0.4 running (samba is working fine) on SuSE 8.2 Personal with Webmin 1.6. I have read the instructions at www.webmin.com and have downloaded and installed the Disk Quota Module. I  have enabled quotas in
in the Disk and Filesystems section for my /usr directory. The weird thing is when I click on disk quotas under system in webmin it says The quotas package does not appear to be installed on your system but when I go into the module configuration there is not place to point to the module file..I installed the module throught the webmin configuration|webmin modules and it said the installation was successful. Can anyone tell me how to do this correctly or how to install and set quotas from the command line step by step. Thanks!
tamischultzAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
DarthModConnect With a Mentor Commented:
PAQed with points (250) refunded

DarthMod
Community Support Moderator
0
 
LuxanaCommented:
Hi,

try use your shell for now:

ENABLE QUOTAS

1:
Set options in /etc/fstab

/dev/hda2              /home       ext2              defaults,usrquota,grpquota     1     2

this is important so check you /etc/fstab and add usrquota,grpquota to options.

2:
Create the quota.user and quota.group files on top of the /home filesystem:

# touch /home/quota.user  /home/quota.group
# chmod 600 /home/quota.user  /home/quota.group

3:
Run quotacheck to initialize the databases ( /home/quota.user  /home/quota.group ).

# quotacheck -avug

4:
Then verify that your quota database files have been initialized by noting that they are no longer of size zero.

# ls -al /home/quota.*

5:
Run quotaon to enable the quota system:

# quotaon -a

6:
Verify that your system's initialization script /etc/rc.d/rc.sysinit will turn on quotas when system boots.

if [ -x  /sbin/quotacheck ]
then
    echo " Checking quotas."
    /sbin/quotacheck -avug
    echo " DONE "
fi
if [ -x /sbin/quotaon ]
then

echo " Turning on quotas."
       /sbin/quotaon -avug
fi

---------------------------------------
Try follow my steps mayby you fist missing quota files ano your partition so webming always give errror and then try continue with webmin.


LUXANA

0
 
paullamhkgCommented:
you sure you want to enable the quota in the /usr folder/directory?? /usr is mainly to contain the applications/system programs and not for data, I hope I misunderstand your question.

or if you need to setup quota in the /usr with some reason, that's fine. but becareful of the quota setting for users. and yes Luxana gave you very good hints on setting up the quota in console mode, and you may missing the quota file as Luxana said which produe there error, try what Luxana suggest and come back if you still got any error.
0
 
tamischultzAuthor Commented:
Thanks for your help, I had to upgrade the kernel to enable disk quotas
0
All Courses

From novice to tech pro — start learning today.