Solved

About VNC service

Posted on 2004-09-10
12
3,715 Views
Last Modified: 2013-11-21
I download the vnc for windows and i can get into the terminal of my linux computer from windows...

How do i get to see the whole Gnome screen?  

right now, i go on vnc viewer... type in the ip:1 and it sends me to the terminal....
i wanted to use the linux machine as i use other windows machine thru remote desktop...

Please let me know how to accomplish that
0
Comment
Question by:jibranilyas
  • 6
  • 3
  • 3
12 Comments
 
LVL 3

Accepted Solution

by:
frieked earned 400 total points
ID: 12028025
The link below has exactly what you're looking for.
http://www.justlinux.com/nhf/Networks/Using_VNC_with_Linux.html
0
 
LVL 1

Assisted Solution

by:ash4stuff
ash4stuff earned 100 total points
ID: 12028335
you need a file called xstartup under the .vnc folder of the user that starts the vnc server that reads:

gnome-session

restart the vnc server and then it should work...




0
 
LVL 1

Expert Comment

by:ash4stuff
ID: 12028346
if that doesnt work, post the .log under the .vnc folder
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 1

Expert Comment

by:ash4stuff
ID: 12028358
oh and make sure there is a vnc server running on the linux machine...
post what you get with: ps aux | grep vnc
0
 

Author Comment

by:jibranilyas
ID: 12028389
first i was seeing the terminal only... after modifying the file xstartup, i can only see a black screen with X as the cursor.

I deleted all the text from the xstartup file and replaced it with the following lines

!/bin/sh
[ -r $HOME/.Xresources ]
&& xrdb $HOME/.Xresources
xsetroot -solid grey
exec gnome-session &

Saved the file and restarted the vnc using

vncserver -depth 16 -geometry 800x600



0
 

Author Comment

by:jibranilyas
ID: 12028418
here is the log

Xvnc version 4.0b4 - built Apr 14 2004 12:42:18
Underlying X server release 40300000, The XFree86 Project, Inc


Fri Sep 10 11:19:02 2004
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
/root/.vnc/xstartup: line 1: !/bin/sh: No such file or directory
/root/.vnc/xstartup: line 3: syntax error near unexpected token `&&'
/root/.vnc/xstartup: line 3: `&& xrdb $HOME/.Xresources'

Fri Sep 10 11:19:17 2004
 Connections: accepted: 10.0.1.245::2910
 SConnection: Client needs protocol version 3.7
 SConnection: Client requests security type VncAuth(2)

Fri Sep 10 11:19:21 2004
 Client:      Server default pixel format depth 16 (16bpp) little-endian rgb565
 Client:      Client pixel format depth 8 (8bpp) rgb max 3,3,3 shift 4,2,0
************
eng of log file
0
 

Author Comment

by:jibranilyas
ID: 12028648
[root@nagiosmachine root]# ps aux | grep vnc
root      3941  0.3  3.0 41044 16020 ?       S    11:07   0:08 gedit file:///root/.vnc/nagiosmachine%3A1.log
root      4213  0.0  0.8  8404 4484 pts/7    S    11:19   0:00 Xvnc :1 -desktop nagiosmachine:1 (root) -httpd /usr/share/vnc/classes -auth /root/.Xauthority -geometry 800x600 -depth 16 -rfbwait 30000 -rfbauth /root/.vnc/passwd -rfbport 5901 -pn
root      4364  0.0  0.1  4220  580 pts/7    R    11:46   0:00 grep vnc
[root@nagiosmachine root]#
0
 
LVL 3

Expert Comment

by:frieked
ID: 12028723
The first line in the xstartup file should be:
#!/bin/sh
You left out the '#'
0
 
LVL 3

Expert Comment

by:frieked
ID: 12028733
If /bin/sh still can't be found try #!/bin/bash
or the location of whatever shell it is you are using.
0
 

Author Comment

by:jibranilyas
ID: 12028770
i put the # sign back

saved the file and restarted VNC

still the same problem... black screen.... with X cursor

how can i find out the location of shell that i m using
0
 

Author Comment

by:jibranilyas
ID: 12028795
http://www.justlinux.com/nhf/Networks/Using_VNC_with_Linux.html

i took out the # sign out per instruction set  " http://www.justlinux.com/nhf/Networks/Using_VNC_with_Linux.html "

Now you need to edit the ~/.VNC/xstartup (you can use any text editor to do this). In this file uncomment (remove the # signs) from these lines:

#!/bin/sh
[ -r $HOME/.Xresources ]
&& xrdb $HOME/.Xresources
xsetroot -solid grey
exec gnome-session &

0
 

Author Comment

by:jibranilyas
ID: 12029190
Thanks for the help guys... its working now

had to add the following two lines

unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Windows 10 is here and for most admins this means frustration and challenges getting that first working Windows 10 image. As in my previous sysprep articles, I've put together a simple help guide to get you through this process. The aim is to achiev…
Know what services you can and cannot, should and should not combine on your server.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question