• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 698
  • Last Modified:

Unable to start oracle 9i database instance after change of parameters

 I have tried to change parameters on Oracle 9i server instance running of Windows XP. After that, I am not able to restart the service. how can I restart my database again?
the parameters I have changed is:
archive_destination_0= '' (old is 'c:\archivelog')
archive_destination_0=disabled ( old is enabled)
lock_sga=true (old is true)
When I choose the option to restart immediately , I could't restart the database.
I am getting an error ORA-27100: shared memory relam already exists.
I even tried to restart the system but no luck!!
How do I restart my database? database is important for me!!
  • 7
  • 7
1 Solution

you have to be more accurate.

there is no such parameter called "archive_destination_0" in oracle database.

there is LOG_ARCHIVE_DEST_x with x being a number from 1...9

but your error message is different, it's basically saying that you have the database running already.

I will give you a quick fix, modify the init.ora back to what it was before.

shutdown the computer and reboot...
Pierrick LOUBIERIS Operational Excellence ManagerCommented:
First, you should NOT disable all archive_destinations if your DB runs in archive log mode. Here are steps to check parameter and change behaviour http://www.adp-gmbh.ch/ora/concepts/backup_recovery/archive_vs_noarchive_log.html

Second, to get rid of ORA-27100, follow these steps :

1/ connect / as sysdba
2/ shutdown abort
3/ startup
4/ shutdown immediate
5/ startup
gvsbnarayanaAuthor Commented:
Hi seazodiac,
Yes... the parameters are LOG_ARCHIVE_DEST_1 and  log_archive_dest_state_1.
How do I change  init.ora. file? i mean I have found the init.ora for the corresponding database but each and every line start with *. . and found that the values are already the previous values.
I have tried to start up the instance with the def_instancename.ora file. but I get a the message ORA-27100 : shared memory relam already exists.
this message is after restarting the PC.
How do I proceed now?
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

then your database is up and running.

try to connect to it using sqlplus

what 's the message?

the reason is that you are using SPFILE instead of PFILE that's why you are seeing *. entries.

but anyway, is this a personal computer? I hope it's not production or any kind, because I sense the danger...
take a look at your control panel--->administrative tool=--->services --->

an entry called "OracleService<DB SID>" see if it's started automatically
gvsbnarayanaAuthor Commented:
Hi poloubier,
 I have tried the following:
commandprompt> set oracle_sid=test ( test is the database name)
sqlplus /nolog
then connect sys/password as sysdba
It responded saying connected to an idle session.
shutdown abort : Oracle instance shutdown
startup : ORA-27100: shared relam already exists.
how do I proceed?
gvsbnarayanaAuthor Commented:
I have checked services.. oracle service is started already.
Yes.. this is a personal computer but this is my development PC. all development data is in here.
try to connect to the database using sqlplus , see what happens? please be complete
gvsbnarayanaAuthor Commented:
I tried to connect using sys/manager@test as sysdba
response is Connected to an Idle instance.
When I try to issue a query select * from v$parameter, error message: ORA-01034 ORACLE not available.
please do this as strictly as it can be:

in the Services panel --->shutdown the OracleService<SID> service manually.

then go back to your DOS windows:

C:\>sqlplus "sys/manager@test as sysdba"

connect to an idle instance
SQL>create spfile from pfile='<where your oracle init.ora file>'    --this file should be in <oracle_dir>\admin\<sid>\pfile folder...



gvsbnarayanaAuthor Commented:
I have tried this: the result is
error: ORA-12500: TNS : listner failed to start a dedicated server process
gvsbnarayanaAuthor Commented:
sorry... when I try to connect using sqlplus "sys/manager@test as sysdba" then , I got the error message
ORA-12500: TNS : listner failed to start a dedicated server process
ok, here is what you are gonna do,

in the SERVICES Panel, make the OracleService<SID> startup type to "MANUAL" , meaning this service will startup automatically when the machine reboot.

then you do the same step as I said above.
gvsbnarayanaAuthor Commented:
Hi Seazodiac,
   I got the instance started well. Thanks a lot for your support.
not a problem, rock'on
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now