Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

IIS 5.1

Posted on 2004-09-10
3
Medium Priority
?
179 Views
Last Modified: 2010-04-20
I have IIS 5.1 installed on a windows xp pro SP2 machine.  I have set the root directory on my I: partition and set the ntfs permissions on that partition to administrators and system only.  When I try to load the webpage I get the not authorized to view this page message.  With the permissions set as they are, shouldn't a username and password box come up instead?  What am I missing?
0
Comment
Question by:firemanrob
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 33

Expert Comment

by:humeniuk
ID: 12028919
If you haven't already done so, remove the restrictions and make sure you can see the website in that location.  If you can, see 'How to set required NTFS permissions and user rights for an IIS 5.0 Web server' at http://support.microsoft.com/default.aspx?kbid=271071
0
 

Author Comment

by:firemanrob
ID: 12029561
I can see it fine without the restrictions in place.  I had used IIS before with the same restrictions and I was challenged with the password box.  Now I'm not.  Just wondering if there is a setting of an .htaccess type file I need to put in--something like that.
0
 
LVL 33

Accepted Solution

by:
humeniuk earned 1000 total points
ID: 12030626
There is, but I'm not completely certain it's the same in IIS 5.1 with WinXP as it is with IIS5/Win2k Server or IIS6/Win2k3 Server (which I'm more familiar with).  However, we can try it and see . . .

Go to Internet Information Services, right click your website and select Properties.  In the website properties box, select the Directory Security tab and beside 'Anonymous access and authentication control' select 'Edit'.   This opens the Authentication Methods box.  I presume you don't want to allow Anonymous access, so make sure that's unchecked.   Under Authenticated access, check the box beside Integrated Windows authentication.

You can read more about this here: http://www.windowsecurity.com/articles/Installing_Securing_IIS_Servers_Part1.html (near the bottom of the page).

A
0

Featured Post

Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Periodically we have to update or add SSL certificates for customers. Depending upon your hosting plan you may be responsible for the installation and/or key generation. In the wake of Heartbleed many sites were forced to re-key. We will concen…
Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question