• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2761
  • Last Modified:

OWA "You are not authorized to view this page"

I'm trying to redirect http to https for OWA.  I've simply made an html page to redirect http to https and edited my custom errors.  I've tested this page and it works fine.  However for some reason http doesn't go to my webpage.  It only gives me "You are not authorized to view this page".  This isn't the 403.4 error, as it states you must use https://.  I've verified my permissions a million times, made sure browse directory is selected and about a million other things.  I can't figure out why I can't get to my page.  It appears that I'm not getting any custom errors from IIS.  I enter http://mail.mydomain/a;lkjdflkj  and i get the same error, and this page obviously doesn't exist.  

The first few times I tried this it worked and then all of a sudden I get this error.  
0
mrsmith14
Asked:
mrsmith14
  • 7
  • 4
1 Solution
 
divtCommented:

Hi, you may find info in one of the following links useful:

"You are not authorized to view this page." or similar error messages
http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q327003
http://support.microsoft.com/?kbid=290989
http://support.microsoft.com/default.aspx?kbid=327843

Required OWA Permissions
http://www.brienposey.com/kb/required_OWA_Permissions.asp

Good luck!
0
 
mrsmith14Author Commented:
Everyone can logon fine over https the problem is with the default errors.  Further investigation has shown my redirection works with Mozilla, but not IE.

I began my troubleshooting with most of those articles... prior to posting here.
0
 
mrsmith14Author Commented:
btw this is exchange 2000
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
mrsmith14Author Commented:
oh and FYI ... when I logon as an administrator internally I get the same error
0
 
divtCommented:
Sorry my post didn't help.  Your issue beats me.  Hope other experts drop by and shed some lights.
0
 
mrsmith14Author Commented:
i appreciate you trying...  thx
0
 
mrsmith14Author Commented:
bump
0
 
divtCommented:
mrsmith14 ,

I have an idea.  

How about doing redirection from http -> dummy https page -> real https page?

I mean instead of redirecting directly to the OWA https page that you want, try redirecting to non-OWA https page first, which will redirect to the OWA https page finally.

What do you think?
0
 
mrsmith14Author Commented:
Lemme see what I can come up with.  I'll try it here in a few.  
0
 
mrsmith14Author Commented:
Well here was my problem.  OWA is my default website.  I was requiring ssl on the default website, which wouldn't allow it to connect to my http page.  The best article I've found from MS is here http://support.microsoft.com/default.aspx?scid=kb;en-us;555126
I'll give you the points just for reminding me to work on this again... lol
0
 
divtCommented:
Well, actually, your 'bump' brought me back to this Question.  :-)

Any way, the article at MS was great.  Might as well need it myself!!!

0
 
judgekingCommented:
This kind of error can occur if the custom error page itself requires HTTPS.  Then it can't run.  So place it in its own folder and uncheck 'Require SSL' on that folder only.  See http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_21958558.html
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now