Solved

setup QOS for Voice on a Frame Relay using 1720 routers

Posted on 2004-09-10
3
274 Views
Last Modified: 2010-04-17
We have 4 locations using a Frame Relay for Data and Voice. Some of the voice connections are breaking up when data is used on the network. We would like to setup QOS so that voice will take priority over the data.


Here is one of the config of the primary frame router.

Using 1416 out of 29688 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Melbourne_Frame
!
enable secret 5 $1$qMzC$AZHr2Ylgrgx1O2dx5SnXA.
enable password 7 05080F1C22431F
!
ip subnet-zero
ip name-server 12.127.17.71
!
!
!
!
!
interface FastEthernet0/0
 description Melbourne LAN
 ip address 192.168.2.2 255.255.255.0
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 service-module t1 timeslots 1-12
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description Rogers, AR
 ip address 10.254.254.1 255.255.255.252
 frame-relay interface-dlci 102  
!
interface Serial0/0.2 point-to-point
 description Manchester, NH
 ip address 10.254.254.5 255.255.255.252
 frame-relay interface-dlci 101  
!
interface Serial0/0.3 point-to-point
 description Boucherville, CA
 ip address 10.254.254.13 255.255.255.252
 frame-relay interface-dlci 105  
!
interface Serial0/0.4 point-to-point
 description Three Rivers, CA
 ip address 10.254.254.9 255.255.255.252
 frame-relay interface-dlci 103  
!
router eigrp 100
 network 10.1.1.0 0.0.0.255
 network 10.254.254.0 0.0.0.255
 network 192.168.2.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1 200
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 1513080D507B78650870
 login
!
no scheduler allocate
end
0
Comment
Question by:morsecom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 7

Expert Comment

by:pedrow
ID: 12030373
I've used priority queueing successfully for VOIP in the past. You can either do it by source/destination if your VOIP stuff has dedicated netblocks or by source/dest ports if you know the protocols used.

Here's an example:

interface Serial2/0/0
 ip address xxxxxxxxxxxx 255.255.255.252
 no fair-queue
 priority-group 10
!
priority-list 10 protocol ip high list 113
!
access-list 113 permit tcp 172.16.255.0 0.0.0.255 range 3200 3201 172.16.255.0 0.0.0.255 range 3200 3201
access-list 113 permit tcp 172.16.255.0 0.0.0.255 range 3200 3201 172.24.1.80 0.0.0.15 range 3200 3201

So, in this example, I knew the source-dest pairs and the protocol ranges. These packets got tagged as 'high' priority. All else got tagged as normal.

Lots of good QOS info and possibilities can be read about here if you don't think QOS is your best option:
http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/prod_configuration_guide09186a008017d8e5.html

i.e. you can try things like traffic shaping, rate limiting, etc, but it still comes down to you being able to sift out the VOIP traffic from the rest of it.

Hope this helps.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12031614
Here's another example of LLQ / traffic-shaping that works pretty well...

!
class-map match-all bts
 match access-group 101
!
!
policy-map TEST
 class bts
  priority 64
 class class-default
  fair-queue
!
!
interface Serial0/0
 description LINK TO FRAME-CIRCUIT
 bandwidth 512
 no ip address
 encapsulation frame-relay
 ip route-cache flow
 no ip mroute-cache
 frame-relay traffic-shaping
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description *remote*
 bandwidth 256
 ip address 192.168.254.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 31 IETF
  class voip
!
!
map-class frame-relay voip
 frame-relay cir 256000
 frame-relay bc 2560
 frame-relay be 0
 frame-relay mincir 256000
 frame-relay fragment 320
 service-policy output TEST
!
access-list 101 remark VOIP to *remote*
access-list 101 permit ip host 172.18.91.240 host 172.18.92.240
access-list 101 permit ip host 172.18.91.241 host 172.18.92.241
!

Reference:
http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuration_example09186a0080094af9.shtml
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 75 total points
ID: 13688746
Do you need more information?
Have you resolved this problem?
Can you close this question?
Thanks!
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question