Solved

Samba 3 Problem with NT Users

Posted on 2004-09-10
2
188 Views
Last Modified: 2013-12-15
I have installed Fedora RC2 with all of the updates and Samba Version 3.0.6-2.fc2.  Below is a copy of my smb.conf file.  I was able to add the computer to the domain with out problem.  When I issue a wbinfo -u or -g I get all of the expected output.  The strange thing is when I try to use getent passwd some users(NT Users) get the expected output other users do not get anything returned.  For the users that I do get information back with using the wbinfo I am able to chown files/directories to their user name and NT user groups and they show up properly when browsing the "Network".  Hope someone can shed some light on this for me.

Thanks

# Global parameters
[global]
        workgroup = DOMAIN1
        netbios name = FILESERVER
        server string = Dell 6300
        security = DOMAIN
        auth methods = winbind
        password server = *
        unix password sync = Yes
        log level = 2
        log file = /var/log/samba/%m.log
        max log size = 50
        name resolve order = wins lmhosts
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = /etc/printcap
        os level = 0
        preferred master = No
        domain master = No
        dns proxy = No
        wins server = 192.168.1.2
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        winbind separator = +
        winbind enable local accounts = No
        winbind use default domain = Yes
        guest ok = Yes
        hosts allow = 127.0.0.1, 192.168.1.0/255.255.255.0
        case sensitive = No
        strict locking = No
 
[homes]
        comment = Home Directories
        read only = No
        browseable = No
 
[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No
 
[samba]
        comment = UsersShare
        path = /var/samba
        read only = No
        browseable = Yes
        inherit permissions = Yes
0
Comment
Question by:paulbueltmann
  • 2
2 Comments
 
LVL 12

Expert Comment

by:paullamhkg
Comment Utility
Is there any firewall setting in the NT client which disable the connection from your samba to NT clients? or have you try to disable the NT client firewall and set to accept the samba connection?
0
 
LVL 12

Accepted Solution

by:
paullamhkg earned 250 total points
Comment Utility
have a check on this http://www.siliconvalleyccie.com/linux-hn/samba-trouble.htm may give you some idea :)
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

Suggested Solutions

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now