Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 328
  • Last Modified:

Terminal Server behind firewall

Hi All,

I am trying to get my terminal server accessible by people outside the firewall. I have a router and then connected to a Win 2k3 server.

i have read on the internet that this port is 3398. and i have tried to set up my router to forward this port to my Server 192.168.0.1 address, but unsuccessful.

Please help

-herman
0
hermanlam
Asked:
hermanlam
  • 4
  • 3
  • 2
  • +1
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
The correct port is 3389 - not 3398.
0
 
hermanlamAuthor Commented:
hi there.

sorry...it was a typo...3398 is the one i typed...but it still doesn't work.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Download PortQry from Microsoft and confirm the port is open (run the program from a machine internally and externally - is there a difference in the resutls.

Also, can you connect internally to the server via an RDP session?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
harleyjdCommented:
What sort of Router? Do you have mail services or Web services running over it? Do they forward OK?

I ask only because some routers require not just a virtual server set, but also a rule permitting connections to the virtual server. If you have mail or web running OK, then duplicate their settings.

And just for competeness sake - it's 3389 TCP - make sure you haven't chosen UDP by mistake...

0
 
karel_jespersCommented:
hi,

to be able to access a terminal server behind a firewall
i  used port 110 for this        (use the scan as earlier said)
on the router forwarded port 110 to the terminal server
and changed the listening port on the terminal server to port 110
 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

and access the server using "ipaddress-router:110"

karel
0
 
karel_jespersCommented:
ps bcs on most firewalls port 3389 if by default closed
0
 
hermanlamAuthor Commented:
hm...there seems to be a problem of my router. i cannot forward any of the ports in.

here's the setup :
I have set my win2k3 server (2 NIC, one connecting to the router, one connecting to my LAN)
i have my line connecting to the router set up to be 192.168.123.1
and the other 192.168.0.1

all the things work perfectly (all my NAT, terminal service, IIS) within the firewall.
i set my router to have virtual service 80, 3389 forwarded to my 192.168.123.1, but THEY ARE NOT WORKING ..

please help !


Thanks all
0
 
karel_jespersCommented:
hi,
also another thing to check
in the system properties / remote tab / select alow users to connect remotely to this computer

karel
0
 
hermanlamAuthor Commented:
thanks guys! i think i have solved the problem. The problem actually originated from my NAT firewall. I forgot to enable HTTP and remote desktop services on the NAT basic firewall.

Thanks all!
0
 
karel_jespersCommented:
okay that makes one more happy person
tks and goodluck
0
 
harleyjdCommented:
Then why did you accept Karel's answer when mine was accurate? I asked you exactly whetther other services were running OK, and to check all their settings.

I think you should request a reallocation of the points in the CS forum.





0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now