Solved

Setup two separate networks using Linksys routers

Posted on 2004-09-10
15
680 Views
Last Modified: 2012-05-05
I would like to setup two separate networks (let's say 192.168.1.X and 192.168.2.X) to separate to groups of people.

If possible I would to set up something like this:  Floor 1 has a DSL modem connected into a Linksys Wireless G Router (WRT54G).  This router is configured with LAN Ip: 192.168.1.1  Subnet mask: 255.255.255.0.  The WAN is configured with the PPPoE connection settings to the ISP.   This setup works and has internet access.

I would like Floor 2 to use 192.168.2.X as their IP scheme and be able to connect to the internet.  This network will use a Linksys Router (BEFSX41).  I configured the LAN Ip to 192.168.2.1 and Subnet mask to: 255.255.255.0.  From this point I cannot figure out how to make this setup work (if it even can).  

Basically, I just want Floor 1 to use 192.168.1.X and have their own network with internet access, and Floor 2 to use 192.168.2.X with their own network and internet access.

This is how I tried to connect the Floor 2 router.  I used a patch cable and went from port 4 of the Floor 1 router to the WAN port of the Floor 2 router.  I configured the WAN port of Floor 2 to "Obtain Ip Automatically".  The DHCP server assigns the correct credentials to a workstation (i.e. IP: 192.168.2.100  Subnet mask: 255.255.255.0, and default gateway: 192.168.2.1)  I tried putting the gateway as 192.168.1.1 and that didn't work.  I can't ping 192.168.1.1.  I tried going from Port 4 Floor 1 to Port 1 Floor 2.  Nothing I try seems to work.

Does anyone have experience setting something like this up?  Thanks for your help!
0
Comment
Question by:jplagens
  • 7
  • 3
  • 3
  • +2
15 Comments
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
It should work just fine if you keep the 2nd floor router in "Gateway" mode versus "router" mode.

DSL -- WRT54G---192.168.1.x ------BEFSX41--- 192.168.2.x
                                                WAN        LAN

If the client is getting a 192.168.2.100 address, the gateway should be set to 192.168.2.1, the local gateway. Changing it to 192.168.1.1 (remote gateway) will absolutely not work. The default gateway must be local to the PC.

Does your status on the BEFSX41 show that you get an IP address on the WAN port that is 192.168.1.10x ?

I have very similar setup working just fine. I can get to the internet from anywhere in my net through the WVRT54G

Cable -- WVRT54G ---192.168.122.0--- BEFW11-S4-----192.168.123.0
                                                     --- Cisco 3550 ---- 192.168.124.0
                                                            |                   192.168.125.0
                                                            | --- Cisco 3640 ---- 10.10.10.0
                                                                        |
                                                                    Cisco 1601 ---- 10.20.20.0

                                     
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
I've tried to setup the configuration like you said but I'm still not able to connect from Floor 2.  I don't know what I'm doing wrong.

Here's the config that I have.  

DSL modem to the WAN port of WVRT54G (192.168.1.1)
Port 1 of WVRT54G to WAN port of BEFSX41 (192.168.2.1)
Client computer plugged into Port 1 of BEFSX41 on Floor 2

I upgraded the firmware of the BEFSX41 to 1.50.18.  On the WVRT54G it says it's in Gateway mode.  The linksys website says that is the correct mode for the router that is providing the internet access (I don't know if that is right).  Since I upgraded the firmware on the BEFSX41 (Floor 2) I can't find where it tells me if it's in Router or Gateway mode.

On the BEFSX41 (Floor 2) I have it set to "Obtain IP automatically" on the WAN side.  When I look at the status for the WAN side.  It doesn't have any IP addresses assisgned on the WAN side.  The LAN side says the correct settings.

Then I tried using "Static IP address" on the WAN config.  I entered this info: (although I'm not sure what to enter here??)
IP: 192.168.1.120
Mask: 255.255.255.0
Gateway: 192.168.1.1
DNS Server: 151.164.11.201 (SBC DNS server address)

I enabled Dynamic Routing and chose "RIP 1" for TX and RX.  Still nothing.

In all of my different tries to get it working.  Sometimes when I try to ping 192.168.1.1 from the Floor 2 BEFSX41 router I receive "Request Timed Out".  Other times when I try the same thing I receive "Reply from 192.168.2.1: Destination net unreachable"  I don't know if I'm getting close when it says that or not?????

What do you think it could be?  I really appreciate your help with this.




0
 
LVL 8

Expert Comment

by:MarkDozier
Comment Utility
you need a cross-over cable from router to router.
"  I used a patch cable and went from port 4 of the Floor 1 router to the WAN port of the Floor 2 router"
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
The cross-over cable was a big part of the problem!  I have the cross-over from Port 4 of the Floor 1 router to the WAN port of the Floor 2 router.  Now the WAN port is being assisgned an IP address.

On the Floor 2 side (192.168.2.X) I still can't get out.  I can ping 192.168.2.1 (BEFSX41 router).  If I try to ping Yahoo for example, I'll type:

ping www.yahoo.com   It will say Pinging [216.109.118.72]....  then I get four "Request Timed Out".  It looks like it's trying to resolve names.  Something is still not allowing it to see out.  It also times out if I try to ping 192.168.1.1 (WRT54G Floor 1 router).

I added a static route on the Floor 2 router (BEFSX41) with this info:
IP: 192.168.1.0
Mask: 255.255.255.0
Gateway: 192.168.1.1

That didn't allow it to see out either.

Any ideas on what is not allowing it to see out?
0
 
LVL 11

Accepted Solution

by:
PennGwyn earned 300 total points
Comment Utility
> This is how I tried to connect the Floor 2 router.  I used a patch cable and went from port 4 of the Floor 1 router to the
> WAN port of the Floor 2 router.  I configured the WAN port of Floor 2 to "Obtain Ip Automatically".  The DHCP server
> assigns the correct credentials to a workstation (i.e. IP: 192.168.2.100  Subnet mask: 255.255.255.0, and default
> gateway: 192.168.2.1)  I tried putting the gateway as 192.168.1.1 and that didn't work.  I can't ping 192.168.1.1.  I tried
> going from Port 4 Floor 1 to Port 1 Floor 2.  Nothing I try seems to work.

The problem is that the WAN port of router 2 is set to "Obtain Ip Automatically", but NAT is not enabled on this router.  So router 1 gets responses back that it NATs to 192.168.2.x addresses -- and it has no route to that subnet.

The simplest fix is to assign router 2's WAN port a STATIC 192.168.1.x address -- outside the DHCP scope offered by router 1 -- and give router 1 a static ROUTE telling it that 192.168.2.x lies behind that address.

(Alternatively, you could turn on NAT on router 2, but troubleshooting the result could be more challenge than you're up for.)



0
 
LVL 8

Expert Comment

by:MarkDozier
Comment Utility
Great answer Penn. Why didn't i think oif that
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
Thanks for the help!  No I'm up for whatever challenge this takes.  I have two partners at bitter disagreement over some issues and they want this working to have separate networks.

I'm not sure what: "give router 1 a static ROUTE telling it that 192.168.2.x lies behind that address" means. I did my best and this is what I have.  From a workstation on the router 2 side (192.168.2.X)  I can ping across the gateway of 192.168.1.1.  For example, I can ping a workstation at 192.168.1.10 and get a reply.  I can ping the server at 192.168.1.120 and get a reply.  I can't ping 192.168.1.1. Nor can I connect to the internet.

Here are my latest configs:

Router 1 (192.168.1.1)
Advanced Routing section:
Operating mode: Gateway
Static Routing section
Destination IP address: 192.168.2.0
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.2.1
Interface: LAN & Wireless

Router 2 (192.168.2.1)
I assigned this router a WAN static IP address of 192.168.1.132 (outside of the DHCP server scope)
Advanced routing section:
NAT: Enabled
Dynamic Routing: Enabled
Transmit RIP Version:  RIP2
Receive RIP Version: RIP2

I've tried bunches of different scenarios.  Nothing is allowing me to get out to the internet..





0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 4

Author Comment

by:jplagens
Comment Utility
I appreciate everyone's efforts so far.  Please don't leave me hanging!  I've got to get this working.  thanks.
0
 
LVL 8

Expert Comment

by:MarkDozier
Comment Utility
At this point given the "bitter" issue I suggest calling in a consultant.
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 200 total points
Comment Utility
Router 1 (192.168.1.1)
Advanced Routing section:
Operating mode: Gateway
Static Routing section
Destination IP address: 192.168.2.0
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.2.1 <==== this should be the WAN interface of R2 = 192.168.1.132
Interface: LAN & Wireless
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Are you still working on this? Any progress to report?
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
Never got this working.  Ended up just setting up a different workgroup and it appeased them.  I'm up for it if you guys want to throw this around a little bit more.  I would definitely like to find out why it's not working.  I ended up spending a lot of time with it and it would never get out to the internet.  I could ping across the gateway a get a reply from a specific machine, but nothing beyond that.
0
 

Expert Comment

by:Seffius
Comment Utility
I'm trying to do the same setup...I have a question for you.  You said from router 2 you could ping 192.168.1.x addresses.  But from Router 1 could you ping 192.168.2.x addresses?  That's a toughey I've run into...Perhaps it's because Router 2 thinks the pings from Router 1 are from the Internet??
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
Sorry to take a long time to get back to you.  I don't remember if I could ping router 2 (192.168.2.x) from router 1.  I want to say that I could not.  You might be onto something.  Maybe router 2 thinks router 1 pings are from the internet.

I'll set my routers up again and see if I come up with anything.  Let me know if you make any progress.

thanks!
0
 
LVL 4

Author Comment

by:jplagens
Comment Utility
I finally got this going.  I ended up throwing out the Linksys BEFSX41 and got a Netgear FVS318.  I left all the settings the same on the Linksys WRT54G.  I setup the WAN port on the Netgear to a static IP address outside of the DHCP on the Linksys router.  I set up the LAN side to another subnet (192.168.2.X), hooked it up, and I could get out to the internet and the workstations are on their own separate network.  Thanks!  Couldn't have done it without all of the previous help!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now