Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 303
  • Last Modified:

Connect new device to network

I know this is going to be easy for somone!
Anyway, I have 3 machines connected on a small network each device has fixed IP address in the range 192.168.0.xx and are connected via a switch which in turn connects to a router that allows access to the internet. The switch is there as the router only allows 10mps and the switch 100.
Everything works fine and I can access the internet and each computer with no problems. I am running XP Pro.

I have just purchased a Keyspan USB server (in response to a previous question).
This device uses port 3842 and DHCP.
I have tried connecting as per the doncumetation and even tried connecting direct to the ethernet port bypassing the switch.

I have disabled Windows firewall as I run Norton Internet security professional. I have tried disabling Norton as I suspected it was blocking access on port 3842.

I still cannot access the USB server, if I could I could change the DNCP to fixed IP and I guess everything would work.

My question is how do I add the server?

Thanks
0
Muskett
Asked:
Muskett
  • 28
  • 19
  • 3
  • +2
1 Solution
 
adamdrayerCommented:
If your router is serving DHCP, then you may be able to login to it, and see if it is issuing an IP address.  Otherwise, type "arp -a" at a command prompt.  It will list the IP addresses and MAC address of those devices which have broadcasted.

Why do you mention your Operating System?  this device is network aware correct?  it plugs into the switch or router and is suppossed to be issued an IP address by the router?  do you have DHCP enabled on the router?  you say you are using static IP address.  If you have DHCP enabled on the router, did you resevere the addresses being used so that DHCP won't try to issue those?

How are you trying to access the USB server?
0
 
MuskettAuthor Commented:
Thanks guys,
to answer you both:
The reset does not help, already tried.
arp -a returns the addresses of the 2 computers that are currently connected to the switch. The router and switch are not reported.
Am I correct in thinking that the switch does not have an IP address?
You ask if I have dhcp enabled in the router, I do not know! It is a Cisco ubr900 and is supplied by the ISP. I use the router to connect only to the internet
as I mentioned originally.
I did not have any problem recently connecting my new laptop to the network, I gave it an IP 192.168.0.5 and it worked first time.
Sorry I am not too "network savy".
To try and access the Keyspan I am using their own interface console.
Hope that helps a bit..
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
MuskettAuthor Commented:
Sorry what I said above is not quite correct. arp -a gives the 2 computers and the router,
i.e, from 192.168.0.2
returns
192.168.0.1
192.168.0.4
0
 
crissandCommented:
The USB server must be connected to the switch first. Then, you must install the software provided with the product. When installed, the software will serach for the usb server. If it cannot find it, must be a problem of cables and/or ports.

If you can't see the server on the network try adding an address usind arp -c ip_address mac_address

The mac addresss must be on the device label.
0
 
MuskettAuthor Commented:
The cables are OK because its the same as I use for my portable.
 
Ports may be an issue, the manual specifies port 3842 I am not sure how to enable it.

Also I do not understand your arp -c instructions
The mac of the server is 006001012a3a
I have tried but the arp returns the standard switches indicating that it has not accepted teh input.
0
 
adamdrayerCommented:
how many green lights do you have?
0
 
MuskettAuthor Commented:
4 USB no devices connected
3 network one blinks occasionally, the one on the right closest to the network port
1 system light blinks every 3 seconds as per manual
0
 
adamdrayerCommented:
from the status lights, it seems that the server is up and running.  So the software that came with it is having trouble connecting to it?
0
 
MuskettAuthor Commented:
Yep
0
 
adamdrayerCommented:
I have a sneaking suspicion that your DHCP is serving out addresses in a different range than 192.168.0.x, and so your usb server is on a different logical subnet than the rest of your machines.  Try setting your workstation to "Obtain IP Address automatically" and rebooting.  Then try to connect to the usb server.  Also take note your new IP address.  If it doesn't work, return to a static setting, reboot, and post the address that was issued.  

I'm going to lunch now.
0
 
MuskettAuthor Commented:
Will try and bon apetite,
Am in Europe so I will let you know what happens then go for dinner,
thanks
0
 
MuskettAuthor Commented:
Well done you are an the right track.
I did the obtian IP... and it worked I could see the server!
So to be clever (wrong move maybe) I changed the address of the server to match my 192.168.0.xx set up and renamed it to 192.168.0.10
subnet mask 255.255.255.0 and gateway to 192.168.0.1 the router. maybe this is wrong as the router does not come into play
I dont think as the server is connected to the switch, the router being for internet access only. should the gateway be the host PC?

Does this not cause problems as I want all 3 pc's to connect to the server.

Thanks again
Dave
0
 
MuskettAuthor Commented:
Oh yes, I can ping sucessfully 192.168.0.10 which means that the server has accepted the new address.
Ping fails to the old IP address of the server.
0
 
MuskettAuthor Commented:
And now more disaster. I cannot see the server (with its new IP address) even if I go back and change the network settings to auto.
One thing though, on arp -a I can now see the server 192.168.0.10 as well as the other computers.

0
 
adamdrayerCommented:
the gateway would only be if your server wanted to access something not on your network.  It probably doesn't matter what it is since this is unlikey.  To be "correct", however, it should probably be the router
0
 
MuskettAuthor Commented:
So I have set it up OK then why can I not see it.
Points upped as I can see this is not as easy as I first thought
0
 
adamdrayerCommented:
>>And now more disaster. I cannot see the server (with its new IP address) even if I go back and change the network settings to auto.

What are you changing back to auto?  the server?  or the computer?  it sounds like your server is configured correctly with 192.168.0.10.  Now you need to configure your computer with it's old static IP address of 192.168.0.x, and you should be able to see it.

and what do you mean when you say you cannot "see it"?
0
 
MuskettAuthor Commented:
OK, I have reset back everything with static IP addresses as before.
Everything works and the computers connect to each other and the internet.
When I run arp -a (or ping) I can see 192.168.0.10, the router (192.168.0.1) and the other PC 192.168.0.4
Fine so far.

What I cannot do is run the Keyspan console and see the Keyspan server.
0
 
adamdrayerCommented:
This is where it may be a firewall problem.
0
 
crissandCommented:
There was an error, is arp -s ip_address mac_address
0
 
MuskettAuthor Commented:
Sorry, I do not understand what I am supposed to do with arp -s ip_address mac_address.
See my last post 05.51 and please help a non network savy person
Thanks
0
 
MuskettAuthor Commented:
And I opened the question thinking it would be easy!
So this is where I am:
I have been able to access the Keyspan once and changed its settings to allow connection to my fixed IP address as above.
It is set to 192.168.0.10 and I can ping it successfully from any computer on the network. It also shows up when I run arp -a

I have downloaded the new software from the Keyspan site.

I I still cannot get the damn thing to connect from the Keyspan console.
I am not running windows firewall and I have disabled Norton internet security.

I am completely lost and more that a little angry the the Keyspan documentation gives no guidance!

Please help,
Thanks
0
 
crissandCommented:
With arp you give the server a fixed address:

On a station type:

arp -s 192.168.0.10 006001012a3a

Now you can verify pinging 192.168.0.10, but to configure the server you must use the software from keyspan. Verify on the station to have installed only tcp/ip protocol, not others.
0
 
MuskettAuthor Commented:
Thanks for that but surely I do not need to do that as I can ping 192.168.0.1 with sucess
Am I correct?
On network properties I have
Client for microsoft networks
File and print sharing for MS networks
QoS packet scheduler
TCIP
0
 
adamdrayerCommented:
Acording to the manual, you need to connect a USB device bef.ore anything will be recognized by the software
0
 
MuskettAuthor Commented:
To recognise USB devices but not the server itself, surely. Anyway I have just tried and no luck!

I spend an hour on the phone with a Keyspan tech guy in UK and he is lost too!
We reverted back to the network settings to obtain ip address automatically, reset everything and I could see the Keyspan server
(with no devices connected)
we updated software and firmware and pinged the Keyspan on 192.168.0.10, Perfect.

When we reverted back to what I need, fixed IP addresses then nothing!
He too is lost!
0
 
adamdrayerCommented:
I'm not sure I am understanding the IP addressign scheme.  When you say "obtain IP address automatically", what type of IPs are you getting.  What subnet masks are you using?
0
 
adamdrayerCommented:
ok.  Back yesterday, you were able to set your workstation to "obtain ip address automatically", and then you could access the configuration of the USB server, correct?  that means that there is no problem with the cabling and switch.  What was the IP range it was assigning?  ok, then you set the USB server to use 192.168.0.10, and changed the workstation back to a static IP as well of 192.168.0.x, right?  what were the subnets that you staticly entered?  Now, you say you can ping 192.168.0.10.  if so, please post a tracert 192.168.0.10.

How are you sure that windows firewall is not working?  or any other firewall application?
0
 
MuskettAuthor Commented:
Sorry trying to do 100 things at the same time.
OK,
My local network is set up to connect 3 PC's via a switch and the switch connects to a router for internet access.
All components have a fixed IP address
Router 192.168.0.1
Working down the TCP IP properties window:
Use the following IP addresses box is checked
PC1 is 192.168.0.2, subnet mask is 255.255.255.0, default gateway is 192.168.0.1
PC and 3 are the next numbers.

Next part:
Use the following DNS server addresses (This is my ISP)
212.51.xx.xx
212.51.xx.xx

When I mean auto the "obtain IP addresses automatically" box is checked and also "Obtain DNS server addresses automatically" is checked
However, I cannot connect to my other computers or the internet with this automatic option.
0
 
adamdrayerCommented:
So you can connect to the server when you set them both to "obtain IP address automatically" but not when you set them both staticly to 192.168.0.x with a subnet mask of 255.255.255.0, right?  We're getting closer if that is the case.  On the PC, type "route print" and post results if you can.
0
 
MuskettAuthor Commented:
Tracert 192.168.0.10
Tracing route to 192.168.0.10 over a maximum of 30 hops
1 <1 ms <1 ms <1 ms 192.168.0.10
Trace complete
0
 
MuskettAuthor Commented:
Pity I cannot paste a screen dump!
Network Destination
0.0.0.0
127.0.0.0
192.168.0.0
192.168.0.2
224.0.0.0
255.255.255.255

Netmask
0.0.0.0
255.0.0.0
255.255.255.0
255.255.255.255
240.0.0.0
192.168.0.1

Gateway
192.168.0.1
127.0.0.1
192.168.0.2
127.0.0.1
192.168.0.2
192.168.0.2
192.168.0.2

Interface
192.168.0.2
127.0.0.1
192.168.0.2
127.0.0.1
192.168.0.2
192.168.0.2
192.168.0.2

Metric
20
1
20
20
20
20
1
0
 
adamdrayerCommented:
ok, just a few more tests.  Now remove the usb server from the network and try to ping 192.168.0.10.

Next tell me thte make and model of the switch
0
 
MuskettAuthor Commented:
Sorry missed default gateway 192.168.0.1
0
 
MuskettAuthor Commented:
Strange but I can ping 192.168.0.10 with the cable removed?

Switch model soon, need to screw it off the wall, do you reall need it?
0
 
adamdrayerCommented:
nah...  that's ok.  Haha!  that's what I thought.  192.168.0.10 may be used by something else.  Try something high like 192.168.0.188
0
 
adamdrayerCommented:
and also, to let you know... you can redirect any dos program that outputs to the screen into a file.  then you can post the file.

For example:  
route print > routes.txt

if you were to type that you wouldn't see anything on the screen but it would have created a file called routes.txt that you can paste into the forum
0
 
MuskettAuthor Commented:
Nope!
Changed the Keyspan to 192.168.0.188 and then reverted back to fixed IP.
Nothing.
Also, I cannot ping that address.

Are we looking at dead hardare?
0
 
MuskettAuthor Commented:
Also I note that there are some options on the config menu, keyspan console:

Network settings:
Default
DHCP
Manual
Using zero config

I have been using manual.
0
 
adamdrayerCommented:
ok, so you are not able to ping the usb server now.  That would make sense.  So now the USB server is configured for 192.168.0.188 and the computer is 192.168.0.2, right?  ok, now try a "arp -ap" again.
0
 
MuskettAuthor Commented:
Interface: 192.168.0.2 --- 0x2
  Internet Address      Physical Address      Type
  192.168.0.1           00-07-0e-05-9e-b4     dynamic  
  192.168.0.4           00-0c-6e-34-21-8d     dynamic  
I guess you mean arp -a
0
 
adamdrayerCommented:
Are all of these devices plugged into the same switch?  can you ping 192.168.0.10 now?
0
 
MuskettAuthor Commented:
Yes the switch has 192.168.0.2
192.162.0.4

and the Keyspan

Ping results:
Pinging 192.168.0.10 with 32 bytes of data:
Reply from 192.168.0.10: bytes=32 time<1ms TTL=127
Reply from 192.168.0.10: bytes=32 time<1ms TTL=127
Reply from 192.168.0.10: bytes=32 time<1ms TTL=127
Reply from 192.168.0.10: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.0.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

And for 192.168.0.188
Timeout.
0
 
adamdrayerCommented:
are we sure that the keyspan responds to pings?  Does the switch port have leds?  does it show link and network activity?  can you log into the switch?  does it have a configuration page?  How did you leave it off with the company?
0
 
adamdrayerCommented:
one more time i want to verify that if you return the USB server to "obtain IP address automatically" and also do the same with the computer, then you can see and ping back and forth.  Sorry for the redundancy but I still don't know if you can do that, and I still don't know what IP addresses you are being issued when you do this.
0
 
MuskettAuthor Commented:
No I am not sure, I was when we had it set to 192xxxx10 but now it does not with 192xxxx188.
No the switch does not have a config page, it is plug in and forget it.
It is made by an outfit called Edimax.
Yes the contact and 100m LEDs both react to removing / inserting the ethernet cable to the Keyspan.

OK I have done a few tests.
I have connected the Keyspan direct to my portable, no switch, router, nothing.
I set the network connections to dynamic.
I can assess the Keyspan and it shows its address 192.168.0.188 as we set up earlier.

I can  not ping 192.168.0.188
FYI I have just realised that 192.168.0.10 is the wireless access point so you were correct I was conflicting.
I have changed the keyspan to 192.168.0.40 as I am sure that is not in use.

Have a think because in here in Eurpe its getting late.
Thanks and talk tomorrow.
Dave
0
 
MuskettAuthor Commented:
To anwser you question. The Keyspan retains whatever IP we set, was 192.168.0.10 (the conflict) changed to 192.168.0.188 and now
192.168.0.40.
There is no way to ping from the Keyspan
Even when I can ping with the the PC network set  to "obtain IP address automatically" I cannot ping the keyspan.
Sorry for the confusion but that was caused by the error with 192xxxx10 I was thinking that was keyspan.

To conclude, I have NEVER been able to ping or see the Keyspan on arp -a.
But with the PC network set  to "obtain IP address automatically" the Keyspan console sees the Keyspan server.
Sorry for the confusion.
0
 
MuskettAuthor Commented:
I have fixed it!!!!
I am going to award the points to adamdrayer on the basis that he was incredibly helpful and patient. During the whole phase of getting the
Keyspan to work he worked tirelessly to help me.
That is the spirit of Experts-exchange.
I also learned a lot on the way so a big thank you to adamdrayer and everyone else who tried to fix my problem.
How did I do it?

In the end it was simple, In the TCIP advanced settings there is an option to enable netbios over tcp/ip under wins.
I am not 100% clear why it works but it does. Perhaps adamdrayer can explain?

I am going to write to Keyspan and tell them that their manual must be updated to cover network connections. In that respect, the
manual is terrible.

Thanks again
0
 
adamdrayerCommented:
Thank you really.  You didn't have to award me everything as I could not fix the problem, but thank you.

Read this: (it's really dry so I'll try and explain below)

NetBIOS over TCP/IP and WINS
http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q119/4/93.asp&NoWebContent=1


well it kinda makes sense that this is what the problem was.  I apologize for not realizing it before.  You could only see the server when you "obtain IP address automatically" so I should have realized it was something that DHCP sets other than the IP address, Subnet, Gateway, and DNS/WINS servers.  Just never occurred to me.

Most times in domains there are DNS servers, and they are the preferred method of resolving names to IP addresses.  When this is not the case, and you need to "browse" other computers, you must enable NetBIOS over TCP/IP (NBT) so that the computer first tries to resolve names by using WINS (if there is a WINS server specified), and then tries broadcasting.  This is hold "Network Neighborhood" works when there is no WINS server.  What I am surprised about is... if the server wanted to use NetBIOS broadcasts, you should have seen it in the "arp -a" commands.... but wait, did we not try that again since the IP address conflict?

Well if this doesn't answer all your questions, then please ask more in this thread as I feel guitly for getting all 2000 points.  I must say however that tech support should have known this, as this is something that must come up all the time.

Thanks again
0
 
MuskettAuthor Commented:
You are most welcome, I apreciate you help and education!
To answer your q?
Keyspan tech support to be honest were fumbling!
Regarding arp -a
Than is strange (to me)
We did arp -a after you found the conflict and did not find 192.168.0.40.

I have just done it and did not find either xxx40 or xxx10 (the wireless access point) so I pinged both and then re-ran arp -a and then they both
apeared.
I guess there must be a good reason?

Anyway, having set up the Keyspan thanks to you guidance I can report that it works fine.
I can connect my Epson colour Laser 700, Epson photo 915 and HP 3620 scanner and all work fine.
Needs some experimenting to get it working smoothly but a clever device that I am sure will fine a strong market.
Just wish the manual adressed setup and did not assume that everyone has auto setting on their network, most do not!
0
 
GriobthaCommented:
Crissand provided the proper solution:

                [crissand]            “With arp you give the server a fixed address:
                                                “On a station type:
                                                “arp –s 192.168.0.10 006001012a3a…”

                [Muskett]           “Thanks for that but surely I do not need to do that as I can ping 192.168.0.1 [different hardware than server]…”

Muskett then goes on to state that he fixed the problem himself, but doesn’t really have an explanation for how it happened, and awards points to AdamDrayer.

SOMETIMES, pinging will succeed and the device/address is placed in the ARP cache, but SOMETIMES NOT.  This is almost pure happenstance.  And SOMETIMES, even when the ping has succeeded and the ARP cache lists the dynamic device address, client-side server software STILL cannot find the device.  What's more, the ARP cache is valid only so long as the TCP/IP protocol is active in the stack (and not reset) -- so every time the system is rebooted or TCP/IP is has to be "repaired", connections are dynamic again and "ARP -a" will only report those connections that have been registered again in the cache.  An unmapped (strictly dynamic) ARP cache rarely has all connections recorded.

While network implementations in client OS’s are sophisticated, very often the client needs an ARP static statement (or batch file) to be run when the client system starts in order to keep network devices positively identified (Who here thinks computers cannot get confused?).  I have had the same problem as Muskett with Keyspan, Cisco, and other devices (and from reviewing, several people have had this problem with the Keyspan USB device server), and the solution has always been the “arp –s” static ip statement, and implementing the command[s] in a startup batch file automates the process.  This is true for Linux as well as Windows, and it is true whether the server software on the client is proprietary, such as the Keyspan client-side server software, or using OS add-ins, such as the Windows Network Client.

Whether Muskett used the ARP static command or let the system hiccup and correct itself matters.  Others looking for solutions may not be so lucky as to have their systems unglitch at the proper time and may not get a working solution, unless they utilize the proper tool… the "ARP –s" command.  Keyspan support and documentation is notably ignorant in this regard, but searching for similar problems with other manufacturers will turn up this answer, and, some IT departments have published manuals detailing this hidden/missing/non-pinging (whatever) device problem, and the solution of utilizing the "ARP -s" static address command line[s] added to a batch file and run on startup.

As for proper formatting of the command, Muskett was using Windows, so the command needs to have the dashes breaking up the MAC address (00-60-01-01-2A-3A).  One could type "ARP -s 192.168.0.10   00-60-01-01-2A-3A" (sans quotes)(or whatever IP address & MAC address is applicable) into Notepad (or any text editor saving UNformatted text files), saving the file as xxxx.BAT (ArpSet.bat for instance) in the system directory, and placing a link/shortcut to this file in the Startup folder (Windows).  Additional lines could be added for router/gateway, other clients, etc...  If, for "repair" or other reasons, one needs to re-implement the "ARP -s" command[s] without rebooting, a Scheduled Task can be set up to periodically run the batch file.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 28
  • 19
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now