How to restrict a user to see only 1 database?


We have an MS SQL server with different users. But when a user enters the enterprise manager then he can see the whole list of all databases created on that SQL server. That's not really the problem because he has only access to see the content of his database. But we have allready more then 40 databases on the SQL server and it takes up to 10 minutes to load that list. If the user only could see his database that it would reduce the load.

Can somebody advice me?

Who is Participating?
billy21Connect With a Mentor Commented:
>Select 'Remove SQL Server Registration

Sorry that should be 'Delete SQL Server Registration'
For each database
Right click on the database
Select 'Remove SQL Server Registration
solution46Connect With a Mentor Commented:
Hmmm.. that would work if the problem was multiple servers, but I don't think it will work with multiple databases.

I dont think you can limit the list of databases on a server in Enterprise Manager (at least I've not found a way to do this).

So far as I can tell, you have two options...

1. Use EM but only open once at the beginning of the day...
2. Be a man - use Query Analyser!!! :)

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

AS long as each user has their own copy of enterprise manager installed it will work.  You can set up your own list.  Or are you saying we're looking at 1 server here and everybody shares the same instance of enterprise manager?
Appologies Solution46 is right.  I was looking at servers and thinking databases ;-)
ShogunWadeConnect With a Mentor Commented:
EM is limited in its functionality in this respect.     Generall EM's performance is pretty poor because it uses SQLDMO.  

Ultimately EM and QA are developer and administratite tools so the concept of "But when a user enters the enterprise manager ...."   shouldnt exist.

As for 10mins.   I would suggest that this is either down to an inordinately busy network, v slow client or severely underpowered server.
I wouldn't mind some of those points if they're being doled out. So far as I can tell we all said pretty much the same thing - don't do it!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.