Solved

Internet Access Not Working on 1 of 2 Subnets Behind PIX 501

Posted on 2004-09-13
20
888 Views
Last Modified: 2010-04-11
I'm having problem with accessing the Internet on one of two subnets behind a pix 501.

Here's the setup:

Subnet_A 192.168.1.0  ----------- Router_A 192.168.1.1 ----------
                                                                                             |
                                                                                              ---------- PIX501 192.168.1.2 ---------- INTERNET
                                                                                             |
Subnet_B 192.168.2.0  ----------- Router_B 192.168.2.1 -----------


Here's the situation:

- Subnet_A is working 100%.  All devices on the subnet can access the internal network (both subnets), and the Internet.
- Subnet_B is working 50%.  All devices can access only the internal network (both subnets).  It cannot access the Internet (not even ping).
- Devices from Subnet_B cannot ping nor access the PIX 501.
- Both routers are attached to the PIX 501's switch.

The PIX is probably not configured properly or I'm just missing something.  Here's the PIX current running config:

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxxxxxxx encrypted

passwd xxxxxxxxxx encrypted

hostname pixfirewall

domain-name xxxxxxxxxx.xxx

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

access-list inbound permit icmp any any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside xxx.xxx.xxx.200 255.255.255.128

ip address inside 192.168.1.2 255.255.0.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.0.0 255.255.0.0 inside

pdm location 192.168.2.0 255.255.255.0 inside

pdm location 192.168.1.5 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.199 netmask 255.255.255.128

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group inbound in interface outside

route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.129 1

route inside 192.168.1.0 255.255.255.0 192.168.1.1 2

route inside 192.168.2.0 255.255.255.0 192.168.1.1 2

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.0.0 255.255.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.3-192.168.1.254 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80




0
Comment
Question by:surbit
  • 10
  • 4
  • 3
  • +2
20 Comments
 
LVL 3

Assisted Solution

by:hehewithbrackets
hehewithbrackets earned 100 total points
ID: 12051795
These should be all you need to grant outside access:
global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.199 netmask 255.255.255.128
nat (inside) 1 0.0.0.0 0.0.0.0 0 0

I don't think you need the following 2 lines:
route inside 192.168.1.0 255.255.255.0 192.168.1.1 2
route inside 192.168.2.0 255.255.255.0 192.168.1.1 2
0
 

Author Comment

by:surbit
ID: 12051862
I removed those two lines.  Subnet_B still unable to access PIX501 and Internet.
0
 

Author Comment

by:surbit
ID: 12051886
Also, if I remove those two lines, workstations and servers on Subnet_A can ping Subnet_B, but the PIX cannot ping Subnet_B. So, I added those two lines back.
0
 
LVL 3

Assisted Solution

by:hehewithbrackets
hehewithbrackets earned 100 total points
ID: 12051893
Is the default gateway for Router B set to 192.168.1.2?  In the 2 route lines above you had them going to 192.168.1.1 which is Router A.

Also, did you restart the PIX after making the changes?  I noticed some changes don't seem to take effect until you have rebooted the PIX.
0
 

Author Comment

by:surbit
ID: 12052347
Thanks for the suggestion.  After looking at the network again, I just realized my diagram is not correct.  The diagram should look like this:

                        [PIX501 192.168.1.2] ---------- [INTERNET]
                                         |
                                    [Switch]
                                         |
[Subnet_A 192.168.1.0]  ----------- [Router_A 192.168.1.1] -----------
                                                                                                   |
                                                                                       (point-to-point t1)  
                                                                                                   |
[Subnet_B 192.168.2.0]  ----------- [Router_B 192.168.2.1] ------------


Router_A uses the PIX as the default gateway.  Router_B routes to Router_A.  Again, Subnet_B can access all the local servers and workstations in Subnet_A, but not the Internet nor the PIX.
0
 

Author Comment

by:surbit
ID: 12052393
I restarted the PIX already.  Still the same.

The routing table for Router_A shows:

          IP Address      Netmask                 Gateway            Port
 0       0.0.0.0            0.0.0.0                  192.168.100.1   ppp0
 1       127.0.0.1        255.255.255.255    127.0.0.1          local
 2       192.168.1.0     255.255.255.0       192.168.100.1   ppp0
 3       192.168.2.0     255.255.255.0       192.168.2.1       eth0
 4       192.168.2.1     255.255.255.255   192.168.2.1       local
 5       192.168.100.0  255.255.255.252  192.168.100.2    ppp0
 6       192.168.100.2  255.255.255.255  192.168.100.2    local
 7       224.0.0.9         255.255.255.255   224.0.0.9          local

This is Router_B's:

          IP Address        Netmask              Gateway            Port
 0       0.0.0.0             0.0.0.0                 192.168.100.1   ppp0
 1       127.0.0.1         255.255.255.255    127.0.0.1          local
 2       192.168.1.0      255.255.255.0       192.168.100.1   ppp0
 3       192.168.2.0      255.255.255.0       192.168.2.1      eth0
 4       192.168.2.1      255.255.255.255   192.168.2.1       local
 5       192.168.100.0   255.255.255.252   192.168.100.2   ppp0
 6       192.168.100.2   255.255.255.255   192.168.100.2   local
 7       224.0.0.9          255.255.255.255    224.0.0.9         local
0
 

Author Comment

by:surbit
ID: 12052445
Sorry, the routing table for Router_A is:

       IP Address        Netmask         Gateway      Port
 0       0.0.0.0         0.0.0.0       192.168.1.2    eth0
 1      127.0.0.1    255.255.255.255    127.0.0.1    local
 2     192.168.1.0    255.255.255.0    192.168.1.1    eth0
 3     192.168.1.1   255.255.255.255   192.168.1.1   local
 4     192.168.2.0    255.255.255.0   192.168.100.2   ppp0
 5    192.168.100.0  255.255.255.252  192.168.100.1   ppp0
 6    192.168.100.1  255.255.255.255  192.168.100.1  local
 7    209.88.29.124  255.255.255.254  209.88.29.124   fdl0
 8    209.88.29.124  255.255.255.255  209.88.29.124  local
 9      224.0.0.9    255.255.255.255    224.0.0.9    local
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 300 total points
ID: 12054361
PIX CONFIG
>ip address inside 192.168.1.2 255.255.0.0

You MUST change your interface subnet mask to 255.255.255.0

>route inside 192.168.1.0 255.255.255.0 192.168.1.1 2
You need to remove this route entry. You are routing your own local subnet to another router. Not a good idea.
0
 

Author Comment

by:surbit
ID: 12055769
Thank you lmoore.  I have made the above changes.  I'm still unable to connect to the Internet from Subnet_B.  When I removed the line to route, I'm no longer able to telnet into the firewall if I VPN into Subnet_A.  But if I can still telnet into the firewall from a computer in Subnet_A.  Subnet_B is still unable to reach the firewall.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 300 total points
ID: 12056059
Can you ping the PIX inside interface from subnet B?
If not, then you may have a routing issue..

Assuming that your 'routers' are Linux boxes?
Let's run down the requirements:

* Host on LAN B points default gateway to 192.168.2.1   <-- Eth0 interface of router - check??
* Rtr B's default gateway is 192.168.100.1  <-- point's to Rtr A - check
* Rtr A's default gateway is 192.168.1.2     <-- points to PIX inside - check
* PIX has route back to LANB:
    route inside 192.168.2.0 255.255.255.0 192.168.1.1 2 <-- this "2" should be a "1"
* PIX Inside interface has local lan subnet mask:
    ip address inside 192.168.1.2 255.255.255.0   <-- double-check ??
* PIX NAT (inside) rule includes 192.168.2.0 subnet
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0   <-- check
* No access-list applied to inside interface on PIX  <-- check
* Do you have enough addresses in global config: <-- maybe....
       global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.199 netmask 255.255.255.128
   only provides for total of 69 inside hosts. Host #70 will not get a global and will not get out
   suggest adding an overload address:
        global (outside) 1 xxx.xxx.xxx.200  <-- provide for PAT 'overload' for hosts #70 - whatever

Once everything checks out, there is nothing else on the PIX that will prevent access. Are you running firewall feature/ipchains on the LINUX router(s)?




 
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 1

Assisted Solution

by:Spankyxeon
Spankyxeon earned 100 total points
ID: 12056082
Three things I see

Change:
global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.199 netmask 255.255.255.128
To:
global (outside) 1 outside


This will free up public IPs to be used for translations in the future ie:mail server, web server, etc....

Change:
ip address inside 192.168.1.2 255.255.0.0
To:
ip address inside 192.168.1.2 255.255.255.0

Self explanitory....

Remove:
route inside 192.168.1.0 255.255.255.0 192.168.1.1 2

this is not needed since the 192.168.1.X network is on the pix already


Login to your pix and get into "enable" mode
COPY AND PASTE THE FOLLOWING COMMANDS BELOW INTO YOUR PIX AND HIT ENTER:::::::

config t
global (outside) 1 outside
ip address inside 192.168.1.2 255.255.255.0
no route inside 192.168.1.0 255.255.255.0 192.168.1.1 2
wr mem
reload
0
 

Author Comment

by:surbit
ID: 12057511
Okay guys, thanks for the above suggestions.  I'm very close.  Here's the new PIX configuration.  Would greatly appreciate any other suggestions.

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxx encrypted
passwd xxxxxx encrypted
hostname pixfirewall
domain-name xxxxxx.xxx
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list inbound permit icmp any any
access-list inbound permit tcp any any eq 8831
access-list inbound permit tcp any any eq 8832
access-list inside_outbound_nat0_acl permit ip any 192.168.1.240 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.240 255.255.255.240
access-list split-tunnel-acl permit ip 192.168.0.0 255.255.0.0 any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.200 255.255.255.128
ip address inside 192.168.1.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn-group 192.168.1.240-192.168.1.250
pdm location 192.168.0.0 255.255.0.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.198
global (outside) 1 xxx.xxx.xxx.199
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xxx.xxx.xxx.xxx 192.168.1.5 netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.129 1
route inside 192.168.2.0 255.255.255.0 192.168.1.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup initial-vpn address-pool vpn-group
vpngroup initial-vpn dns-server 192.168.1.100 4.2.2.1
vpngroup initial-vpn wins-server 192.168.1.100
vpngroup initial-vpn default-domain xxxxxx.xxx
vpngroup initial-vpn split-tunnel split-tunnel-acl
vpngroup initial-vpn idle-time 1800
vpngroup initial-vpn password ********
telnet 192.168.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.3-192.168.1.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
0
 

Author Comment

by:surbit
ID: 12057523
The routers are ADTRAN boxes.  Yes, there's voice and data going through the point-to-point T1.
0
 
LVL 1

Expert Comment

by:Spankyxeon
ID: 12057612
You now have TWO (global outside)

global (outside) 1 xxx.xxx.xxx.130-xxx.xxx.xxx.198
global (outside) 1 xxx.xxx.xxx.199

you just confussed it on how to get outside

change it to
global (outside) 1 outside
0
 
LVL 1

Expert Comment

by:Spankyxeon
ID: 12057793
" I'm very close.  Here's the new PIX configuration.  Would greatly appreciate any other suggestions"

What do you mean you are close? Did you get out to the net? What more would you like to know?
0
 

Author Comment

by:surbit
ID: 12058002
But as lrmoore said, wouldn't the first global assign clients the IPs 130 thru 198, and then subsequent clients rollover to 199?  This config is working fine for another PIX.

I think I'm getting close.  I have to physically go to Subnet_B, which is in another building.  I think someone misconfigured some wires.  I will make sure there are no wiring problems and then try to access the Internet from Subnet_ B again.  As of now, I am able to do everything in Subnet_A.  But I cannot access the firewall nor the Internet from Subnet_B.  From Subnet_B, I am only able to access workstations and servers in Subnet_A.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12058825
surbit and Spankyxeon...

Yes, you CAN have two global (outside) commands. This is how the PIX was designed, and works exactly as surbit understands. The 2nd global is a "overload" PAT address that is used once the pool is depleted.

Spakyxeon, we appreciate the help, but I had already advised surbit to do the exact things that you posted.

As long as the Adtrans are routing properly and not doing NAT/Firewalling, then you should be good to go. There is nothing else in the <new> PIX config that would prevent LANB from going out on the Internet.

0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 12059939
You have three (or four!) internal subnets, but only two internal subnet ranges.  You have routers with two (or three!) interfaces, but only one address shown.  No wonder it doesn't work!

Router B needs two addresses, one on it's clients' LAN and one on the outside connection which, depending which diagram we believe, goes either to the PIX or to router A.

The inside address of the PIX cannot be on the client range for router A.  It needs to be on a different range, used for a different port on router A, which may or may not be the same port as router B connects to.

Router A needs at least two addresses, one for the space where its clients are, and one for its link to the PIX.  If it connects to router B on a third (serial) interface, that needs its own, too.

0
 

Author Comment

by:surbit
ID: 12060170
Hi guys,

The key to why lrmoore got most of the points is because he gave me assurance that the PIX configuration should work.  That allowed me to full-heartedly inspect the physical network and catch the culprit, and not waste my time with any more configuration.

But I would take everyone out to lunch if I could since help is so invaluable at times.  The points don't give enough dues!

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12060219
So, what was the final analysis of what was broken?
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Let’s list some of the technologies that enable smooth teleworking. 
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now