Solved

Problems With point to point Frames

Posted on 2004-09-14
7
266 Views
Last Modified: 2010-04-17
I'm trying to reconfigure one end of a point to point frame.  I have one main office that has a T1 for internet, and then has two frames from remote offices coming into it.  One of the remote offices is working fine.  The other had been down for a while, we've just recently reactivated the line and installed a new Cisco 1720.  Other than changing the ips I've pretty much copied the config from the other remote office, but am unable to figure out why this isn't working.  Admittedly I am an amateur Cisco User at best.  Below are my configs.  the Hst Turnpike is the main office.  378_Page is the working remote.  421_page is the new remote.

sho run
Building configuration...

Current configuration : 3407 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 1063_Turnpike
!
logging buffered 4096 debugging
logging rate-limit console 10 except errors
enable password 7 04590A0806
!
memory-size iomem 25
ip subnet-zero
no ip finger
no ip domain-lookup
ip name-server 141.154.0.68
ip name-server 141.155.0.68
!
!
 --More--         !
!
interface FastEthernet0
 description connected to STD 1063 Turnpike LAN
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 service-module t1 timeslots 1-6
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description connected to 421_PageSt
 ip address 192.168.10.1 255.255.255.252
 ip nat inside
 frame-relay interface-dlci 17  
!
interface Serial0.2 point-to-point
 --More--          description connected to 378_PageSt
 ip address 192.168.10.5 255.255.255.252
 ip nat inside
 frame-relay interface-dlci 18  
!
interface Serial0.3 point-to-point
 description connected to Internet
 ip address 141.154.41.106 255.255.255.252
 ip nat outside
 frame-relay interface-dlci 100  
!
router eigrp 100
 passive-interface Serial0.1
 network 141.154.0.0
 network 192.168.10.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router rip
 version 2
 passive-interface Serial0.3
 network 10.0.0.0
 network 192.168.100.0
 --More--          no auto-summary
!
ip nat pool Turnpike 141.154.193.226 141.154.193.254 netmask 255.255.255.224
ip nat inside source list 1 pool Turnpike overload
ip nat inside source static 10.10.10.1 141.154.193.225
ip nat inside source static 141.154.193.33 141.154.193.33
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0.3
ip route 10.10.20.0 255.255.255.0 Serial0.1
ip route 10.10.30.0 255.255.255.0 Serial0.2
no ip http server
!
access-list 1 permit 141.154.193.32 0.0.0.31
access-list 1 permit 192.168.10.0 0.0.0.3
access-list 1 permit 192.168.10.4 0.0.0.3
access-list 1 permit 192.168.100.0 0.0.0.255
access-list 1 permit 192.168.200.0 0.0.0.255
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 1 permit 10.10.30.0 0.0.0.255
snmp-server community public RO

!
line con 0
 exec-timeout 0 0
 password 7 110A1016141D
 login
 transport input none
line aux 0
 password 7 0111070A52
 login
line vty 0 4
 --More--          password 7 14141B180F0B
 login
!
end
----------------------------------------------------------------------------------------------------------------------------------------------
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 378_Page
!
logging buffered 4096 debugging
logging rate-limit console 10 except errors
enable password cisco
!
memory-size iomem 25
ip subnet-zero
no ip finger
ip name-server 141.154.0.68
ip name-server 141.155.0.68
!
ip audit notify log
ip audit po max-events 100
 --More--         !
!
!
interface FastEthernet0
 description connected to EthernetLAN_2
 ip address 10.10.30.1 255.255.255.0
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 service-module t1 timeslots 1-6
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description connected to Turnpike
 ip address 192.168.10.10 255.255.255.252
 frame-relay interface-dlci 16  
!
router rip
 version 2
 --More--          network 10.0.0.0
 network 192.168.10.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 serial0.1
no ip http server
!
snmp-server community public RO

line con 0
 exec-timeout 0 0
 password cisco
 login
 transport input none
line aux 0
 password *****
 login
line vty 0 4
 password *****
 login
-------------------------------------------------------------------------------------------------------------------------------------------
show run
Building configuration...

Current configuration : 2940 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 421_Page
!
logging buffered 4096 debugging
logging rate-limit console 10 except errors
enable password cisco
!
memory-size iomem 25
ip subnet-zero
no ip finger
ip name-server 141.154.0.68
ip name-server 141.155.0.68
!
ip audit notify log
ip audit po max-events 100
 --More--         !
!
!
interface FastEthernet0
 description connected to EthernetLAN_2
 ip address 10.10.20.1 255.255.255.0
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 service-module t1 timeslots 1-6
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description connected to Turnpike
 ip address 192.168.10.6 255.255.255.252
 frame-relay interface-dlci 19  
!
router rip
 version 2
 --More--          network 10.0.0.0
 network 192.168.100.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 serial0.1
no ip http server
!
snmp-server community public RO
line con 0
 exec-timeout 0 0
 password cisco
 login
 transport input none
line aux 0
 password ****
 login
line vty 0 4
 password cisco
 login
---------------------------------------------------------------------------------------------------------------------------------------------

Thanks for any help you can give me.

0
Comment
Question by:hindsight
  • 3
  • 3
7 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 12060019
You have conflicting IP subnets assigned to the frame sub-interfaces:

Turnpike:
interface Serial0.1 point-to-point
 description connected to 421_PageSt
 ip address 192.168.10.1 255.255.255.252

421_Page:
interface Serial0.1 point-to-point
 description connected to Turnpike
 ip address 192.168.10.6 255.255.255.252  <-- this should be 192.168.10.2 to match the Turnpike end
 frame-relay interface-dlci 19  

421_Page needs the RIP config tweaked:

>router rip
 version 2
 network 10.0.0.0
 network 192.168.100.0
 no auto-summary

SHOULD BE:
   router rip
     version 2
     network 192.168.10.0  <== .10.0 vs .100.0 - one extra zero in the current config
     network 10.0.0.0
     no auto-summary

Can you paste results (from Turnpike)
sho frame-relay pvc
sho ip route

Can you access 421_Page and paste results of:
sho frame-relay pvc
sho interface serial 0/0
sho ip route
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 12060185
> interface Serial0.1 point-to-point
>  description connected to 421_PageSt
>  ip address 192.168.10.1 255.255.255.252
>  ip nat inside
>  frame-relay interface-dlci 17  
> !
> interface Serial0.2 point-to-point
>  description connected to 378_PageSt
>  ip address 192.168.10.5 255.255.255.252
>  ip nat inside
>  frame-relay interface-dlci 18  
> !

According to these addresses and masks, the router at 421 Page St should have the address 192.168.10.2 and 378 Page St should be 192.168.10.6.  But the actual configs show them as 192.168.10.6 and .10 respectively, and that can't work.

0
 
LVL 1

Author Comment

by:hindsight
ID: 12083958
lrmoore,

Ok.  I changed the subnet on the 421 side to 192.168.20.x.  Made s0.1 at Turnpike 192.168.20.10. Made S0.1 at 421_Page 192.168.20.2.  Changed the Router Rip as you suggested (removed the extra 0) also now added an entry:

Network 192.168.20.0

Since I changed the other subnet.  Still can't ping back and forth here are the results you asked for from Turnpike St.  I will post the other ones in about an hour when I can get over to 421.
-------------------------------------------------------------------------------------------------

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 307           output pkts 3938         in bytes 21525    
  out bytes 1292292        dropped pkts 0           in FECN pkts 0        
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        
  in DE pkts 0             out DE pkts 0        
  out bcast pkts 3924      out bcast bytes 1290996  
  pvc create time 3d23h, last time pvc status changed 11:57:26
 --More--         
DLCI = 18, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.2

  input pkts 766042        output pkts 777377       in bytes 386486435
  out bytes 331056834      dropped pkts 0           in FECN pkts 258      
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        
  in DE pkts 97256         out DE pkts 0        
  out bcast pkts 80012     out bcast bytes 6638728  
  pvc create time 3d23h, last time pvc status changed 3d23h
 --More--         
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.3

  input pkts 18406523      output pkts 18258138     in bytes 1888840219
  out bytes 1187511678     dropped pkts 0           in FECN pkts 127      
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0        
  in DE pkts 3422485       out DE pkts 0        
  out bcast pkts 80031     out bcast bytes 6639904  
  pvc create time 3d23h, last time pvc status changed 3d23h
1063_Turnpike#  so ip route
               ^
% Invalid input detected at '^' marker.

1063_Turnpike#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     141.154.0.0/30 is subnetted, 1 subnets
C       141.154.41.104 is directly connected, Serial0.3
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.4 is directly connected, Serial0.2
C    192.168.20.0/24 is directly connected, Serial0.1
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.10.0 is directly connected, FastEthernet0
S       10.10.20.0 is directly connected, Serial0.1
S       10.10.30.0 is directly connected, Serial0.2
S*   0.0.0.0/0 is directly connected, Serial0.3
1063_Turnpike#
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 79

Expert Comment

by:lrmoore
ID: 12084144
>DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1
  input pkts 307           output pkts 3938         in bytes 21525    

Looks like good Layer 2 communications, just  no layer 3 yet. As soon as you change the IP address on Serial port on the 421 side, you might be in business.

0
 
LVL 1

Author Comment

by:hindsight
ID: 12084412
Ok.  Still can't ping the Turnpike St Router, either from the 421_router or any host at 421.  I've captured the new config from 421 as well as the results you asked for.

isho run
Building configuration...

Current configuration : 3009 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 378_Page
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$.K0d$KfoVkiQqzS.ysNwI7y3Lz.
enable password cisco
!
memory-size iomem 25
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
 --More--         ip subnet-zero
no ip routing
no ip cef
!
!
!
ip name-server 141.154.0.68
ip name-server 141.155.0.68
no ftp-server write-enable
!
!
!
!
interface FastEthernet0
 description connected to EthernetLAN_2
 ip address 10.10.20.1 255.255.255.0
 no ip route-cache
 speed auto
 half-duplex
!
interface Serial0
 no ip address
 encapsulation frame-relay
 --More--          no ip route-cache
 no fair-queue
 service-module t1 timeslots 1-6
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description connected to Turnpike
 ip address 192.168.20.2 255.255.255.0
 no ip route-cache
 frame-relay interface-dlci 19  
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0.1
no ip http server
!
snmp-server community public RO
snmp-server enable traps tty
banner exec ^CCCCCCCCC
 ***************************************************************************
 *                           STD Manufacturing                             *
 *                                                                         *
 * WARNING:                                                                *
 --More--          *          THIS SYSTEM IS FOR THE USE OF AUTHORIZED CLIENTS ONLY!         *
 *          INDIVIDUALS USING THE COMPUTER NETWORK SYSTEM WITHOUT          *
 *          AUTHORIZATION, OR IN EXCESS OF THEIR AUTHORIZATION, ARE        *
 *          SUBJECT TO HAVING ALL THEIR ACTIVITY ON THIS COMPUTER          *
 *          NETWORK SYSTEM MONITORED AND RECORDED BY SYSTEM                *
 *          PERSONNEL.   TO PROTECT THE COMPUTER NETWORK SYSTEM            *
 *          FROM UNAUTHORIZED USE AND TO ENSURE THE COMPUTER NETWORK       *
 *          SYSTEMS IS FUNCTIONING PROPERLY, SYSTEM ADMINISTRATORS         *
 *          MONITOR THIS SYSTEM.   ANYONE USING THIS COMPUTER NETWORK      *
 *          MONITOR THIS SYSTEM.   ANYONE USING THIS

COMPUTER NETWORK      *
 *          THAT IF SUCH MONITORING REVEALS POSSIBLE CONDUCT OF            *
 *          CRIMINAL ACTIVITY, SYSTEM PERSONNEL MAY PROVIDE THE            *
 *          EVIDENCE OF SUCH ACTIVITY TO LAW ENFORCEMENT OFFICERS.         *
 *                                                                         *
 *          ACCESS IS RESTRICTED TO AUTHORIZED USERS ONLY!                 *
 *          UNAUTHORIZED ACCESS IS A VIOLATION OF STATE AND FEDERAL,       *
 *          CIVIL AND CRIMINAL LAWS.                                       *
 ***************************************************************************
^C
!
line con 0
 --More--          exec-timeout 0 0
 password cisco
 login
line aux 0
 password bani
 login
line vty 0 4
 password cisco
 login
!
!
end

378_Page#sho frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            0            1            0
  Switched       0            0            0            0
  Unused         1            0            0            0

DLCI = 16, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0

  input pkts 4062          output pkts 0            in bytes 1306611  
  out bytes 0              dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  switched pkts 0        
  Detailed packet drop counters:
  no out intf 0            out intf down 0          no out PVC 0        
  in PVC down 0            out PVC down 0           pkt too big 0        
  shaping Q full 0         pkt above DE 0           policing drop 0        
 --More--           pvc create time 2d17h, last time pvc status changed 12:42:22
 --More--         
DLCI = 19, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0.1

  input pkts 0             output pkts 19           in bytes 0        
  out bytes 3129           dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 19        out bcast bytes 3129      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 2d17h, last time pvc status changed 12:43:23
378_Page#sho interface serial 0/0
                               ^
% Invalid input detected at '^' marker.

378_Page#sho interface serial 0/0  
Serial0 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  MTU 1500 bytes, BW 384 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  23779, LMI stat recvd 23779, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 323/0, interface broadcasts 284
  Last input 00:00:05, output 00:00:06, output hang never
  Last clearing of "show interface" counters 2d18h
  Input queue: 0/75/1/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     27873 packets input, 1669637 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 3 giants, 0 throttles
     107 input errors, 16 CRC, 28 frame, 0 overrun, 0 ignored, 63 abort
     24102 packets output, 356573 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
 --More--              5 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

378_Page#sho ri  ip route
Default gateway is not set

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty
378_Page#

I'm at a loss now.  Changed this thing so many times I'm not even sure how screwed up I am.  I appreciate all of your help, thanks.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12085016
Looks like this is the problem:
>DLCI = 16, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0

interface Serial0.1 point-to-point
 description connected to Turnpike
 ip address 192.168.20.2 255.255.255.0
 no ip route-cache
 frame-relay interface-dlci 19   <== this should be dlci 16

router(config)#interface serial 0.1
router(config-if)#no frame-relay interface-dlci 19
router(config-if)#frame-relay interfac-dlci 16

done

0
 
LVL 1

Author Comment

by:hindsight
ID: 12087614
Awesome, reset that, added the new subnets to my access lists, and got rid of the no ip routing line and I was in business, thanks you are a lifesaver.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now